add btsco, btsco-module: closes #586
authorPhilipp Zabel <philipp.zabel@gmail.com>
Fri, 13 Jan 2006 00:01:31 +0000 (00:01 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Fri, 13 Jan 2006 00:01:31 +0000 (00:01 +0000)
packages/btsco/.mtn2git_empty [new file with mode: 0644]
packages/btsco/btsco-module-0.41/.mtn2git_empty [new file with mode: 0644]
packages/btsco/btsco-module-0.41/makefile.patch [new file with mode: 0644]
packages/btsco/btsco-module_0.41.bb [new file with mode: 0644]
packages/btsco/btsco_0.41.bb [new file with mode: 0644]

diff --git a/packages/btsco/.mtn2git_empty b/packages/btsco/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/btsco/btsco-module-0.41/.mtn2git_empty b/packages/btsco/btsco-module-0.41/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/btsco/btsco-module-0.41/makefile.patch b/packages/btsco/btsco-module-0.41/makefile.patch
new file mode 100644 (file)
index 0000000..cf57b59
--- /dev/null
@@ -0,0 +1,16 @@
+--- btsco-0.41/kernel/Makefile.orig    2006-01-13 00:32:58.000000000 +0100
++++ btsco-0.41/kernel/Makefile 2006-01-13 00:33:35.000000000 +0100
+@@ -10,10 +10,10 @@
+ default:
+-      @make -C /lib/modules/`uname -r`/build M=`pwd` modules
++      $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules
+ install:
+-      @make -C /lib/modules/`uname -r`/build M=`pwd` modules_install
++      $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules_install
+ clean:
+-      @make -C /lib/modules/`uname -r`/build M=`pwd` clean
++      $(MAKE) -C $(KERNEL_SRC) M=`pwd` clean
diff --git a/packages/btsco/btsco-module_0.41.bb b/packages/btsco/btsco-module_0.41.bb
new file mode 100644 (file)
index 0000000..c4997cf
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Bluetooth-alsa headset module"
+SECTION = "kernel/modules"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib bluez-libs"
+
+inherit module
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-0.41.tar.gz \
+          file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/btsco-${PV}/kernel"
+
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
+
+do_install() {
+       install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+       install -m 0644 ${S}/snd-bt-sco${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+}
diff --git a/packages/btsco/btsco_0.41.bb b/packages/btsco/btsco_0.41.bb
new file mode 100644 (file)
index 0000000..dae5877
--- /dev/null
@@ -0,0 +1,11 @@
+DESCRIPTION = "Bluetooth-alsa headset tool"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+MAINTAINER = "Robert Woerle <robert@linuxdevelopment.de>"
+DEPENDS = "alsa-lib bluez-libs"
+
+inherit autotools pkgconfig
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-0.41.tar.gz"
+
+S = "${WORKDIR}/${PN}-${PV}"