gnome-games: brute-force sed to fix -I/usr/include
authorKoen Kooi <koen@openembedded.org>
Sun, 21 Sep 2008 18:14:02 +0000 (18:14 +0000)
committerKoen Kooi <koen@openembedded.org>
Sun, 21 Sep 2008 18:14:02 +0000 (18:14 +0000)
packages/gnome/gnome-games_2.23.6.bb

index b312382..6fb4dd7 100644 (file)
@@ -1,7 +1,7 @@
 LICENSE = "GPL"
 DEPENDS = "libggz ggz-client-libs python-pygtk gtk+ libgnome libgnomeui librsvg gnome-vfs gconf libglade gnome-common gnome-python-desktop"
 
-PR = "r1"
+PR = "r2"
 
 inherit gnome distutils-base gconf
 
@@ -19,6 +19,11 @@ do_configure_prepend() {
        done
 }
 
+do_configure_prepend() {
+       for i in $(find ${S} -name "Makefile") ; do
+               sed -i -e s:'-I /usr/include -I /usr/local/include'::g $i
+       done    
+}
 
 FILES_${PN}-doc += " ${datadir}/gnome/help"
 FILES_${PN}-dbg += " ${bindir}/.debug ${libdir}/gnome-games/.debug"