guile 1.6.4 add patch for building with gcc4. reorder and enhance metadata
authorMichael Lauer <mickey@vanille-media.de>
Sun, 2 Jul 2006 13:50:18 +0000 (13:50 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sun, 2 Jul 2006 13:50:18 +0000 (13:50 +0000)
packages/guile/configure-lossage.patch [deleted file]
packages/guile/files/.mtn2git_empty [new file with mode: 0644]
packages/guile/files/configure-lossage.patch [new file with mode: 0644]
packages/guile/files/gcc4.patch [new file with mode: 0644]
packages/guile/guile_1.6.4.bb

diff --git a/packages/guile/configure-lossage.patch b/packages/guile/configure-lossage.patch
deleted file mode 100644 (file)
index da1d0de..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- guile-1.6.4/configure.in~configure-lossage
-+++ guile-1.6.4/configure.in
-@@ -462,7 +462,9 @@
- # explicitly to LIBOBJS to make sure that it is translated to
- # `alloca.lo' for libtool later on.  This can and should be done more cleanly.
- AC_FUNC_ALLOCA
--if test "$ALLOCA" = "alloca.o"; then AC_LIBOBJ([alloca]); fi
-+if test "$ALLOCA" = "alloca.o"; then 
-+   AC_LIBOBJ([alloca])
-+fi
- AC_CHECK_MEMBERS([struct stat.st_rdev])
- AC_CHECK_MEMBERS([struct stat.st_blksize])
---- guile-1.6.4/guile-readline/configure.in~configure-lossage
-+++ guile-1.6.4/guile-readline/configure.in
-@@ -2,6 +2,7 @@
- AC_INIT
- AC_CONFIG_SRCDIR([readline.c])
-+AC_CONFIG_AUX_DIR([..])
- . $srcdir/../GUILE-VERSION
- PACKAGE=guile-readline
- AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
diff --git a/packages/guile/files/.mtn2git_empty b/packages/guile/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/guile/files/configure-lossage.patch b/packages/guile/files/configure-lossage.patch
new file mode 100644 (file)
index 0000000..da1d0de
--- /dev/null
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- guile-1.6.4/configure.in~configure-lossage
++++ guile-1.6.4/configure.in
+@@ -462,7 +462,9 @@
+ # explicitly to LIBOBJS to make sure that it is translated to
+ # `alloca.lo' for libtool later on.  This can and should be done more cleanly.
+ AC_FUNC_ALLOCA
+-if test "$ALLOCA" = "alloca.o"; then AC_LIBOBJ([alloca]); fi
++if test "$ALLOCA" = "alloca.o"; then 
++   AC_LIBOBJ([alloca])
++fi
+ AC_CHECK_MEMBERS([struct stat.st_rdev])
+ AC_CHECK_MEMBERS([struct stat.st_blksize])
+--- guile-1.6.4/guile-readline/configure.in~configure-lossage
++++ guile-1.6.4/guile-readline/configure.in
+@@ -2,6 +2,7 @@
+ AC_INIT
+ AC_CONFIG_SRCDIR([readline.c])
++AC_CONFIG_AUX_DIR([..])
+ . $srcdir/../GUILE-VERSION
+ PACKAGE=guile-readline
+ AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
diff --git a/packages/guile/files/gcc4.patch b/packages/guile/files/gcc4.patch
new file mode 100644 (file)
index 0000000..2168683
--- /dev/null
@@ -0,0 +1,16 @@
+
+#
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+#
+
+--- guile-1.6.4/libguile/guile.c~gcc4
++++ guile-1.6.4/libguile/guile.c
+@@ -88,7 +88,7 @@
+ {
+ #ifdef DYNAMIC_LINKING
+   /* libtool automagically inserts this variable into your executable... */
+-  extern const scm_lt_dlsymlist lt_preloaded_symbols[];
++  extern const scm_lt_dlsymlist *lt_preloaded_symbols;
+   scm_lt_dlpreload_default (lt_preloaded_symbols);
+ #endif
+   scm_boot_guile (argc, argv, inner_main, 0);
index dc55c26..389aec9 100644 (file)
@@ -1,9 +1,15 @@
-SECTION = "unknown"
-LICENSE = "GPL"
+DESCRIPTION = "Guile is an interpreter for the Scheme programming language, \
+packaged as a library which can be incorporated into your programs."
+HOMEPAGE = "http://www.gnu.org/software/guile/guile.html"
+SECTION = "devel/scheme"
+DEPENDS = "guile-native"
 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL"
+PR = "r1"
+
 SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
-          file://configure-lossage.patch;patch=1"
-DEPENDS = "guile-native"
+           file://configure-lossage.patch;patch=1 \
+           file://gcc4.patch;patch=1"
 
 inherit autotools