Enable e300c2 and c3 support for gcc 4.3.1
authorKhem Raj <raj.khem@gmail.com>
Sun, 24 Aug 2008 03:28:56 +0000 (03:28 +0000)
committerKhem Raj <raj.khem@gmail.com>
Sun, 24 Aug 2008 03:28:56 +0000 (03:28 +0000)
Tested on (mpc8313e-rdb,angstrom)

packages/gcc/gcc-4.3.1.inc
packages/gcc/gcc-4.3.1/gcc-4.0.2-e300c2c3.patch
packages/gcc/gcc-cross-sdk_4.3.1.bb
packages/gcc/gcc-cross_4.3.1.bb
packages/gcc/gcc_4.3.1.bb

index afbc395..7a04be2 100644 (file)
@@ -51,7 +51,7 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
        file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
        file://cache-amnesia.patch;patch=1 \
        file://gfortran.patch;patch=1 \
-#      file://gcc-4.0.2-e300c2c3.patch;patch=1 \
+       file://gcc-4.0.2-e300c2c3.patch;patch=1 \
 #      file://pr34130.patch;patch=1 \
 #      file://fortran-static-linking.patch;patch=1 \
 #      file://intermask-bigendian.patch;patch=1 \
index 736ac4b..d1df8b2 100644 (file)
@@ -3,10 +3,18 @@ http://www.bitshrine.org/gpp/tc-fsl-x86lnx-e300c3-nptl-4.0.2-2.src.rpm
 
 Leon Woestenberg <leonw@mailcan.com>
 
-Index: gcc-4.1.2/gcc/config/rs6000/e300c2c3.md
+---
+ gcc/config.gcc                |    2 
+ gcc/config/rs6000/e300c2c3.md |  189 ++++++++++++++++++++++++++++++++++++++++++
+ gcc/config/rs6000/rs6000.c    |   24 +++++
+ gcc/config/rs6000/rs6000.h    |    4 
+ gcc/config/rs6000/rs6000.md   |    3 
+ 5 files changed, 220 insertions(+), 2 deletions(-)
+
+Index: gcc-4.3.1/gcc/config/rs6000/e300c2c3.md
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ gcc-4.1.2/gcc/config/rs6000/e300c2c3.md    2007-10-18 15:32:51.000000000 +0200
++++ gcc-4.3.1/gcc/config/rs6000/e300c2c3.md    2008-08-23 16:51:33.000000000 -0700
 @@ -0,0 +1,189 @@
 +;; Pipeline description for Motorola PowerPC e300c3 core.
 +;;   Copyright (C) 2003 Free Software Foundation, Inc.
@@ -197,12 +205,12 @@ Index: gcc-4.1.2/gcc/config/rs6000/e300c2c3.md
 +  (and (eq_attr "type" "fpstore,fpstore_ux,fpstore_u")
 +       (eq_attr "cpu" "ppce300c3"))
 +  "ppce300c3_decode,ppce300c3_issue+ppce300c3_lsu,ppce300c3_retire")
-Index: gcc-4.1.2/gcc/config/rs6000/rs6000.c
+Index: gcc-4.3.1/gcc/config/rs6000/rs6000.c
 ===================================================================
---- gcc-4.1.2.orig/gcc/config/rs6000/rs6000.c  2006-12-16 20:24:56.000000000 +0100
-+++ gcc-4.1.2/gcc/config/rs6000/rs6000.c       2007-10-18 15:34:26.000000000 +0200
-@@ -557,6 +557,21 @@
-   COSTS_N_INSNS (29),   /* ddiv */
+--- gcc-4.3.1.orig/gcc/config/rs6000/rs6000.c  2008-08-23 16:49:39.000000000 -0700
++++ gcc-4.3.1/gcc/config/rs6000/rs6000.c       2008-08-23 16:54:25.000000000 -0700
+@@ -669,6 +669,21 @@ struct processor_costs ppc8540_cost = {
+   1,                  /* prefetch streams /*/
  };
  
 +/* Instruction costs on E300C2 and E300C3 cores.  */
@@ -223,16 +231,16 @@ Index: gcc-4.1.2/gcc/config/rs6000/rs6000.c
  /* Instruction costs on POWER4 and POWER5 processors.  */
  static const
  struct processor_costs power4_cost = {
-@@ -1140,6 +1155,8 @@
+@@ -1420,6 +1435,8 @@ rs6000_override_options (const char *def
+        {"8540", PROCESSOR_PPC8540, POWERPC_BASE_MASK | MASK_STRICT_ALIGN},
         /* 8548 has a dummy entry for now.  */
-        {"8548", PROCESSOR_PPC8540,
-         POWERPC_BASE_MASK | MASK_PPC_GFXOPT | MASK_STRICT_ALIGN},
-+       {"e300c2", PROCESSOR_PPCE300C2, POWERPC_BASE_MASK | MASK_SOFT_FLOAT},
-+       {"e300c3", PROCESSOR_PPCE300C3, POWERPC_BASE_MASK},
+        {"8548", PROCESSOR_PPC8540, POWERPC_BASE_MASK | MASK_STRICT_ALIGN},
++       {"e300c2", PROCESSOR_PPCE300C2, POWERPC_BASE_MASK | MASK_SOFT_FLOAT},
++       {"e300c3", PROCESSOR_PPCE300C3, POWERPC_BASE_MASK},
         {"860", PROCESSOR_MPCCORE, POWERPC_BASE_MASK | MASK_SOFT_FLOAT},
         {"970", PROCESSOR_POWER4,
          POWERPC_7400_MASK | MASK_PPC_GPOPT | MASK_MFCRF | MASK_POWERPC64},
-@@ -1529,6 +1546,11 @@
+@@ -1845,6 +1862,11 @@ rs6000_override_options (const char *def
        rs6000_cost = &ppc8540_cost;
        break;
  
@@ -244,68 +252,68 @@ Index: gcc-4.1.2/gcc/config/rs6000/rs6000.c
        case PROCESSOR_POWER4:
        case PROCESSOR_POWER5:
        rs6000_cost = &power4_cost;
-@@ -16647,6 +16669,8 @@
-   case CPU_PPC750:
+@@ -18606,6 +18628,8 @@ rs6000_issue_rate (void)
    case CPU_PPC7400:
    case CPU_PPC8540:
+   case CPU_CELL:
 +  case CPU_PPCE300C2:
 +  case CPU_PPCE300C3:
      return 2;
    case CPU_RIOS2:
    case CPU_PPC604:
-Index: gcc-4.1.2/gcc/config/rs6000/rs6000.h
+Index: gcc-4.3.1/gcc/config/rs6000/rs6000.h
 ===================================================================
---- gcc-4.1.2.orig/gcc/config/rs6000/rs6000.h  2006-11-18 01:25:49.000000000 +0100
-+++ gcc-4.1.2/gcc/config/rs6000/rs6000.h       2007-10-18 15:32:51.000000000 +0200
-@@ -111,6 +111,8 @@
- %{mcpu=970: -mpower4 -maltivec} \
+--- gcc-4.3.1.orig/gcc/config/rs6000/rs6000.h  2008-01-26 09:18:35.000000000 -0800
++++ gcc-4.3.1/gcc/config/rs6000/rs6000.h       2008-08-23 16:55:30.000000000 -0700
+@@ -117,6 +117,8 @@
  %{mcpu=G5: -mpower4 -maltivec} \
  %{mcpu=8540: -me500} \
+ %{mcpu=8548: -me500} \
 +%{mcpu=e300c2: -mppc} \
 +%{mcpu=e300c3: -mppc -mpmr} \
  %{maltivec: -maltivec} \
  -many"
  
-@@ -211,6 +213,8 @@
+@@ -262,6 +264,8 @@ enum processor_type
     PROCESSOR_PPC7400,
     PROCESSOR_PPC7450,
     PROCESSOR_PPC8540,
 +   PROCESSOR_PPCE300C2,
 +   PROCESSOR_PPCE300C3,
     PROCESSOR_POWER4,
-    PROCESSOR_POWER5
- };
-Index: gcc-4.1.2/gcc/config/rs6000/rs6000.md
+    PROCESSOR_POWER5,
+    PROCESSOR_POWER6,
+Index: gcc-4.3.1/gcc/config/rs6000/rs6000.md
 ===================================================================
---- gcc-4.1.2.orig/gcc/config/rs6000/rs6000.md 2006-12-16 20:24:56.000000000 +0100
-+++ gcc-4.1.2/gcc/config/rs6000/rs6000.md      2007-10-18 15:32:51.000000000 +0200
-@@ -103,7 +103,7 @@
+--- gcc-4.3.1.orig/gcc/config/rs6000/rs6000.md 2008-02-13 16:14:45.000000000 -0800
++++ gcc-4.3.1/gcc/config/rs6000/rs6000.md      2008-08-23 16:57:29.000000000 -0700
+@@ -133,7 +133,7 @@
  ;; Processor type -- this attribute must exactly match the processor_type
  ;; enumeration in rs6000.h.
  
--(define_attr "cpu" "rios1,rios2,rs64a,mpccore,ppc403,ppc405,ppc440,ppc601,ppc603,ppc604,ppc604e,ppc620,ppc630,ppc750,ppc7400,ppc7450,ppc8540,power4,power5"
-+(define_attr "cpu" "rios1,rios2,rs64a,mpccore,ppc403,ppc405,ppc440,ppc601,ppc603,ppc604,ppc604e,ppc620,ppc630,ppc750,ppc7400,ppc7450,ppc8540,ppce300c2,ppce300c3,power4,power5"
+-(define_attr "cpu" "rios1,rios2,rs64a,mpccore,ppc403,ppc405,ppc440,ppc601,ppc603,ppc604,ppc604e,ppc620,ppc630,ppc750,ppc7400,ppc7450,ppc8540,power4,power5,power6,cell"
++(define_attr "cpu" "rios1,rios2,rs64a,mpccore,ppc403,ppc405,ppc440,ppc601,ppc603,ppc604,ppc604e,ppc620,ppc630,ppc750,ppc7400,ppc7450,ppc8540,power4,power5,power6,cell,ppce300c2,ppce300c3"
    (const (symbol_ref "rs6000_cpu_attr")))
  
- (automata_option "ndfa")
-@@ -119,6 +119,7 @@
+@@ -166,6 +166,7 @@
  (include "7xx.md")
  (include "7450.md")
  (include "8540.md")
 +(include "e300c2c3.md")
  (include "power4.md")
  (include "power5.md")
-Index: gcc-4.1.2/gcc/config.gcc
+ (include "power6.md")
+Index: gcc-4.3.1/gcc/config.gcc
 ===================================================================
---- gcc-4.1.2.orig/gcc/config.gcc      2007-10-18 15:26:23.000000000 +0200
-+++ gcc-4.1.2/gcc/config.gcc   2007-10-18 15:32:51.000000000 +0200
-@@ -2710,7 +2710,7 @@
+--- gcc-4.3.1.orig/gcc/config.gcc      2008-08-23 16:49:43.000000000 -0700
++++ gcc-4.3.1/gcc/config.gcc   2008-08-23 17:03:55.000000000 -0700
+@@ -3144,7 +3144,7 @@ case "${target}" in
                        | rios | rios1 | rios2 | rsc | rsc1 | rs64a \
                        | 401 | 403 | 405 | 405fp | 440 | 440fp | 505 \
                        | 601 | 602 | 603 | 603e | ec603e | 604 \
 -                      | 604e | 620 | 630 | 740 | 750 | 7400 | 7450 \
 +                      | 604e | 620 | 630 | 740 | 750 | 7400 | 7450 | e300c[23] \
-                       | 854[08] | 801 | 821 | 823 | 860 | 970 | G3 | G4 | G5)
+                       | 854[08] | 801 | 821 | 823 | 860 | 970 | G3 | G4 | G5 | cell)
                                # OK
                                ;;
index 24d628d..fe44c73 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r11"
+PR = "r12"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
index abbde9a..1514b1a 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc