ossie : Adjust RDEPENDS so that waveforms require the component they need.
authorPhilip Balister <philip@balister.org>
Mon, 27 Nov 2006 20:43:25 +0000 (20:43 +0000)
committerPhilip Balister <philip@balister.org>
Mon, 27 Nov 2006 20:43:25 +0000 (20:43 +0000)
        task-ossie need only depend on the required waveforms to pull in
        the waveform components.

packages/ossie/ossie-demo_svn.bb
packages/tasks/task-ossie.bb

index 1108a37..1099b6d 100644 (file)
@@ -5,6 +5,7 @@ PRIORITY = "optional"
 LICENSE = "GPL"
 
 DEPENDS = "ossiecf ossie-channeldemo ossie-rxdemo"
+RDEPENDS = "ossie-channeldemo ossie-rxdemo"
 
 S="${WORKDIR}/ossie_demo"
 
index e2b5005..a6c34bf 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "Meta-package for OSSIE Software Defined Radio (SDR)"
 LICENSE = "MIT"
-RDEPENDS = "${OSSIE_BASE} ${OSSIE_PLATFORM} ${OSSIE_COMPONENTS}"
+RDEPENDS = "${OSSIE_BASE} ${OSSIE_PLATFORM} ${OSSIE_COMPONENTS} ${OSSIE_WAVEFORMS}"
 PR = "r0"
 
 PACKAGES = "task-ossie"
@@ -11,4 +11,5 @@ IPKG_INSTALL = "${OSSIE_BASE} ${OSSIE_PLATFORM} ${OSSIE_COMPONENTS}"
 
 OSSIE_BASE = "screen procps xerces-c omniorb usrp"
 OSSIE_PLATFORM = "ossiecf ossie-standardinterfaces ossie-nodebooter ossie-c-wavloader"
-OSSIE_COMPONENTS = "ossie-gpp-device ossie-usrp-device ossie-soundout-device ossie-demo ossie-channeldemo ossie-rxdemo"
+OSSIE_COMPONENTS = "ossie-gpp-device ossie-usrp-device ossie-soundout-device"
+OSSIE_WAVEFORMS = "ossie-demo ossie-tx-random-data"