Include limits.h explicitly in zeroconf.c
authorKhem Raj <raj.khem@gmail.com>
Wed, 28 May 2008 00:49:38 +0000 (00:49 +0000)
committerKhem Raj <raj.khem@gmail.com>
Wed, 28 May 2008 00:49:38 +0000 (00:49 +0000)
packages/zeroconf/files/zeroconf-limits.h.patch [new file with mode: 0644]
packages/zeroconf/zeroconf_0.9.bb

diff --git a/packages/zeroconf/files/zeroconf-limits.h.patch b/packages/zeroconf/files/zeroconf-limits.h.patch
new file mode 100644 (file)
index 0000000..46ba208
--- /dev/null
@@ -0,0 +1,21 @@
+In newer glibc after this commit.
+
+http://sourceware.org/cgi-bin/cvsweb.cgi/libc/sysdeps/unix/sysv/linux/bits/socket.h.diff?r1=1.60&r2=1.61&cvsroot=glibc
+
+
+do not include limits.h indirectly through sockets.h so we would need to include limits.h explicitely.
+
+-Khem
+
+Index: zeroconf-0.9/zeroconf.c
+===================================================================
+--- zeroconf-0.9.orig/zeroconf.c       2008-05-27 16:56:05.000000000 -0700
++++ zeroconf-0.9/zeroconf.c    2008-05-27 16:56:20.000000000 -0700
+@@ -33,6 +33,7 @@
+ #include <net/if_arp.h>
+ #include <sys/time.h>
+ #include <signal.h>
++#include <limits.h>
+ #include "delay.h"
index c8f7ddf..5c42237 100644 (file)
@@ -5,10 +5,11 @@ LICENSE = "GPL"
 SECTION = "net"
 PRIORITY = "optional"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${PN}-${PV}.tar.gz \
           file://zeroconf-default \
+          file://zeroconf-limits.h.patch;patch=1 \
           file://debian-zeroconf"
 
 do_install () {