gst-plugin-pulse 0.9.7 add patch reducing 20% of the load due to some busylooping
authorMichael Lauer <mickey@vanille-media.de>
Wed, 13 Feb 2008 11:40:41 +0000 (11:40 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Wed, 13 Feb 2008 11:40:41 +0000 (11:40 +0000)
NOTE: need to play more with that to find out whether we can get even more

packages/gstreamer/gst-plugin-pulse/.mtn2git_empty [new file with mode: 0644]
packages/gstreamer/gst-plugin-pulse/dont-overload-pulseaudio.patch [new file with mode: 0644]
packages/gstreamer/gst-plugin-pulse_0.9.7.bb

diff --git a/packages/gstreamer/gst-plugin-pulse/.mtn2git_empty b/packages/gstreamer/gst-plugin-pulse/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gstreamer/gst-plugin-pulse/dont-overload-pulseaudio.patch b/packages/gstreamer/gst-plugin-pulse/dont-overload-pulseaudio.patch
new file mode 100644 (file)
index 0000000..377a4f9
--- /dev/null
@@ -0,0 +1,13 @@
+Index: gst-pulse-0.9.7/src/pulsesink.c
+===================================================================
+--- gst-pulse-0.9.7.orig/src/pulsesink.c
++++ gst-pulse-0.9.7/src/pulsesink.c
+@@ -477,6 +477,8 @@ static guint gst_pulsesink_write(GstAudi
+         length -= l;
+         sum += l;
++
++      usleep( 500 );
+     }
+     pa_threaded_mainloop_unlock(pulsesink->mainloop);
index a1e321c..5a83f39 100644 (file)
@@ -2,11 +2,12 @@ DESCRIPTION = "GStreamer plugin for using pulse audio as sink and source"
 HOMEPAGE = "http://0pointer.de/lennart/projects/gst-pulse/"
 LICENSE = "GPL"
 DEPENDS = "gstreamer pulseaudio"
-PR = "r0"
+PR = "r1"
 
 DEFAULT_PREFERENCE = "-1"
 
-SRC_URI = "http://0pointer.de/lennart/projects/gst-pulse/gst-pulse-${PV}.tar.gz"
+SRC_URI = "http://0pointer.de/lennart/projects/gst-pulse/gst-pulse-${PV}.tar.gz \
+       file://dont-overload-pulseaudio.patch;patch=1"
 S = "${WORKDIR}/gst-pulse-${PV}"
 
 inherit autotools