libxml-native - Initial add.
authorRaymond Danks <raymond@edanks.com>
Mon, 24 Jul 2006 16:12:16 +0000 (16:12 +0000)
committerRaymond Danks <raymond@edanks.com>
Mon, 24 Jul 2006 16:12:16 +0000 (16:12 +0000)
packages/libxml/libxml2-native_2.6.10.bb [new file with mode: 0644]
packages/libxml/libxml2-native_2.6.9.bb [new file with mode: 0644]

diff --git a/packages/libxml/libxml2-native_2.6.10.bb b/packages/libxml/libxml2-native_2.6.10.bb
new file mode 100644 (file)
index 0000000..1a387c4
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "GNOME XML library"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2-${PV}.tar.gz"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit autotools native pkgconfig 
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+       oe_runmake install
+}
diff --git a/packages/libxml/libxml2-native_2.6.9.bb b/packages/libxml/libxml2-native_2.6.9.bb
new file mode 100644 (file)
index 0000000..1a387c4
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "GNOME XML library"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+
+SRC_URI = "http://xmlsoft.org/sources/libxml2-${PV}.tar.gz"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit autotools native pkgconfig 
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+       oe_runmake install
+}