dpkg: Add 1.14.25 (current on mirrors)
authorTom Rini <trini@embeddedalley.com>
Wed, 18 Feb 2009 21:31:03 +0000 (16:31 -0500)
committerTom Rini <trini@embeddedalley.com>
Wed, 18 Feb 2009 21:31:03 +0000 (16:31 -0500)
packages/dpkg/dpkg-1.14.25/ignore_extra_fields.patch [new file with mode: 0644]
packages/dpkg/dpkg-native_1.14.25.bb [new file with mode: 0644]
packages/dpkg/dpkg_1.14.25.bb [new file with mode: 0644]

diff --git a/packages/dpkg/dpkg-1.14.25/ignore_extra_fields.patch b/packages/dpkg/dpkg-1.14.25/ignore_extra_fields.patch
new file mode 100644 (file)
index 0000000..e47af42
--- /dev/null
@@ -0,0 +1,24 @@
+ dpkg-deb/build.c |    4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: dpkg-1.14.23/dpkg-deb/build.c
+===================================================================
+--- dpkg-1.14.23.orig/dpkg-deb/build.c 2008-11-18 10:57:33.000000000 +0000
++++ dpkg-1.14.23/dpkg-deb/build.c      2008-12-15 11:27:08.000000000 +0000
+@@ -243,14 +243,14 @@
+               controlfile, checkedinfo->otherpriority);
+       warns++;
+     }
+-    for (field= checkedinfo->available.arbs; field; field= field->next) {
++    /*for (field= checkedinfo->available.arbs; field; field= field->next) {
+       if (known_arbitrary_field(field))
+         continue;
+       fprintf(stderr, _("warning, `%s' contains user-defined field `%s'\n"),
+               controlfile, field->name);
+       warns++;
+-    }
++    }*/
+     checkversion(checkedinfo->available.version.version,"(upstream) version",&errs);
+     checkversion(checkedinfo->available.version.revision,"Debian revision",&errs);
+     if (errs) ohshit(_("%d errors in control file"),errs);
diff --git a/packages/dpkg/dpkg-native_1.14.25.bb b/packages/dpkg/dpkg-native_1.14.25.bb
new file mode 100644 (file)
index 0000000..f8d6705
--- /dev/null
@@ -0,0 +1,15 @@
+require dpkg.inc
+DEPENDS += "bzip2-native zlib-native virtual/update-alternatives-native"
+SRC_URI += "file://noman.patch;patch=1"
+
+FILESPATH += "dpkg-${PV}"
+
+inherit native
+
+EXTRA_OECONF = "--without-static-progs \
+               --without-dselect \
+               --with-start-stop-daemon \
+               --with-zlib \
+               --with-bz2lib \
+                --without-selinux \
+               --without-sgml-doc"
diff --git a/packages/dpkg/dpkg_1.14.25.bb b/packages/dpkg/dpkg_1.14.25.bb
new file mode 100644 (file)
index 0000000..dac14f9
--- /dev/null
@@ -0,0 +1,11 @@
+require dpkg.inc
+DEPENDS += "zlib bzip2"
+#RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
+SRC_URI += "file://noman.patch;patch=1"
+
+EXTRA_OECONF = "--without-static-progs \
+               --without-dselect \
+               --with-start-stop-daemon \
+               --with-zlib \
+               --with-bz2lib \
+               --without-sgml-doc"