gst-plugins: fix do_split_packages bogus dependency addition
authorKoen Kooi <koen@openembedded.org>
Sun, 10 Aug 2008 18:32:14 +0000 (18:32 +0000)
committerKoen Kooi <koen@openembedded.org>
Sun, 10 Aug 2008 18:32:14 +0000 (18:32 +0000)
gst-plguins-good: fix gconfelements plugin

packages/gstreamer/gst-plugins-good_0.10.7.bb
packages/gstreamer/gst-plugins.inc

index fb551f5..ac3a5e7 100644 (file)
@@ -1,5 +1,10 @@
 require gst-plugins.inc
-PR = "r1"
+PR = "r2"
+
+inherit gconf 
 
 EXTRA_OECONF += "--with-check=no"
 DEPENDS += "gst-plugins-base esound"
+
+PACKAGES =+ "gst-plugin-gconfelements"
+FILES_gst-plugin-gconfelements += "${sysconfdir}/gconf"
index eaba834..1775853 100644 (file)
@@ -19,8 +19,8 @@ python populate_packages_prepend () {
        gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
        postinst = bb.data.getVar('plugin_postinst', d, 1)
 
-       do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst)
-       do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)')
+       do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst, extra_depends='')
+       do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)', extra_depends='')
 }
 
 ALLOW_EMPTY = "1"