ccxstream package from kolla
authorJohn Bowler <jbowler@nslu2-linux.org>
Mon, 1 Aug 2005 19:29:17 +0000 (19:29 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Mon, 1 Aug 2005 19:29:17 +0000 (19:29 +0000)
packages/ccxstream/.mtn2git_empty [new file with mode: 0644]
packages/ccxstream/ccxstream-1.0.15/.mtn2git_empty [new file with mode: 0644]
packages/ccxstream/ccxstream-1.0.15/ccxstream-termcap.patch [new file with mode: 0644]
packages/ccxstream/ccxstream-1.0.15/ccxstream.conf [new file with mode: 0644]
packages/ccxstream/ccxstream-1.0.15/ccxstream.init [new file with mode: 0644]
packages/ccxstream/ccxstream_1.0.15.bb [new file with mode: 0644]

diff --git a/packages/ccxstream/.mtn2git_empty b/packages/ccxstream/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/ccxstream/ccxstream-1.0.15/.mtn2git_empty b/packages/ccxstream/ccxstream-1.0.15/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/ccxstream/ccxstream-1.0.15/ccxstream-termcap.patch b/packages/ccxstream/ccxstream-1.0.15/ccxstream-termcap.patch
new file mode 100644 (file)
index 0000000..c392a6a
--- /dev/null
@@ -0,0 +1,11 @@
+--- ccxstream-1.0.15/Makefile.orig     2003-12-27 04:57:23.733355080 +0000
++++ ccxstream-1.0.15/Makefile  2003-12-27 04:57:34.506717280 +0000
+@@ -22,7 +22,7 @@
+ #
+ CFLAGS+=-I. -g
+-LDFLAGS+=-lreadline -ltermcap
++LDFLAGS+=-lreadline -lncurses
+ all: ccxstream ccxtest
diff --git a/packages/ccxstream/ccxstream-1.0.15/ccxstream.conf b/packages/ccxstream/ccxstream-1.0.15/ccxstream.conf
new file mode 100644 (file)
index 0000000..29928e6
--- /dev/null
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+#Uncomment the line below to begin (mandatory)
+#CHECK=YES
+
+#Below the user to run the service as (mandatory)
+RUNASUSER="root"
+
+#Below the password on the XBOX (optional)
+#REMOTEPASS="xboxpassword" 
+
+#Below the interface to listen on (mandatory)
+LISTENINTERFACE="192.168.1.1"
+
+FOLLOWSYMLINKS=YES
+
+#Comment (optional)
+#SERVERCOMMENT="Video and MP3 server powered by Gentoo. Watch and listen and ENJOY."
+
+#Shares to make available (mandatory)
+SHARES="movies=/data/videos audio=/data/mp3"
+
+#Location of binary file. Leave default unless you know what you're doing (mandatory)
+BIN="/usr/sbin/ccxstream"
+
+#-----------------------------------------------------------------------------#
+#-----------------------------------------------------------------------------#
+
+DIR="-"
+
+PIDFILE=/var/run/ccxstream.pid
+
+PARAMS="-f -F $PIDFILE -r $DIR -u $RUNASUSER"
+
+if test "$FOLLOWSYMLINKS" = "YES" ; then
+    PARAMS="$PARAMS -L"
+fi
+
+if test "x$REMOTEPASS" != "x" ; then
+    PARAMS="$PARAMS -P $REMOTEPASS"
+fi
+
+if test "x$LISTENINTERFACE" != "x" ; then
+    PARAMS="$PARAMS -l $LISTENINTERFACE"
+fi
+
+for i in $SHARES ; do
+    PARAMS="$PARAMS -S $i"
+done
+
+if test "x$SERVERCOMMENT" = "x" ; then
+    SERVERCOMMENT="$(hostname -f)"
+fi
+                           
diff --git a/packages/ccxstream/ccxstream-1.0.15/ccxstream.init b/packages/ccxstream/ccxstream-1.0.15/ccxstream.init
new file mode 100644 (file)
index 0000000..f577528
--- /dev/null
@@ -0,0 +1,37 @@
+#! /bin/sh
+
+start() {
+        . /etc/ccxstream.conf
+        if [ "${CHECK}" = "YES" ] ; then
+
+            echo -n "Starting ccXstream : "
+            start-stop-daemon --start --quiet --exec ${BIN} \
+            -- ${PARAMS} -C ${SERVERCOMMENT}
+            status="$?"
+            test ${status} = "0" && echo OK || echo FAILED
+            return ${status}
+        else
+            echo "Please setup /etc/ccxstream.conf before starting ccXstream"
+            return 1
+        fi
+}
+
+stop() {
+        echo -n "Stopping ccXstream : "
+        start-stop-daemon --stop --quiet --pidfile /var/run/ccxstream.pid
+        return $?
+}
+
+case $1 in
+        start)
+                start
+        ;;
+        stop)
+                stop
+        ;;
+        restart)
+                stop
+                start
+        ;;
+esac
+
diff --git a/packages/ccxstream/ccxstream_1.0.15.bb b/packages/ccxstream/ccxstream_1.0.15.bb
new file mode 100644 (file)
index 0000000..85d4a5b
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "XStream Server"
+
+LICENSE = "GPL-2"
+
+SRC_URI = "http://surfnet.dl.sourceforge.net/sourceforge/xbplayer/${P}.tar.gz \
+       file://ccxstream-termcap.patch;patch=1 \
+       file://ccxstream.init \
+       file://ccxstream.conf"
+
+inherit autotools
+
+do_install() {
+       # add startup and sample config
+       mkdir -p ${D}${sysconfdir}/init.d ${D}/usr/bin
+       install -m 0755 ${WORKDIR}/ccxstream.init ${D}${sysconfdir}/init.d/ccxstream
+       install -m 0644 ${WORKDIR}/ccxstream.conf ${D}${sysconfdir}/ccxstream.conf
+       install -m 0755 ccxstream ${D}/usr/sbin/ccxstream || exit 1
+}