bluez-libs: add 4.40, set default preference to -1 pending availability
authorPhil Blundell <philb@gnu.org>
Fri, 22 May 2009 10:49:05 +0000 (11:49 +0100)
committerPhil Blundell <philb@gnu.org>
Fri, 22 May 2009 10:49:05 +0000 (11:49 +0100)
of apps

conf/checksums.ini
recipes/bluez/bluez-libs/avinfo-link.patch [new file with mode: 0644]
recipes/bluez/bluez-libs_4.40.bb [new file with mode: 0644]

index 245875d..5d41dd8 100644 (file)
@@ -2758,6 +2758,10 @@ sha256=2bfc5db7703cbcaaa4be2576609136450e1dac5d4782707dd0dc81754e3c2489
 md5=ba06291b737077332e914d6d653501c6
 sha256=924dc4b8ae78da2c8f3af9c36ab85d08ee7f8ec0ae4dfe58840ae70041580063
 
+[http://www.kernel.org/pub/linux/bluetooth/bluez-4.40.tar.gz]
+md5=a25fa37c97c309338649f6a5fd4cea76
+sha256=1208d8e986f8b545659db21c8220ec28b48979627158123dd9018f9733d858d2
+
 [http://www.kernel.org/pub/linux/bluetooth/bluez-4.7.tar.gz]
 md5=2aa806940d2c841e57a9b2ab7302b750
 sha256=ed384dea4f5f21157758fcd7db64db19ce0b410509c26630706e4a3c779287a0
diff --git a/recipes/bluez/bluez-libs/avinfo-link.patch b/recipes/bluez/bluez-libs/avinfo-link.patch
new file mode 100644 (file)
index 0000000..944a98a
--- /dev/null
@@ -0,0 +1,22 @@
+--- tools/Makefile.am.old      2009-05-22 11:27:06.000000000 +0100
++++ tools/Makefile.am  2009-05-22 11:27:29.000000000 +0100
+@@ -1,8 +1,10 @@
+ if TOOLS
+ tools_programs = hcitool l2ping sdptool ciptool
++avinfo_programs = avinfo
+ tools_manfiles = hcitool.1 l2ping.1 sdptool.1 ciptool.1
+ else
++avinfo_programs =
+ tools_programs =
+ tools_manfiles =
+ endif
+@@ -41,7 +43,7 @@
+ bin_PROGRAMS = $(tools_programs) $(dfutool_programs) $(dfubabel_programs)
+-noinst_PROGRAMS = hcieventmask hcisecfilter ppporc avinfo $(usb_programs)
++noinst_PROGRAMS = hcieventmask hcisecfilter ppporc $(avinfo_programs) $(usb_programs)
+ hcieventmask_LDADD = @BLUEZ_LIBS@
diff --git a/recipes/bluez/bluez-libs_4.40.bb b/recipes/bluez/bluez-libs_4.40.bb
new file mode 100644 (file)
index 0000000..578afaa
--- /dev/null
@@ -0,0 +1,26 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+SECTION = "libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
+        file://avinfo-link.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/bluez-${PV}"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+EXTRA_OECONF = "\
+  --disable-tools \
+  --disable-audio \
+  --disable-network \
+  --disable-serial \
+  --disable-service \
+  --disable-usb \
+"
+
+FILES_${PN} = "${libdir}/libbluetooth.so.*"