abiword*: update to 2.5.2
authorKoen Kooi <koen@openembedded.org>
Wed, 22 Aug 2007 11:16:29 +0000 (11:16 +0000)
committerKoen Kooi <koen@openembedded.org>
Wed, 22 Aug 2007 11:16:29 +0000 (11:16 +0000)
packages/abiword/abiword-embedded_2.5.2.bb [new file with mode: 0644]
packages/abiword/abiword-plugins_2.5.2.bb [new file with mode: 0644]
packages/abiword/abiword_2.5.2.bb [new file with mode: 0644]

diff --git a/packages/abiword/abiword-embedded_2.5.2.bb b/packages/abiword/abiword-embedded_2.5.2.bb
new file mode 100644 (file)
index 0000000..47cf9e0
--- /dev/null
@@ -0,0 +1,10 @@
+require abiword-2.5.inc
+
+EXTRA_OECONF += "--enable-embedded"
+
+S = "${WORKDIR}/abiword-${PV}"
+
+RCONFLICTS = "abiword"
+RPROVIDES += "abiword"
+
+
diff --git a/packages/abiword/abiword-plugins_2.5.2.bb b/packages/abiword/abiword-plugins_2.5.2.bb
new file mode 100644 (file)
index 0000000..54d87ac
--- /dev/null
@@ -0,0 +1,39 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word""
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "boost loudmouth libwpd librsvg goffice poppler libglade"
+RDEPENDS = "abiword"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+           http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+          "
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = " --without-libwmf \
+                 --without-inter7eps \
+                --with-abiword=${WORKDIR}/abiword-${PV} \
+                --with-boost=${STAGINC_INCDIR}/../ \ 
+                "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+       abiword_libdir    = bb.data.expand('${libdir}/abiword-2.5/plugins', d)
+       do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+        do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
+}
+
+
+PACKAGES =+ "abiword-plugin-collab-glade"
+
+FILES_abiword-plugin-collab-glade += "${datadir}"
+RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
+
+FILES_${PN}-dbg += "${libdir}/abiword-2.5/plugins/.debug"
+
diff --git a/packages/abiword/abiword_2.5.2.bb b/packages/abiword/abiword_2.5.2.bb
new file mode 100644 (file)
index 0000000..66d8fae
--- /dev/null
@@ -0,0 +1,7 @@
+require abiword-2.5.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PR = "r0"
+
+RCONFLICTS = "abiword-embedded"