gst-plugins-bad: disable inline asm during thumb builds
authorPhil Blundell <philb@gnu.org>
Mon, 27 Oct 2008 20:37:48 +0000 (20:37 +0000)
committerPhil Blundell <philb@gnu.org>
Mon, 27 Oct 2008 20:37:48 +0000 (20:37 +0000)
packages/gstreamer/gst-plugins-bad/ivorbis-thumb.patch [new file with mode: 0644]
packages/gstreamer/gst-plugins-bad_0.10.6.bb

diff --git a/packages/gstreamer/gst-plugins-bad/ivorbis-thumb.patch b/packages/gstreamer/gst-plugins-bad/ivorbis-thumb.patch
new file mode 100644 (file)
index 0000000..c94a788
--- /dev/null
@@ -0,0 +1,11 @@
+--- bad/ext/ivorbis/vorbisdec.c~       2008-01-22 09:55:22.000000000 +0000
++++ bad/ext/ivorbis/vorbisdec.c        2008-10-27 20:12:43.000000000 +0000
+@@ -792,7 +792,7 @@
+ }
+ /* Taken from Tremor, misc.h */
+-#ifdef _ARM_ASSEM_
++#if defined(_ARM_ASSEM_) && !defined(__thumb__)
+ static inline ogg_int32_t
+ CLIP_TO_15 (ogg_int32_t x)
+ {
index 2a99858..5d06a3c 100644 (file)
@@ -1,7 +1,8 @@
 require gst-plugins.inc
 
 SRC_URI += "file://vorbisenc.h file://vorbisdec.h \
-            file://gst-plugins-directfb-fix.patch;patch=1;pnum=2"
+            file://gst-plugins-directfb-fix.patch;patch=1;pnum=2 \
+            file://ivorbis-thumb.patch;patch=1"
 DEPENDS += "gst-plugins-base directfb"
 
 do_compile_prepend() {