fuse: add 2.4.2
authorKoen Kooi <koen@openembedded.org>
Fri, 9 Dec 2005 09:20:31 +0000 (09:20 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Fri, 9 Dec 2005 09:20:31 +0000 (09:20 +0000)
fuse-modules: add kernel module for fuse
sshfs-fuse: add sshfs 1.3

packages/fuse/.mtn2git_empty [new file with mode: 0644]
packages/fuse/fuse-module_2.4.2.bb [new file with mode: 0644]
packages/fuse/fuse_2.4.2.bb [new file with mode: 0644]
packages/fuse/sshfs-fuse_1.3.bb [new file with mode: 0644]

diff --git a/packages/fuse/.mtn2git_empty b/packages/fuse/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/fuse/fuse-module_2.4.2.bb b/packages/fuse/fuse-module_2.4.2.bb
new file mode 100644 (file)
index 0000000..8b8ca91
--- /dev/null
@@ -0,0 +1,33 @@
+HOMEPAGE = "http://fuse.sf.net"
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+LICENSE = "GPL"
+
+
+DEPENDS = "fakeroot-native"
+RRECOMMEND = "fuse"
+
+SRC_URI="${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz"
+S = "${WORKDIR}/fuse-${PV}"
+
+inherit autotools pkgconfig module
+EXTRA_OECONF = "  --with-kernel=${STAGING_KERNEL_DIR}"
+
+do_configure() {
+cd ${S} ; oe_runconf
+}
+
+do_compile(){
+LDFLAGS=""
+cd ${S}/kernel
+oe_runmake
+}
+
+fakeroot do_install() {
+LDFLAGS=""
+cd ${S}/kernel
+oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} = "/dev /lib/modules"
diff --git a/packages/fuse/fuse_2.4.2.bb b/packages/fuse/fuse_2.4.2.bb
new file mode 100644 (file)
index 0000000..27abd3a
--- /dev/null
@@ -0,0 +1,23 @@
+HOMEPAGE = "http://fuse.sf.net"
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+LICENSE_${PN} = "LGPL"
+
+DEPENDS = "fakeroot-native"
+RRECOMMENDS_${PN} = "fuse-module"
+
+SRC_URI="${SOURCEFORGE_MIRROR}/fuse/${P}.tar.gz"
+
+inherit autotools pkgconfig
+EXTRA_OECONF = " --disable-kernel-module"
+
+fakeroot do_install() {
+oe_runmake install DESTDIR=${D}
+}
+
+fakeroot do_stage() {
+autotools_stage_all
+}
+
+
diff --git a/packages/fuse/sshfs-fuse_1.3.bb b/packages/fuse/sshfs-fuse_1.3.bb
new file mode 100644 (file)
index 0000000..d147d82
--- /dev/null
@@ -0,0 +1,14 @@
+HOMEPAGE = "http://fuse.sourceforge.net/sshfs.html"
+DESCRIPTION = "This is a filesystem client based on the SSH File Transfer Protocol using FUSE."
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+LICENSE_${PN} = "LGPL"
+
+DEPENDS = "fakeroot-native fuse" 
+RRECOMMENDS_${PN} = "fuse-module"
+
+SRC_URI="${SOURCEFORGE_MIRROR}/fuse/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+