midpath-core 0.2+03rc2: Added patch to fix file opening.
authorRobert Schuster <thebohemian@gmx.net>
Thu, 4 Dec 2008 20:15:56 +0000 (21:15 +0100)
committerRobert Schuster <thebohemian@gmx.net>
Thu, 4 Dec 2008 20:15:56 +0000 (21:15 +0100)
packages/midpath/files/fix-openfile.patch [new file with mode: 0644]
packages/midpath/midpath-core_0.2+0.3rc2.bb

diff --git a/packages/midpath/files/fix-openfile.patch b/packages/midpath/files/fix-openfile.patch
new file mode 100644 (file)
index 0000000..6b9b8be
--- /dev/null
@@ -0,0 +1,13 @@
+Index: midpath-0.3rc2/components/core/src/org/thenesis/midpath/io/backend/j2se/FileHandlerImpl.java
+===================================================================
+--- midpath-0.3rc2.orig/components/core/src/org/thenesis/midpath/io/backend/j2se/FileHandlerImpl.java  2008-12-04 21:10:39.000000000 +0100
++++ midpath-0.3rc2/components/core/src/org/thenesis/midpath/io/backend/j2se/FileHandlerImpl.java       2008-12-04 21:12:11.000000000 +0100
+@@ -182,7 +182,7 @@
+       public void openForRead() throws IOException {\r
+               if (randomAccessFile == null) {\r
+                       //stream = new FileRandomAccessStream(file);\r
+-                      randomAccessFile = new RandomAccessFile(file, "rws");\r
++                      randomAccessFile = new RandomAccessFile(file, "r");\r
+               }\r
+       }\r
\r
index 1a6fee8..d4d6b6b 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "MIDPath is a Java library which provides a MIDP2 implementation"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz"
 
@@ -9,6 +9,7 @@ S = "${WORKDIR}/midpath-0.3rc2"
 require midpath-common.inc
 
 SRC_URI += "\
+       file://fix-openfile.patch;patch=1 \
   file://midpath-suitemanager \
   file://midpath-launcher-j2se \
   file://midpath-suitemanager.desktop \