klibc: make changes so that klibc-utils-static compiles for eabi as well. Closes...
authorThomas Kunze <thommycheck@gmx.de>
Fri, 8 Feb 2008 22:47:02 +0000 (22:47 +0000)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Fri, 8 Feb 2008 22:47:02 +0000 (22:47 +0000)
packages/klibc/files/klibc-config-eabi.patch [new file with mode: 0644]
packages/klibc/klibc-utils-static_1.5.bb

diff --git a/packages/klibc/files/klibc-config-eabi.patch b/packages/klibc/files/klibc-config-eabi.patch
new file mode 100644 (file)
index 0000000..86517f0
--- /dev/null
@@ -0,0 +1,9 @@
+diff -Nur klibc-1.5/defconfig klibc-1.5p/defconfig
+--- klibc-1.5/defconfig        2007-03-04 02:52:10.000000000 +0100
++++ klibc-1.5p/defconfig       2008-02-08 19:24:22.337127756 +0100
+@@ -5,4 +5,4 @@
+ CONFIG_REGPARM=y
+ # ARM options
+ # CONFIG_KLIBC_THUMB is not set
+-# CONFIG_AEABI is not set
++CONFIG_AEABI=y
index 17db233..bbb3248 100644 (file)
@@ -4,6 +4,9 @@ PR = "r3"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/klibc/Stable/klibc-${PV}.tar.bz2"
 
+SRC_URI_append_linux-gnueabi = "\
+                               file://klibc-config-eabi.patch;patch=1"
+
 EXTRA_OEMAKE = "'KLIBCARCH=${KLIBC_ARCH}' \
                 'CROSS_COMPILE=${TARGET_PREFIX}' \
                 "
@@ -36,7 +39,6 @@ do_install() {
         install -m 755 usr/utils/static/uname ${D}${base_bindir}
 }
 
-PACKAGE_ARCH = "${MACHINE_ARCH}"
 PACKAGES = "klibc-utils-static-sh klibc-utils-static-gzip \
         klibc-utils-static-cat klibc-utils-static-chroot \
         klibc-utils-static-cpio klibc-utils-static-dd \
@@ -71,11 +73,3 @@ FILES_klibc-utils-static-sleep = "${base_bindir}/sleep"
 FILES_klibc-utils-static-true = "${base_bindir}/true"
 FILES_klibc-utils-static-umount = "${base_bindir}/umount"
 FILES_klibc-utils-static-uname = "${base_bindir}/uname"
-
-# the klibc code contains ARM instructions (for ARM), this
-# could be fixed, but for the moment:
-ARM_INSTRUCTION_SET = "arm"
-
-KLIBC_ARCH = "'${TARGET_ARCH}'"
-KLIBC_ARCH_armeb = "'arm'"
-KLIBC_ARCH_mipsel = "'mips'"