iproute2: Add latest version 2.6.22. Also move the settings of S into the
authorJamie Lenehan <lenehan@twibble.org>
Sat, 18 Aug 2007 08:41:06 +0000 (08:41 +0000)
committerJamie Lenehan <lenehan@twibble.org>
Sat, 18 Aug 2007 08:41:06 +0000 (08:41 +0000)
individual .bb files since it has changed again in this release.

packages/iproute2/iproute2-2.6.22/.mtn2git_empty [new file with mode: 0644]
packages/iproute2/iproute2-2.6.22/new-flex-fix.patch [new file with mode: 0644]
packages/iproute2/iproute2-2.6.22/no-strip.patch [new file with mode: 0644]
packages/iproute2/iproute2.inc
packages/iproute2/iproute2_2.6.16.bb
packages/iproute2/iproute2_2.6.18.bb
packages/iproute2/iproute2_2.6.20.bb
packages/iproute2/iproute2_2.6.22.bb [new file with mode: 0644]

diff --git a/packages/iproute2/iproute2-2.6.22/.mtn2git_empty b/packages/iproute2/iproute2-2.6.22/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/iproute2/iproute2-2.6.22/new-flex-fix.patch b/packages/iproute2/iproute2-2.6.22/new-flex-fix.patch
new file mode 100644 (file)
index 0000000..af72721
--- /dev/null
@@ -0,0 +1,83 @@
+The tc command was failing to build due to flex errors. These errors are
+caused by an incompatible change to flex in recent versions, including the
+version shipped with OE. 
+
+This fix is as per the one used by opensure:
+
+  http://lists.opensuse.org/opensuse-commit/2006-04/msg00090.html
+
+and simple renames str to prevent it conflicting.
+
+--- iproute-2.6.20-070313/tc/emp_ematch.l      2007/03/17 02:52:20     1.1
++++ iproute-2.6.20-070313/tc/emp_ematch.l      2007/03/17 02:54:01
+@@ -63,7 +63,7 @@
+ %}
+-%x str
++%x STR
+ %option 8bit stack warn noyywrap prefix="ematch_"
+ %%
+@@ -78,17 +78,17 @@
+                                               }
+                                               strbuf_index = 0;
+-                                              BEGIN(str);
++                                              BEGIN(STR);
+                                       }
+-<str>\"                                       {
++<STR>\"                                       {
+                                               BEGIN(INITIAL);
+                                               yylval.b = bstr_new(strbuf, strbuf_index);
+                                               yylval.b->quoted = 1;
+                                               return ATTRIBUTE;
+                                       }
+-<str>\\[0-7]{1,3}                     { /* octal escape sequence */
++<STR>\\[0-7]{1,3}                     { /* octal escape sequence */
+                                               int res;
+                                               sscanf(yytext + 1, "%o", &res);
+@@ -100,12 +100,12 @@
+                                               strbuf_append_char((unsigned char) res);
+                                       }
+-<str>\\[0-9]+                         { /* catch wrong octal escape seq. */
++<STR>\\[0-9]+                         { /* catch wrong octal escape seq. */
+                                               fprintf(stderr, "error: invalid octale escape sequence\n");
+                                               return ERROR;
+                                       }
+-<str>\\x[0-9a-fA-F]{1,2}              {
++<STR>\\x[0-9a-fA-F]{1,2}              {
+                                               int res;
+                                               sscanf(yytext + 2, "%x", &res);
+@@ -118,16 +118,16 @@
+                                               strbuf_append_char((unsigned char) res);
+                                       }
+-<str>\\n                              strbuf_append_char('\n');
+-<str>\\r                              strbuf_append_char('\r');
+-<str>\\t                              strbuf_append_char('\t');
+-<str>\\v                              strbuf_append_char('\v');
+-<str>\\b                              strbuf_append_char('\b');
+-<str>\\f                              strbuf_append_char('\f');
+-<str>\\a                              strbuf_append_char('\a');
++<STR>\\n                              strbuf_append_char('\n');
++<STR>\\r                              strbuf_append_char('\r');
++<STR>\\t                              strbuf_append_char('\t');
++<STR>\\v                              strbuf_append_char('\v');
++<STR>\\b                              strbuf_append_char('\b');
++<STR>\\f                              strbuf_append_char('\f');
++<STR>\\a                              strbuf_append_char('\a');
+-<str>\\(.|\n)                         strbuf_append_char(yytext[1]);
+-<str>[^\\\n\"]+                               strbuf_append_charp(yytext);
++<STR>\\(.|\n)                         strbuf_append_char(yytext[1]);
++<STR>[^\\\n\"]+                               strbuf_append_charp(yytext);
+ [aA][nN][dD]                          return AND;
+ [oO][rR]                              return OR;
diff --git a/packages/iproute2/iproute2-2.6.22/no-strip.patch b/packages/iproute2/iproute2-2.6.22/no-strip.patch
new file mode 100644 (file)
index 0000000..6490dad
--- /dev/null
@@ -0,0 +1,36 @@
+--- iproute-2.6.20-070313/ip/Makefile  2007/03/17 05:17:30     1.1
++++ iproute-2.6.20-070313/ip/Makefile  2007/03/17 05:17:37
+@@ -16,7 +16,7 @@
+ rtmon: $(RTMONOBJ) $(LIBNETLINK)
+ install: all
+-      install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++      install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+       install -m 0755 $(SCRIPTS) $(DESTDIR)$(SBINDIR)
+ clean:
+--- iproute-2.6.20-070313/misc/Makefile        2007/03/17 05:18:20     1.1
++++ iproute-2.6.20-070313/misc/Makefile        2007/03/17 05:18:26
+@@ -27,7 +27,7 @@
+ lnstat: $(LNSTATOBJ)
+ install: all
+-      install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++      install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+       ln -sf lnstat $(DESTDIR)$(SBINDIR)/rtstat
+       ln -sf lnstat $(DESTDIR)$(SBINDIR)/ctstat
+--- iproute-2.6.20-070313/tc/Makefile  2007/03/17 05:17:42     1.1
++++ iproute-2.6.20-070313/tc/Makefile  2007/03/17 05:17:54
+@@ -70,9 +70,9 @@
+ install: all
+       mkdir -p $(DESTDIR)/usr/lib/tc
+-      install -m 0755 -s tc $(DESTDIR)$(SBINDIR)
++      install -m 0755 tc $(DESTDIR)$(SBINDIR)
+       for i in $(TCSO); \
+-      do install -m 755 -s $$i $(DESTDIR)/usr/lib/tc; \
++      do install -m 755 $$i $(DESTDIR)/usr/lib/tc; \
+       done
+ clean:
index c417280..7162231 100644 (file)
@@ -1,16 +1,13 @@
 DESCRIPTION = "kernel routing and traffic control utilities"
+HOMEPAGE = "http://linux-net.osdl.org/index.php/Iproute2"
 SECTION = "base"
 LICENSE = "GPL"
 DEPENDS = "flex-native bison-native"
 
-# This changed from iproute2 to iproute with version 2.6.20, so set to
-# iproute in the recipe for 2.6.20 and newer versions.
-DIRNAME ?= "${PN}"
-
 # Set the DATE in the .bb file
 SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}-${DATE}.tar.gz"
 
-S = "${WORKDIR}/${DIRNAME}-${PV}-${DATE}"
+# Set S in the .bb files
 
 inherit update-alternatives
 
index 9d26192..5cdbdc7 100644 (file)
@@ -1,8 +1,10 @@
 PR = "r3"
 
+DATE = "060323"
+
 SRC_URI_append = " file://iproute2-2.6.15_no_strip.diff;patch=1;pnum=0 \
                    file://new-flex-fix.patch;patch=1"
 
-require iproute2.inc
+S = "${WORKDIR}/iproute2-${PV}-${DATE}"
 
-DATE = "060323"
+require iproute2.inc
index ad62b53..ed5f3a1 100644 (file)
@@ -1,8 +1,10 @@
 PR = "r2"
 
+DATE = "061002"
+
 SRC_URI_append = " file://iproute2-2.6.15_no_strip.diff;patch=1;pnum=0 \
                    file://new-flex-fix.patch;patch=1"
 
-require iproute2.inc
+S = "${WORKDIR}/iproute2-${PV}-${DATE}"
 
-DATE = "061002"
+require iproute2.inc
index 5efdf98..9894bf0 100644 (file)
@@ -1,11 +1,12 @@
 PR = "r2"
 
+DATE = "070313"
+
 SRC_URI_append = " file://new-flex-fix.patch;patch=1 \
                    file://ip6tunnel.patch;patch=1 \
                    file://man-pages-fix.patch;patch=1 \
                    file://no-strip.patch;patch=1"
 
-require iproute2.inc
+S = "${WORKDIR}/iproute-${PV}-${DATE}"
 
-DIRNAME = "iproute"
-DATE = "070313"
+require iproute2.inc
diff --git a/packages/iproute2/iproute2_2.6.22.bb b/packages/iproute2/iproute2_2.6.22.bb
new file mode 100644 (file)
index 0000000..7115c58
--- /dev/null
@@ -0,0 +1,10 @@
+PR = "r0"
+
+DATE = "070710"
+
+SRC_URI_append = " file://new-flex-fix.patch;patch=1 \
+                   file://no-strip.patch;patch=1"
+
+S = "${WORKDIR}"
+
+require iproute2.inc