[iotop] Make the installed package work
authorHolger Hans Peter Freyther <zecke@openmoko.org>
Mon, 21 Jul 2008 17:37:45 +0000 (19:37 +0200)
committerHolger Freyther <ich@tamarin.(none)>
Wed, 15 Oct 2008 16:53:39 +0000 (18:53 +0200)
packages/iotop/iotop_0.2.1.bb

index 64d2a36..9d4d93c 100644 (file)
@@ -1,6 +1,14 @@
 HOMEPAGE = "http://guichaz.free.fr/iotop/"
 LICENSE = "GPL"
+PR = "r1"
+
+RDEPENDS = "python-distutils python-curses python-setuptools python-textutils"
 
 SRC_URI = "http://guichaz.free.fr/iotop/files/${PN}-${PV}.tar.bz2"
 
 inherit distutils
+
+do_install_prepend() {
+    rm -f ${D}${libdir}/${PYTHON_DIR}/site-packages/site.pyo
+    rm -f ${D}${libdir}/${PYTHON_DIR}/site-packages/site.py
+}