git: Add git and git-native packages. git-native may need some addition dependencies...
authorRichard Purdie <rpurdie@rpsys.net>
Tue, 13 Sep 2005 14:34:15 +0000 (14:34 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Tue, 13 Sep 2005 14:34:15 +0000 (14:34 +0000)
packages/git/.mtn2git_empty [new file with mode: 0644]
packages/git/files/.mtn2git_empty [new file with mode: 0644]
packages/git/files/Makefile.patch [new file with mode: 0644]
packages/git/git-native.bb [new file with mode: 0644]
packages/git/git.bb [new file with mode: 0644]

diff --git a/packages/git/.mtn2git_empty b/packages/git/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/git/files/.mtn2git_empty b/packages/git/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/git/files/Makefile.patch b/packages/git/files/Makefile.patch
new file mode 100644 (file)
index 0000000..0a82649
--- /dev/null
@@ -0,0 +1,13 @@
+Index: git-snapshot-20050912/Makefile
+===================================================================
+--- git-snapshot-20050912.orig/Makefile        2005-09-11 03:46:53.000000000 +0100
++++ git-snapshot-20050912/Makefile     2005-09-12 12:18:38.000000000 +0100
+@@ -239,7 +240,7 @@
+       $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+ git-%: %.o $(LIB_FILE)
+-      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++      $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) $(LDFLAGS)
+ git-mailinfo : SIMPLE_LIB += $(LIB_4_ICONV)
+ $(SIMPLE_PROGRAMS) : $(LIB_FILE)
diff --git a/packages/git/git-native.bb b/packages/git/git-native.bb
new file mode 100644 (file)
index 0000000..1bd495f
--- /dev/null
@@ -0,0 +1,8 @@
+include git.bb
+inherit native
+
+do_stage () {
+       oe_runmake install bindir=${STAGING_BINDIR} \
+               template_dir=${STAGING_DIR}/${BUILD_SYS}/share/git-core/templates/ \
+               GIT_PYTHON_DIR=${STAGING_DIR}/${BUILD_SYS}/share/git-core/python
+}
diff --git a/packages/git/git.bb b/packages/git/git.bb
new file mode 100644 (file)
index 0000000..3a1228d
--- /dev/null
@@ -0,0 +1,21 @@
+SECTION = "console/utils"
+LICENSE = "GPL"
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+DEPENDS = "openssl curl"
+MAINTAINER = "Richard Purdie <rpurdie@rpsys.net>"
+
+PKGDATE = "${@time.strftime('%Y-%m-%d',time.gmtime())}"
+
+SRC_URI = "http://www.codemonkey.org.uk/projects/git-snapshots/git/git-${PKGDATE}.tar.gz \
+           file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/git-snapshot-${DATE}"
+
+FILES_${PN} += "${datadir}/git-core"
+
+do_install () {
+       oe_runmake install prefix=${D} bindir=${D}${bindir} \
+               template_dir=${D}${datadir}/git-core/templates \
+               GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+