geode-drivers: GeodeGX/5535 GeodeLX/5536 kernel modules.
authorRaymond Danks <raymond@edanks.com>
Tue, 18 Apr 2006 01:29:34 +0000 (01:29 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Tue, 18 Apr 2006 01:29:34 +0000 (01:29 +0000)
packages/geode-drivers/.mtn2git_empty [new file with mode: 0644]
packages/geode-drivers/geode-accessbus5536_2.6.11.bb [new file with mode: 0644]
packages/geode-drivers/geode-aeslx_2.6.11.bb [new file with mode: 0644]
packages/geode-drivers/geode-alsa5536_2.6.11.bb [new file with mode: 0644]
packages/geode-drivers/geode-modules.inc [new file with mode: 0644]
packages/geode-drivers/geode-v4l2lx_2.6.11.bb [new file with mode: 0644]

diff --git a/packages/geode-drivers/.mtn2git_empty b/packages/geode-drivers/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/geode-drivers/geode-accessbus5536_2.6.11.bb b/packages/geode-drivers/geode-accessbus5536_2.6.11.bb
new file mode 100644 (file)
index 0000000..97071bc
--- /dev/null
@@ -0,0 +1,13 @@
+# AccessBus OE build file for the AMD Geode 5535/5536
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Linux Access Bus driver for the AMD Geode 5535/5536"
+HOMEPAGE = "http://www.amd.com/embedded"
+MAINTAINER = "Raymond Danks <raymondd@ia.amd.com>"
+
+PR = "r0"
+AMD_DRIVER_VERSION = "01.00.0401"
+AMD_DRIVER_LABEL = "AccessBus_Linux_5536_${AMD_DRIVER_VERSION}"
+
+include geode-modules.inc
\ No newline at end of file
diff --git a/packages/geode-drivers/geode-aeslx_2.6.11.bb b/packages/geode-drivers/geode-aeslx_2.6.11.bb
new file mode 100644 (file)
index 0000000..03b04d5
--- /dev/null
@@ -0,0 +1,20 @@
+# AES OE build file for the AMD Geode LX
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Linux AES Driver for the AMD Geode LX processor"
+HOMEPAGE = "http://www.amd.com/embedded"
+MAINTAINER = "Raymond Danks <raymondd@ia.amd.com>"
+
+PR = "r0"
+AMD_DRIVER_VERSION = "02.01.0100"
+AMD_DRIVER_LABEL = "AES_Linux_LX_${AMD_DRIVER_VERSION}"
+
+include geode-modules.inc
+
+FILES_${PN} += " /etc"
+
+do_install_append(){ 
+        install -d ${D}/etc/modules.d
+        echo options geodeaes rsvd_mem=0x200000 > ${D}/etc/modules.d/aes
+}
diff --git a/packages/geode-drivers/geode-alsa5536_2.6.11.bb b/packages/geode-drivers/geode-alsa5536_2.6.11.bb
new file mode 100644 (file)
index 0000000..8e3b85b
--- /dev/null
@@ -0,0 +1,13 @@
+# ALSA OE build file for the AMD Geode 5535/5536
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Linux 2.6.11 ALSA Audio Driver for the AMD Geode 5535/5536 companion chip"
+HOMEPAGE = "http://www.amd.com/embedded"
+MAINTAINER = "Raymond Danks <raymondd@ia.amd.com>"
+
+PR = "r0"
+AMD_DRIVER_VERSION = "1.00.0500"
+AMD_DRIVER_LABEL = "Audio_LinuxALSA_5536_${AMD_DRIVER_VERSION}"
+
+include geode-modules.inc
\ No newline at end of file
diff --git a/packages/geode-drivers/geode-modules.inc b/packages/geode-drivers/geode-modules.inc
new file mode 100644 (file)
index 0000000..6d3d236
--- /dev/null
@@ -0,0 +1,24 @@
+# Linux kernel modules OE build files for the AMD Geode GX5535/LX5536
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+LICENSE = "GPL"
+HOMEPAGE = "http://www.amd.com/embedded"
+MAINTAINER = "Raymond Danks <raymondd@ia.amd.com>"
+
+inherit autotools module-base
+
+export ARCH="i386"
+
+DEPENDS += " virtual/kernel"
+
+S="${WORKDIR}/${AMD_DRIVER_LABEL}"
+
+PACKAGES="${PN}"
+FILES_${PN} = "/lib"
+
+KERNEL_SOURCE = ${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')}
+
+EXTRA_OECONF="--with-kernel-path=${KERNEL_SOURCE} --with-module-path=${D}/lib/modules"
+
+SRC_URI = "http://www.amd.com/files/connectivitysolutions/geode/geode_lx/${AMD_DRIVER_LABEL}.tar.gz"
diff --git a/packages/geode-drivers/geode-v4l2lx_2.6.11.bb b/packages/geode-drivers/geode-v4l2lx_2.6.11.bb
new file mode 100644 (file)
index 0000000..cc80a2c
--- /dev/null
@@ -0,0 +1,17 @@
+# V4L2 OE build file for the AMD Geode LX
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Linux video capture/overlay driver for the AMD Geode LX"
+HOMEPAGE = "http://www.amd.com/embedded"
+MAINTAINER = "Raymond Danks <raymondd@ia.amd.com>"
+
+PR = "r0"
+AMD_DRIVER_VERSION = "03.02.0100"
+AMD_DRIVER_LABEL = "Graphics_Video4Linux2_LX_${AMD_DRIVER_VERSION}"
+
+include geode-modules.inc
+
+S="${WORKDIR}/${AMD_DRIVER_LABEL}/lxv4l2"
+
+export EXTRA_CFLAGS += " -DLINUX_2_6=1"
\ No newline at end of file