use RRECOMMENDS instead of RDEPENDS for some packages
authorghost <andreas.monzner@multimedia-labs.de>
Tue, 16 Feb 2010 15:52:35 +0000 (16:52 +0100)
committerghost <andreas.monzner@multimedia-labs.de>
Tue, 16 Feb 2010 15:52:35 +0000 (16:52 +0100)
conf/machine/dm500hd.conf
conf/machine/dm800.conf
conf/machine/dm8000.conf
recipes/enigma2/enigma2.bb
recipes/tasks/task-opendreambox-base.bb
recipes/tasks/task-opendreambox-cdplayer.bb
recipes/tasks/task-opendreambox-dvbapi2.bb
recipes/tasks/task-opendreambox-dvbapi3.bb
recipes/tasks/task-opendreambox-dvdplayer.bb
recipes/tasks/task-opendreambox-enigma2.bb

index 7005fa3..31ff04a 100644 (file)
@@ -11,8 +11,10 @@ PREFERRED_VERSION_wpa-supplicant = "0.5.10"
 COMBINED_FEATURES_append = "${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '', 'nl80211', d)}"
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.18 = "\
+"
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.18 = "\
        kernel-module-cifs \
-       kernel-module-cdfs \
        kernel-module-exportfs \
        kernel-module-ext2 \
        kernel-module-reiserfs \
@@ -21,24 +23,27 @@ MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.18 = "\
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.3x = "\
        kernel-module-autofs4 \
-       kernel-module-cdrom \
-       kernel-module-cifs \
        kernel-module-dvb-core \
-       kernel-module-exportfs \
-       kernel-module-ext2 \
        kernel-module-fb \
-       kernel-module-isofs \
-       kernel-module-reiserfs \
        kernel-module-sg \
        kernel-module-snd-pcm \
        kernel-module-snd \
        kernel-module-sr-mod \
        kernel-module-stv0299 \
        kernel-module-usbhid \
+"
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.3x = "\
+       kernel-module-cdrom \
+       kernel-module-cifs \
+       kernel-module-exportfs \
+       kernel-module-ext2 \
+       kernel-module-reiserfs \
        kernel-module-xfs \
 "
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS = ${@base_contains('PREFERRED_VERSION_linux-dm500hd', '2.6.18', '${MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.18}', '${MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.3x}', d)}
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS = ${@base_contains('PREFERRED_VERSION_linux-dm500hd', '2.6.18', '${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.18}', '${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.3x}', d)}
 
 KERNEL_EXTRA_CMD = ${@base_contains('PREFERRED_VERSION_linux-dm500hd', '2.6.18', '--disable-compressor=lzo ', '', d)}
 
@@ -68,4 +73,6 @@ IMAGE_CMD_jffs2 = "\
 GLIBC_EXTRA_OECONF = "--disable-profile --with-tls --with-__thread"
 TARGET_FPU = "hard"
 
+MACHINE_FEATURES += "modem"
+
 require conf/machine/include/dreambox-mipsel.inc
index 46c0530..b5cc6f9 100644 (file)
@@ -11,8 +11,10 @@ PREFERRED_VERSION_wpa-supplicant = "0.5.10"
 COMBINED_FEATURES_append = "${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '', 'nl80211', d)}"
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.18 = "\
+"
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.18 = "\
        kernel-module-cifs \
-       kernel-module-cdfs \
        kernel-module-exportfs \
        kernel-module-ext2 \
        kernel-module-reiserfs \
@@ -21,24 +23,27 @@ MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.18 = "\
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.3x = "\
        kernel-module-autofs4 \
-       kernel-module-cdrom \
-       kernel-module-cifs \
        kernel-module-dvb-core \
-       kernel-module-exportfs \
-       kernel-module-ext2 \
        kernel-module-fb \
-       kernel-module-isofs \
-       kernel-module-reiserfs \
        kernel-module-sg \
        kernel-module-snd-pcm \
        kernel-module-snd \
        kernel-module-sr-mod \
        kernel-module-stv0299 \
        kernel-module-usbhid \
+"
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.3x = "\
+       kernel-module-cdrom \
+       kernel-module-cifs \
+       kernel-module-exportfs \
+       kernel-module-ext2 \
+       kernel-module-reiserfs \
        kernel-module-xfs \
 "
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS = ${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '${MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.18}', '${MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.3x}', d)}
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS = ${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.18}', '${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.3x}', d)}
 
 KERNEL_EXTRA_CMD = ${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '--disable-compressor=lzo ', '', d)}
 
@@ -65,4 +70,6 @@ IMAGE_CMD_jffs2 = "\
                ${MACHINE} 64 \
                > ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.nfi"
 
+MACHINE_FEATURES += "modem"
+
 require conf/machine/include/dreambox-mipsel.inc
index 4304741..6a2f214 100644 (file)
@@ -14,13 +14,6 @@ COMBINED_FEATURES_append = "${@base_contains('PREFERRED_VERSION_linux-dm8000', '
 #JAVA_mipsel = ",java"
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.18 = "\
-       kernel-module-cifs \
-       kernel-module-cdfs \
-       kernel-module-exportfs \
-       kernel-module-ext2 \
-       kernel-module-reiserfs \
-       kernel-module-xfs \
-       kernel-module-udf \
        kernel-module-dvb-core \
        kernel-module-stv0299 \
        kernel-module-fb \
@@ -28,26 +21,37 @@ MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.18 = "\
        kernel-module-snd \
 "
 
-MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.3x = "\
-       kernel-module-autofs4 \
-       kernel-module-cdrom \
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.18 = "\
        kernel-module-cifs \
-       kernel-module-dvb-core \
        kernel-module-exportfs \
        kernel-module-ext2 \
-       kernel-module-fb \
-       kernel-module-isofs \
        kernel-module-reiserfs \
+       kernel-module-xfs \
+"
+
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.3x = "\
+       kernel-module-autofs4 \
+       kernel-module-dvb-core \
+       kernel-module-fb \
        kernel-module-sg \
        kernel-module-snd-pcm \
        kernel-module-snd \
        kernel-module-sr-mod \
        kernel-module-stv0299 \
        kernel-module-usbhid \
+"
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.3x = "\
+       kernel-module-cdrom \
+       kernel-module-cifs \
+       kernel-module-exportfs \
+       kernel-module-ext2 \
+       kernel-module-reiserfs \
        kernel-module-xfs \
 "
 
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS = ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '${MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.18}', '${MACHINE_ESSENTIAL_EXTRA_RDEPENDS_2.6.3x}', d)}
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS = ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.18}', '${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS_2.6.3x}', d)}
 
 KERNEL_EXTRA_CMD = ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '--disable-compressor=lzo ', '', d)}
 
index 19d5e45..0402128 100755 (executable)
@@ -6,14 +6,14 @@ DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
        gst-plugins-bad gst-plugins-good gst-plugins-ugly"
 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
        python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
-       gst-plugin-queue2 gst-plugin-app \
+       python-pickle gst-plugin-queue2 gst-plugin-app \
        gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
        gst-plugin-typefindfunctions gst-plugin-ivorbis gst-plugin-audioconvert gst-plugin-audioresample \
        gst-plugin-wavparse python-netclient gst-plugin-mpegstream gst-plugin-selector \
        gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux \
        gst-plugin-neonhttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
        gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect \
-       glibc-gconv-iso8859-15"
+       glibc-gconv-iso8859-15 ethtool"
 
 RDEPENDS_append_dm7020 = " gst-plugin-ossaudio"
 RDEPENDS_append_dm7025 = " gst-plugin-alsa alsa-conf"
@@ -47,7 +47,7 @@ DESCRIPTION_append_enigma2-plugin-systemplugins-crashlogautosubmit = "automatica
 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "twisted-mail twisted-names python-compression python-mime python-email"
 DESCRIPTION_append_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
 DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
-RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts"
+RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools"
 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
@@ -55,7 +55,7 @@ DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy s
 PN = "enigma2"
 PR = "r0"
 
-SRCDATE = "20100213"
+SRCDATE = "20100216"
 #SRCDATE is NOT used by git to checkout a specific revision
 #but we need it to build a ipk package version
 #when you like to checkout a specific revision of e2 you need
index 30d08b5..7af16bf 100644 (file)
@@ -15,13 +15,10 @@ OPENDREAMBOX_BASE_ESSENTIAL = "\
   base-files-doc \
   dreambox-bootlogo \
   dreambox-compat \
-  dreambox-dccamd \
   dreambox-wdog \
   dreambox-tpmd \
   dreambox-feed-configs \
   dreambox-keymaps \
-  dropbear \
-  dvbsnoop \
   e2fsprogs-e2fsck \
   e2fsprogs-mke2fs \
   fakelocale \
@@ -33,7 +30,14 @@ OPENDREAMBOX_BASE_ESSENTIAL = "\
   vsftpd \
 "
 
-OPENDREAMBOX_BASE_OPTIONAL = "\
+OPENDREAMBOX_BASE_RECOMMENDS = "\
+  dropbear \
+  dreambox-dccamd \
+  sambaserver \
+  zeroconf \
+"
+
+OPENDREAMBOX_BASE_OPTIONAL_RECOMMENDS = "\
   gdbserver \
   hddtemp \
   joe \
@@ -44,10 +48,13 @@ OPENDREAMBOX_BASE_OPTIONAL = "\
 
 RDEPENDS_${PN} = "\
        ${OPENDREAMBOX_BASE_ESSENTIAL} \
-       ${OPENDREAMBOX_BASE_OPTIONAL} \
 "
 
-RDEPENDS_${PN}_dm7025 = "\
-       ${OPENDREAMBOX_BASE_ESSENTIAL} \
+RRECOMMENDS_${PN} = "\
+       ${OPENDREAMBOX_BASE_RECOMMENDS} \
+       ${OPENDREAMBOX_BASE_OPTIONAL_RECOMMENDS} \
 "
 
+RRECOMMENDS_${PN}_dm7025 = "\
+       ${OPENDREAMBOX_BASE_RECOMMENDS} \
+"
index 175cc7b..0d47dc2 100644 (file)
@@ -11,6 +11,7 @@ inherit task
 DESCRIPTION_${PN} = "OpenDreambox: CD-Player Support"
 DEPENDS_${PN} = "enigma2-plugins"
 RDEPENDS_${PN} = "\
+ kernel-module-cdfs \
  enigma2-plugin-extensions-cdinfo \
  libcddb \
  libcdio \
index 489dad4..5e2f342 100644 (file)
@@ -16,6 +16,7 @@ PROVIDES = "\
 RPROVIDES_${PN} = "task-opendreambox-dvbapi"
 DESCRIPTION_${PN} = "OpenDreambox: DVB API v2 Dependencies"
 RDEPENDS_${PN} = "\
+  dvbsnoop \
   dreambox-dvb-tools \
   tuxbox-stream \
 "
index 7b3cf02..d2c4ce1 100644 (file)
@@ -16,6 +16,7 @@ PROVIDES = "\
 RPROVIDES_${PN} = "task-opendreambox-dvbapi"
 DESCRIPTION_${PN} = "OpenDreambox: DVB API v3 Dependencies"
 RDEPENDS_${PN} = "\
+  dvbsnoop \
   dreambox-dvb-tools-v3 \
   dvbtraffic \
   sctzap \
index 67664a5..a81cee8 100644 (file)
@@ -11,6 +11,7 @@ inherit task
 DESCRIPTION_${PN} = "OpenDreambox: DVD-Player Support"
 DEPENDS_${PN} = "enigma2
 RDEPENDS_${PN} = "\
+  kernel-module-udf \
   enigma2-plugin-extensions-dvdplayer \
 "
 
index f5624a0..6306e65 100755 (executable)
@@ -20,35 +20,36 @@ PACKAGES = "\
 RPROVIDES_task-opendreambox-enigma2 = "task-opendreambox-ui"
 DESCRIPTION_task-opendreambox-enigma2 = "OpenDreambox: Enigma2 Dependencies"
 RDEPENDS_task-opendreambox-enigma2 = "\
-  aio-grab \
   dreambox-blindscan-utils \
   enigma2 \
   enigma2-defaultservices \
-  enigma2-plugin-extensions-cutlisteditor \
-  enigma2-plugin-extensions-graphmultiepg \
-  enigma2-plugin-extensions-mediaplayer \
   enigma2-plugin-extensions-mediascanner \
-  enigma2-plugin-extensions-pictureplayer \
-  enigma2-plugin-extensions-webinterface \
   enigma2-plugin-systemplugins-frontprocessorupgrade \
   enigma2-plugin-systemplugins-hotplug \
   enigma2-plugin-systemplugins-networkwizard \
-  enigma2-plugin-systemplugins-positionersetup \
-  enigma2-plugin-systemplugins-satfinder \
-  enigma2-plugin-systemplugins-skinselector \
   enigma2-plugin-systemplugins-softwaremanager \
   enigma2-plugin-systemplugins-videotune \
   enigma2-streamproxy \
-  ethtool \
+  tuxbox-tuxtxt-32bpp \
+"
+
+RRECOMMENDS_task-opendreambox-enigma2 = "\
+  aio-grab \
   python-crypt \
   python-netserver \
-  python-pickle \
   python-twisted-core \
   python-twisted-protocols \
   python-twisted-web \
-  tuxbox-tuxtxt-32bpp \
-  ${@base_contains("MACHINE_FEATURES", "modem", "task-opendreambox-modem", "", d)} \
+  enigma2-plugin-extensions-cutlisteditor \
+  enigma2-plugin-extensions-graphmultiepg \
+  enigma2-plugin-extensions-mediaplayer \
+  enigma2-plugin-extensions-pictureplayer \
+  enigma2-plugin-extensions-webinterface \
+  enigma2-plugin-systemplugins-satfinder \
+  enigma2-plugin-systemplugins-positionersetup \
+  enigma2-plugin-systemplugins-skinselector \
   ${@base_contains("MACHINE_FEATURES", "wifi", "task-opendreambox-wlan", "", d)} \
+  ${@base_contains("MACHINE_FEATURES", "modem", "task-opendreambox-modem", "", d)} \
 "
 
 RDEPENDS_task-opendreambox-enigma2_append_dm500hd = "\
@@ -65,6 +66,9 @@ RDEPENDS_task-opendreambox-enigma2_append_dm8000 = "\
   enigma2-plugin-extensions-genuinedreambox \
   enigma2-plugin-systemplugins-commoninterfaceassignment \
   enigma2-plugin-systemplugins-videomode \
+"
+
+RRECOMMENDS_task-opendreambox-enigma2_append_dm8000 = "\
   task-opendreambox-cdplayer \
   task-opendreambox-dvdplayer \
   task-opendreambox-dvdburn \