gpe-session-scripts: replace /usr/bin with ${bindir} in 0.67
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>
Sat, 13 Jun 2009 15:10:28 +0000 (00:10 +0900)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Sat, 13 Jun 2009 15:48:37 +0000 (00:48 +0900)
* same as commit a729981b8a3e27e800078ccfd05249eef42b7ae4

recipes/gpe-session-scripts/gpe-session-scripts_0.67.bb

index bab26e7..979ed5a 100644 (file)
@@ -41,15 +41,15 @@ do_install_append() {
        install -d ${D}${sysconfdir}/gpe/xsettings-default.d
        install -m 0644 ${WORKDIR}/disable-composite.xsettings ${D}${sysconfdir}/gpe/xsettings-default.d/disable-composite
 
-       mv ${D}/usr/bin/gpe-logout ${D}/usr/bin/gpe-logout.matchbox
+       mv ${D}${bindir}gpe-logout ${D}${bindir}gpe-logout.matchbox
 }
 
 pkg_postinst_${PN}() {
-       update-alternatives --install /usr/bin/gpe-logout gpe-logout /usr/bin/gpe-logout.matchbox 10
+       update-alternatives --install ${bindir}gpe-logout gpe-logout ${bindir}gpe-logout.matchbox 10
 }
 
 pkg_postrm_${PN}() {
-       update-alternatives --remove gpe-logout /usr/bin/gpe-logout.matchbox
+       update-alternatives --remove gpe-logout ${bindir}gpe-logout.matchbox
 }
 
 # This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately