bootsplash: make it building - close #346
authorMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 27 Apr 2006 21:46:20 +0000 (21:46 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Thu, 27 Apr 2006 21:46:20 +0000 (21:46 +0000)
packages/bootsplash/bootsplash-native_3.0.7.bb
packages/bootsplash/bootsplash_3.0.7.bb
packages/bootsplash/files/.mtn2git_empty [new file with mode: 0644]
packages/bootsplash/files/freetype2.patch [new file with mode: 0644]

index ccc9377..df368ce 100644 (file)
@@ -8,7 +8,7 @@ inherit native
 S="${WORKDIR}/bootsplash-${PV}"
 
 do_compile() {
-       oe_runmake -C Utilities splash
+       oe_runmake splash
 }
 
 do_stage() {
index da2290e..9ffa97d 100644 (file)
@@ -6,12 +6,18 @@ DESCRIPTION="Bootsplash shows pretty pictures during boot"
 HOMEPAGE="http://www.bootsplash.org"
 SECTION = "media-gfx"
 LICENSE = "GPL"
-SRC_URI="ftp://ftp.openbios.org/pub/bootsplash/rpm-sources/bootsplash/bootsplash-${PV}.tar.bz2"
+SRC_URI="ftp://ftp.openbios.org/pub/bootsplash/rpm-sources/bootsplash/bootsplash-${PV}.tar.bz2 \
+         file://freetype2.patch;patch=1"
 
-DEPENDS="freetype"
+DEPENDS="freetype libmng"
+PR = "r1"
+
+EXTRA_OEMAKE += "-C Utilities \
+               CFLAGS='${CFLAGS} -I${STAGING_INCDIR}/freetype2/ -I${STAGING_INCDIR}' \
+               LDFLAGS='${LDFLAGS} -L${STAGING_LIBDIR} -ljpeg'"
 
 do_compile() {
-       oe_runmake -C Utilities 
+       oe_runmake
 }
 
 do_install() {
diff --git a/packages/bootsplash/files/.mtn2git_empty b/packages/bootsplash/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/bootsplash/files/freetype2.patch b/packages/bootsplash/files/freetype2.patch
new file mode 100644 (file)
index 0000000..3683c62
--- /dev/null
@@ -0,0 +1,15 @@
+Index: bootsplash-3.0.7/Utilities/ttf.c
+===================================================================
+--- bootsplash-3.0.7.orig/Utilities/ttf.c      2003-08-09 11:58:44.000000000 +0200
++++ bootsplash-3.0.7/Utilities/ttf.c   2006-04-04 11:26:54.210699456 +0200
+@@ -9,8 +9,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <ft2build.h> 
++#include FT_FREETYPE_H
+-#include <freetype/freetype.h>
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>