merge of 3a8d976edec8e170e572b6281c1d290e82e766ee
authorMichael Lauer <mickey@vanille-media.de>
Fri, 26 Aug 2005 09:47:31 +0000 (09:47 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Fri, 26 Aug 2005 09:47:31 +0000 (09:47 +0000)
     and dc2238d7bd47c01641da36969ca532175cee09d9

28 files changed:
packages/gpe-buttonbox/.mtn2git_empty [new file with mode: 0644]
packages/gpe-buttonbox/gpe-buttonbox_cvs.bb [new file with mode: 0644]
packages/gpe-session-scripts/gpe-session-scripts_0.64.bb [new file with mode: 0644]
packages/hostap/hostap-daemon-0.4.4/.mtn2git_empty [new file with mode: 0644]
packages/hostap/hostap-daemon-0.4.4/defconfig [new file with mode: 0644]
packages/hostap/hostap-daemon-0.4.4/init [new file with mode: 0644]
packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff [new file with mode: 0644]
packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff [new file with mode: 0644]
packages/hostap/hostap-daemon-0.4.4/mtx-1/.mtn2git_empty [new file with mode: 0644]
packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig [new file with mode: 0644]
packages/hostap/hostap-daemon_0.4.4.bb [new file with mode: 0644]
packages/hostap/hostap-utils_0.4.0.bb [new file with mode: 0644]
packages/kdepimpi/kdepimpi_2.2.2.bb [deleted file]
packages/kdepimpi/kdepimpi_2.2.3.bb [new file with mode: 0644]
packages/kdepimpi/pwmpi_2.2.2.bb [deleted file]
packages/kdepimpi/pwmpi_2.2.3.bb [new file with mode: 0644]
packages/libdvb/files/.mtn2git_empty [new file with mode: 0644]
packages/libdvb/files/topf2ps.patch [new file with mode: 0644]
packages/libdvb/libdvb_0.5.5.1.bb
packages/linux-hotplug/linux-hotplug_20040329.bb
packages/linux-hotplug/linux-hotplug_20040920.bb
packages/meta/e-image-core.bb [new file with mode: 0644]
packages/meta/e-image.bb
packages/meta/meta-e-x11.bb
packages/meta/meta-sdk.bb
packages/scap/files/scap.desktop
packages/scap/files/scap.sh
packages/scap/scap_0.1.bb

diff --git a/packages/gpe-buttonbox/.mtn2git_empty b/packages/gpe-buttonbox/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gpe-buttonbox/gpe-buttonbox_cvs.bb b/packages/gpe-buttonbox/gpe-buttonbox_cvs.bb
new file mode 100644 (file)
index 0000000..44c2779
--- /dev/null
@@ -0,0 +1,15 @@
+LICENSE =      "GPL"
+DESCIPTION =   "Buttonbox for gpe"
+
+SRC_URI =      "cvs://anoncvs:anoncvs@cvs.handhelds.org/cvs;module=gpe/base/gpe-buttonbox"
+
+DEPENDS =      "libgpewidget libgpelaunch"
+
+S =            "${WORKDIR}/${PN}"
+PV =           "0.0+cvs-${CVSDATE}"
+PR =           "r1"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/gpe"
+
diff --git a/packages/gpe-session-scripts/gpe-session-scripts_0.64.bb b/packages/gpe-session-scripts/gpe-session-scripts_0.64.bb
new file mode 100644 (file)
index 0000000..cf62a9a
--- /dev/null
@@ -0,0 +1,31 @@
+LICENSE = "GPL"
+PR = "r0"
+
+inherit gpe
+
+DESCRIPTION = "GPE session startup scripts"
+SECTION = "gpe"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+RDEPENDS_${PN} = "matchbox gpe-session-starter gpe-bluetooth xstroke xtscal gpe-question gpe-clock matchbox-applet-inputmanager xrandr xmodmap xdpyinfo x11-common"
+# more rdepends: keylaunch ipaq-sleep apmd blueprobe
+DEPENDS = "matchbox-wm matchbox-panel gpe-bluetooth xstroke xtscal gpe-question matchbox-applet-inputmanager gpe-clock xrandr xmodmap xdpyinfo x11-common"
+
+SRC_URI += "file://matchbox-session \
+       file://disable-composite.xsettings \
+        file://remove-x11-common-files.patch;patch=1"
+
+do_install_append() {
+       install -d ${D}${sysconfdir}/gpe/xsettings-default.d
+       if [ "${GUI_MACHINE_CLASS}" != "bigscreen" ]; then
+               echo "Gtk/ToolbarStyle:S:icons" > ${D}${sysconfdir}/gpe/xsettings-default.d/toolbar
+       fi
+       install -d ${D}${sysconfdir}/matchbox
+       install ${WORKDIR}/matchbox-session ${D}${sysconfdir}/matchbox/session
+
+       install -d ${D}${sysconfdir}/gpe/xsettings-default.d
+       install -m 0644 ${WORKDIR}/disable-composite.xsettings ${D}${sysconfdir}/gpe/xsettings-default.d/disable-composite
+}
+
+# This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/packages/hostap/hostap-daemon-0.4.4/.mtn2git_empty b/packages/hostap/hostap-daemon-0.4.4/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/hostap/hostap-daemon-0.4.4/defconfig b/packages/hostap/hostap-daemon-0.4.4/defconfig
new file mode 100644 (file)
index 0000000..d0e22f2
--- /dev/null
@@ -0,0 +1,66 @@
+# Example hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+CONFIG_DRIVER_WIRED=y
+
+# Driver interface for madwifi driver
+#CONFIG_DRIVER_MADWIFI=y
+#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
+
+# Driver interface for Prism54 driver
+CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# IEEE 802.11F/IAPP
+CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# Integrated EAP authenticator
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP authenticator
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP authenticator
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP authenticator
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP authenticator
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP authenticator
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP authenticator
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP authenticator
+#CONFIG_EAP_SIM=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# authenticator from external hosts using RADIUS.
+CONFIG_RADIUS_SERVER=y
diff --git a/packages/hostap/hostap-daemon-0.4.4/init b/packages/hostap/hostap-daemon-0.4.4/init
new file mode 100644 (file)
index 0000000..b0736c0
--- /dev/null
@@ -0,0 +1,39 @@
+#!/bin/sh
+DAEMON=/usr/sbin/hostapd
+NAME=httpd
+DESC="HOSTAP Daemon"
+ARGS="/etc/hostapd.conf"
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+    start)
+        echo -n "starting $DESC: $NAME... "
+       start-stop-daemon -S -b -n $NAME -a $DAEMON -- $ARGS
+       echo "done."
+       ;;
+    stop)
+        echo -n "stopping $DESC: $NAME... "
+       start-stop-daemon -K -n $NAME
+       echo "done."
+       ;;
+    restart)
+        echo "restarting $DESC: $NAME... "
+       $0 stop
+       $0 start
+       echo "done."
+       ;;
+    reload)
+       echo -n "reloading $DESC: $NAME... "
+       killall -HUP $(basename ${DAEMON})
+       echo "done."
+       ;;
+    *)
+       echo "Usage: $0 {start|stop|restart|reload}"
+       exit 1
+       ;;
+esac
+
+exit 0
diff --git a/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff b/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff
new file mode 100644 (file)
index 0000000..d9dab26
--- /dev/null
@@ -0,0 +1,12 @@
+--- driver_madwifi.c.orig      2005-03-18 15:12:53.392793216 +0100
++++ driver_madwifi.c   2005-03-18 15:13:09.246383104 +0100
+@@ -21,7 +21,8 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+-#include <include/compat.h>
++#include <net80211/compat.h>
++#include <net80211/_ieee80211.h>
+ #include <net80211/ieee80211.h>
+ #include <net80211/ieee80211_crypto.h>
+ #include <net80211/ieee80211_ioctl.h>
diff --git a/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff b/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff
new file mode 100644 (file)
index 0000000..25d2ca3
--- /dev/null
@@ -0,0 +1,26 @@
+--- Makefile.orig      2005-03-18 14:34:27.274376504 +0100
++++ Makefile   2005-03-18 14:35:56.609795456 +0100
+@@ -1,7 +1,9 @@
+-CC=gcc
++CC?=gcc
+ DIR_WPA_SUPPLICANT=.
+ DIR_HOSTAP=.
++TARGET_PREFIX ?= /usr/local/bin/
++
+ ifndef CFLAGS
+ CFLAGS = -MMD -O2 -Wall -g
+ endif
+@@ -170,10 +172,10 @@
+       fi
+ install: all
+-      for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
++      for i in $(ALL); do cp $$i $(TARGET_PREFIX)/$$i; done
+ hostapd: $(OBJS)
+-      $(CC) -o hostapd $(OBJS) $(LIBS)
++      $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
+ driver_conf.c: Makefile .config
+       rm -f driver_conf.c
diff --git a/packages/hostap/hostap-daemon-0.4.4/mtx-1/.mtn2git_empty b/packages/hostap/hostap-daemon-0.4.4/mtx-1/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig b/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig
new file mode 100644 (file)
index 0000000..8c3065c
--- /dev/null
@@ -0,0 +1,66 @@
+# Example hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+CONFIG_DRIVER_WIRED=y
+
+# Driver interface for madwifi driver
+CONFIG_DRIVER_MADWIFI=y
+#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
+
+# Driver interface for Prism54 driver
+CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# IEEE 802.11F/IAPP
+CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# Integrated EAP authenticator
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP authenticator
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP authenticator
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP authenticator
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP authenticator
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP authenticator
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP authenticator
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP authenticator
+#CONFIG_EAP_SIM=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# authenticator from external hosts using RADIUS.
+CONFIG_RADIUS_SERVER=y
diff --git a/packages/hostap/hostap-daemon_0.4.4.bb b/packages/hostap/hostap-daemon_0.4.4.bb
new file mode 100644 (file)
index 0000000..9363a10
--- /dev/null
@@ -0,0 +1,31 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV}) hostap-utils (${PV})"
+DEPENDS_mtx-1_append = "madwifi-modules"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+       file://makefile-cross.diff;patch=1;pnum=0 \
+       file://madwifi-bsd-fix.diff;patch=1;pnum=0 \
+       file://defconfig \
+       file://init"
+
+S = "${WORKDIR}/hostapd-${PV}"
+
+do_configure() {
+       install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+
+do_compile() {
+       CFLAGS='${CFLAGS}' CC='${CC}' make
+}
+
+do_install() {
+       install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+       make TARGET_PREFIX=${D}${sbindir} install
+       install -m 0644 hostapd.conf ${D}${sysconfdir}
+       install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}
diff --git a/packages/hostap/hostap-utils_0.4.0.bb b/packages/hostap/hostap-utils_0.4.0.bb
new file mode 100644 (file)
index 0000000..7601129
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV})"
+PR = "r1"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+          file://hostap-fw-load.patch;patch=1"
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+           hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+       install -d ${D}${sbindir}/
+       for f in ${BINARIES}
+       do
+               install -m 0755 $f ${D}${sbindir}/
+       done
+}
+
diff --git a/packages/kdepimpi/kdepimpi_2.2.2.bb b/packages/kdepimpi/kdepimpi_2.2.2.bb
deleted file mode 100644 (file)
index f3dde1a..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-SRC_URI = "${SOURCEFORGE_MIRROR}/kdepimpi/kdepimpi-${PV}.tar.gz "
-
-include kdepimpi-base.inc
diff --git a/packages/kdepimpi/kdepimpi_2.2.3.bb b/packages/kdepimpi/kdepimpi_2.2.3.bb
new file mode 100644 (file)
index 0000000..f3dde1a
--- /dev/null
@@ -0,0 +1,3 @@
+SRC_URI = "${SOURCEFORGE_MIRROR}/kdepimpi/kdepimpi-${PV}.tar.gz "
+
+include kdepimpi-base.inc
diff --git a/packages/kdepimpi/pwmpi_2.2.2.bb b/packages/kdepimpi/pwmpi_2.2.2.bb
deleted file mode 100644 (file)
index 904f640..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-include kdepimpi_${PV}.bb
-
-include pwmpi.inc
diff --git a/packages/kdepimpi/pwmpi_2.2.3.bb b/packages/kdepimpi/pwmpi_2.2.3.bb
new file mode 100644 (file)
index 0000000..904f640
--- /dev/null
@@ -0,0 +1,3 @@
+include kdepimpi_${PV}.bb
+
+include pwmpi.inc
diff --git a/packages/libdvb/files/.mtn2git_empty b/packages/libdvb/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/libdvb/files/topf2ps.patch b/packages/libdvb/files/topf2ps.patch
new file mode 100644 (file)
index 0000000..93503ca
--- /dev/null
@@ -0,0 +1,123 @@
+diff -ruN libdvb-0.5.5/Makefile libdvb-0.5.5-topfield/Makefile
+--- libdvb-0.5.5/Makefile      2004-09-16 04:56:21.000000000 +1000
++++ libdvb-0.5.5-topfield/Makefile     2004-12-03 15:53:24.677184191 +1100
+@@ -68,7 +68,7 @@
+       make -C libdvbmpeg clean
+       make -C sample_progs clean
+       make -C dvb-mpegtools clean
+-      rm include/*~
++      -rm -f include/*~
+ dist: 
+       mkdir libdvb-$(VERSION)
+diff -ruN libdvb-0.5.5/dvb-mpegtools/Makefile libdvb-0.5.5-topfield/dvb-mpegtools/Makefile
+--- libdvb-0.5.5/dvb-mpegtools/Makefile        2004-09-16 04:56:21.000000000 +1000
++++ libdvb-0.5.5-topfield/dvb-mpegtools/Makefile       2004-12-03 12:38:58.000000000 +1100
+@@ -16,7 +16,7 @@
+       pesplot pes2ts2 pes_repack split_mpg cut_mpg ts2ps ts2es\
+       insert_pat_pmt get_http extract_pes extract_pes_payload\
+       change_aspect_1_1 change_aspect_4_3 change_aspect_16_9 \
+-      change_aspect_221_1
++      change_aspect_221_1 topf2ps
+ .PHONY: depend clean install uninstall
+diff -ruN libdvb-0.5.5/dvb-mpegtools/main.cc libdvb-0.5.5-topfield/dvb-mpegtools/main.cc
+--- libdvb-0.5.5/dvb-mpegtools/main.cc 2004-09-16 04:56:21.000000000 +1000
++++ libdvb-0.5.5-topfield/dvb-mpegtools/main.cc        2004-12-03 12:45:39.000000000 +1100
+@@ -52,7 +52,7 @@
+         write(STDOUT_FILENO, buf, count);
+ }
+-#define PROGS 29
++#define PROGS 30
+ char *prognames[PROGS+1] = { "streamtype",    // 0
+                              "ts2pes",            // 1
+@@ -83,6 +83,7 @@
+                              "change_aspect_4_3",
+                              "change_aspect_16_9",
+                              "change_aspect_221_1",   // 28
++                             "topf2ps",
+                              " "
+                            };
+@@ -116,6 +117,7 @@
+        change_aspect_4_3_,
+        change_aspect_16_9_,
+        change_aspect_221_1_,  // 28
++       topf2ps_,
+        none_,
+      };
+@@ -226,6 +228,11 @@
+                 cerr << "or     insert_pat_pmt < <filename> (or pipe)" << endl;
+                 break;
++        case topf2ps_:
++                cerr << "usage: topf2ps <filename>" << endl;
++                cerr << "or     topf2ps < <filename> (or pipe)" << endl;
++                break;
++
+         case get_http_:
+                 cerr << "usage: get_http <URL>" << endl;
+                 break;
+@@ -345,6 +352,10 @@
+                         }
+                         break;
++                case topf2ps_:
++                        topf_to_ps(fd, STDOUT_FILENO);
++                        break;
++
+                 case insert_pat_pmt_:
+                         insert_pat_pmt( fd, STDOUT_FILENO);
+                         break;
+diff -ruN libdvb-0.5.5/include/transform.h libdvb-0.5.5-topfield/include/transform.h
+--- libdvb-0.5.5/include/transform.h   2004-09-16 04:56:21.000000000 +1000
++++ libdvb-0.5.5-topfield/include/transform.h  2004-12-03 12:49:20.000000000 +1100
+@@ -192,6 +192,7 @@
+       void kpes_to_ts( p2p *p,uint8_t *buf ,int count );
+       void setup_ts2pes( p2p *pa, p2p *pv, uint32_t pida, uint32_t pidv, 
+                          void (*pes_write)(uint8_t *buf, int count, void *p));
++    void topf_to_ps(int fdin, int fdout);
+       void kts_to_pes( p2p *p, uint8_t *buf);
+       void pes_repack(p2p *p);
+       void extract_from_pes(int fdin, int fdout, uint8_t id, int es);
+diff -ruN libdvb-0.5.5/libdvbmpeg/transform.c libdvb-0.5.5-topfield/libdvbmpeg/transform.c
+--- libdvb-0.5.5/libdvbmpeg/transform.c        2004-09-16 04:56:21.000000000 +1000
++++ libdvb-0.5.5-topfield/libdvbmpeg/transform.c       2004-12-03 12:50:55.000000000 +1100
+@@ -1247,6 +1247,30 @@
+ }
++void topf_to_ps( int fdin, int fdout)
++{
++
++  uint16_t pida, pidv;
++  uint8_t buf[1880];
++  int count = 1;
++
++  if ((count = save_read(fdin, buf, sizeof(buf))) < 0)
++      perror("reading");
++
++  if ((count != sizeof(buf)) || (buf[0] != 'T') || (buf[1] != 'F') ||
++      (buf[2] != 'r') || (buf[3] != 'c')) {
++
++      fprintf(stderr, "Couldn't read Topfield header\n");
++      return;
++  }
++
++  pida = (buf[24] << 8) + buf[25];
++  pidv = ((buf[26] & 0x7f) << 8) + buf[27];
++
++        fprintf(stderr, "apid %d (0x%02x)\n",pida,pida);
++        fprintf(stderr, "vpid %d (0x%02x)\n",pidv,pidv);
++  ts_to_pes(fdin, pida, pidv, 1);
++}
+ #define INN_SIZE 2*IN_SIZE
+ void insert_pat_pmt( int fdin, int fdout)
+
+
+
index 9de5799..0e0c2b9 100644 (file)
@@ -5,9 +5,11 @@ HOMEPAGE = "http://www.metzlerbros.org/dvb/index.html"
 MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org"
 SECTION = "libs"
 PRIORITY = "optional"
-PR = "r1"
+PR = "r2"
+
+SRC_URI = "http://www.metzlerbros.org/dvb/${PN}-${PV}.tar.gz \
+         file://topf2ps.patch;patch=1"
 
-SRC_URI = "http://www.metzlerbros.org/dvb/${PN}-${PV}.tar.gz"
 S = "${WORKDIR}/${PN}-${PV}"
 
 inherit autotools pkgconfig
index 9f06cd7..06d9fae 100644 (file)
@@ -3,9 +3,10 @@ DESCRIPTION = "This package contains the scripts necessary \
 for hotplug Linux support, and lets you plug in new devices \
 and use them immediately."
 LICENSE = "GPL"
-RPROVIDES = "hotplug"
-RCONFLICTS = "hotplug"
-RREPLACES = "hotplug"
+RPROVIDES_${PN} = "hotplug"
+RCONFLICTS_${PN} = "hotplug"
+RREPLACES_${PN} = "hotplug"
+PR = "r1"
 
 SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/hotplug-2004_03_29.tar.gz \
           file://busybox.patch;patch=1 \
index db4cf3f..ce503a2 100644 (file)
@@ -3,12 +3,12 @@ for hotplug Linux support, and lets you plug in new devices \
 and use them immediately."
 HOMEPAGE = "http://linux-hotplug.sourceforge.net/"
 LICENSE = "GPL"
-RPROVIDES = "hotplug"
-RCONFLICTS = "hotplug"
-RREPLACES = "hotplug"
+RPROVIDES_${PN} = "hotplug"
+RCONFLICTS_${PN} = "hotplug"
+RREPLACES_${PN} = "hotplug"
 SECTION = "base"
 RSUGGESTS = "pciutils usbutils"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/hotplug-2004_09_20.tar.gz \
        file://userspecified_hcd.patch;patch=1 \
diff --git a/packages/meta/e-image-core.bb b/packages/meta/e-image-core.bb
new file mode 100644 (file)
index 0000000..c7a7630
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "An X11-based distribution with the Enlightenment Window Manager"
+LICENSE = "MIT"
+PR = "r0"
+
+export IMAGE_BASENAME = "e-image-core"
+export IMAGE_LINGUAS = ""
+
+DEPENDS = "task-bootstrap meta-e-x11 xserver-kdrive"
+
+PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
+PREFERRED_PROVIDER_virtual/evas = "evas-x11"
+PREFERRED_PROVIDER_virtual/ecore = "ecore-x11"
+PREFERRED_PROVIDER_virtual/imlib2 = "imlib2-x11"
+PREFERRED_PROVIDER_virtual/libxine = "libxine-x11"
+
+export IPKG_INSTALL = "task-bootstrap task-enlightenment-x11-core xserver-kdrive-fbdev"
+
+inherit image_ipk
index d58215d..2183674 100644 (file)
@@ -1,18 +1,7 @@
 DESCRIPTION = "An X11-based distribution with the Enlightenment Window Manager and Tools"
-LICENSE = "MIT"
-PR = "r1"
+PR = "r2"
 
-export IMAGE_BASENAME = "e-image"
-export IMAGE_LINGUAS = ""
-
-DEPENDS = "task-bootstrap meta-e-x11 xserver-kdrive"
-
-PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
-PREFERRED_PROVIDER_virtual/evas = "evas-x11"
-PREFERRED_PROVIDER_virtual/ecore = "ecore-x11"
-PREFERRED_PROVIDER_virtual/imlib2 = "imlib2-x11"
-PREFERRED_PROVIDER_virtual/libxine = "libxine-x11"
+include e-image-core.bb
 
-export IPKG_INSTALL = "task-bootstrap task-enlightenment-x11 xserver-kdrive-fbdev"
-
-inherit image_ipk
+export IMAGE_BASENAME = "e-image"
+export IPKG_INSTALL += "task-enlightenment-x11"
\ No newline at end of file
index 4ff955e..47bec68 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Meta-package for Enlightenment/X11"
 LICENSE = "MIT"
-PACKAGES = "task-enlightenment-x11"
-PR = "r4"
+PACKAGES = "task-enlightenment-x11 task-enlightenment-x11-core"
+PR = "r5"
 
 FEED_URIS += "x11##http://openzaurus.org/official/unstable/3.5.2/feed/x11 \
               e##http://openzaurus.org/official/unstable/3.5.2/feed/e"
@@ -11,14 +11,20 @@ ALLOW_EMPTY = 1
 #
 # X
 #
-DEPENDS  += "diet-x11 rxvt-unicode xstroke xtscal xrandr xmodmap xdpyinfo fontconfig \
-             ttf-bitstream-vera bash chkhinge"
-RDEPENDS += "         rxvt-unicode xstroke xtscal xrandr xmodmap xdpyinfo            \
-             ttf-bitstream-vera chkhinge"
+DEPENDS_task-enlightenment-x11-core  += "diet-x11 rxvt-unicode xstroke xtscal xrandr xmodmap xdpyinfo fontconfig \
+                                         ttf-bitstream-vera chkhinge"
+RDEPENDS_task-enlightenment-x11-core += "         rxvt-unicode xstroke xtscal xrandr xmodmap xdpyinfo            \
+                                         ttf-bitstream-vera chkhinge"
+
+#
+# E-core
+#
+DEPENDS_task-enlightenment-x11-core  += "entrance e-wm"
+RDEPENDS_task-enlightenment-x11-core += "entrance e-wm"
 
 #
 # E
 #
-DEPENDS  += "entrance e-wm entice eclair examine evidence e-modules e-utils elitaire"
-RDEPENDS += "entrance e-wm entice eclair examine evidence e-modules e-utils elitaire"
+DEPENDS_task-enlightenment-x11 +=  "task-enlightenment-x11-core entice eclair examine evidence e-modules e-utils elitaire"
+RDEPENDS_task-enlightenment-x11 += "task-enlightenment-x11-core entice eclair examine evidence e-modules e-utils elitaire"
 
index 9be1e32..b846eeb 100644 (file)
@@ -3,9 +3,9 @@ LICENSE = MIT
 DEPENDS = "ipkg-native ipkg-utils-native fakeroot-native \
            binutils-cross-sdk gcc-cross-sdk gdb-cross \
            libidl libsvg-cairo sed-native \
-           meta-gpe \
+           meta-gpe gstreamer\
            opie-mail"
-PR = "r5"
+PR = "r7"
 
 PACKAGES = ""
 
@@ -51,24 +51,14 @@ libice-dev \
 libidl-2-dev \
 libipkg-dev \
 libjpeg-dev \
-libmailwrapper-dev \
 libmb-dev \
 libmimedir-dev \
 libopenobex-1.0-dev \
-libopiebluez2-dev \
-libopiedb2-dev \
-libopiecore2-dev \
-libopienet2-dev \
-libopiepim2-dev \
-libopieui2-dev \
 libpcap-dev \
 libpixman-dev \
 libpng-dev \
 libpng12-dev \
 libpopt-dev \
-libqpe1-dev \
-libqte2-dev \
-libqtaux2-dev \
 libreadline-dev \
 libschedule-dev \
 libsm-dev \
@@ -113,8 +103,21 @@ xextensions-dev \
 libxmu-dev \
 xproto-dev \
 xtrans-dev \
+gstreamer-dev \
 "
 
+#libopiebluez2-dev \
+#libopiedb2-dev \
+#libopiecore2-dev \
+#libopienet2-dev \
+#libopiepim2-dev \
+#libopieui2-dev \
+#libqpe1-dev \
+#libqte2-dev \
+#libqtaux2-dev \
+#libmailwrapper-dev \
+
+
 do_populate_sdk() {
        touch ${DEPLOY_DIR_IPK}/Packages
        ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
index 6209d8f..bba1725 100644 (file)
@@ -1,5 +1,5 @@
 [Desktop Entry]
-Name=Online Screenshot
+Name=Upload Screenshot
 Comment=Upload a screenshot to http://handhelds.org/scap
 Exec=scap
 Terminal=0
index f8e0485..ba8bc7e 100644 (file)
@@ -1,6 +1,6 @@
 #!/bin/sh
 
-sleep 5
+sleep 2
 if [ -x /usr/bin/bl ]; then
        bl toggle
 fi
index 30cf1b3..7bef893 100644 (file)
@@ -1,5 +1,5 @@
 LICENSE = "OSL"
-PR = "r2"
+PR = "r4"
 
 DESCRIPTION = "handhelds.org screen capture utility"
 SRC_URI = "file://scap.sh file://scap.desktop file://scap.png"