speech-dispatcher: Improve packaging
authorMatthias Hentges <oe@hentges.net>
Fri, 4 Jan 2008 14:10:09 +0000 (14:10 +0000)
committerMatthias Hentges <oe@hentges.net>
Fri, 4 Jan 2008 14:10:09 +0000 (14:10 +0000)
packages/speech-dispatcher/speech-dispatcher_0.6.5.bb

index ac001bf..68bfd8a 100644 (file)
@@ -5,12 +5,13 @@ LICENSE = "GPLv2"
 DEPENDS = "flite libdotconf glib-2.0"
 RPROVIDES += "speechd"
 
-PR = "r0"
+PR = "r1"
 
 inherit autotools
 
 SRC_URI = "http://www.freebsoft.org/pub/projects/speechd/${PN}-${PV}.tar.gz \
-           file://srcMakefile.am.patch;patch=1 "
+           file://srcMakefile.am.patch;patch=1 \
+          file://confSpeechd.conf_00.patch;patch=1"
 
 LEAD_SONAME = "libspeechd.so"
 
@@ -18,15 +19,20 @@ do_install() {
         install -d ${D}${bindir}
         install -d ${D}${includedir}
         install -d ${D}${libdir}/${PN}-modules
+       install -d ${D}${sysconfdir}
+       install -d ${D}${sysconfdir}/modules
 
         oe_libinstall -so -C src/audio libsdaudio ${D}${libdir}
         oe_libinstall -so -C src/c/api libspeechd ${D}${libdir}
         
         install -m 0644 ${S}/src/c/api/libspeechd.h    ${D}${includedir}
-        install -m 0755 ${S}/src/c/clients/say/spd-say ${D}${bindir}
+        install -m 0755 ${S}/src/c/clients/say/.libs/spd-say ${D}${bindir}
         install -m 0755 ${S}/src/c/clients/spdsend/spdsend ${D}${bindir}
-        install -m 0755 ${S}/src/server/speech-dispatcher  ${D}${bindir}
-        install -m 0755 ${S}/src/modules/sd_*   ${D}${libdir}/${PN}-modules/
+        install -m 0755 ${S}/src/server/.libs/speech-dispatcher  ${D}${bindir}
+        install -m 0755 ${S}/src/modules/.libs/sd_*   ${D}${libdir}/${PN}-modules/
+       
+       install -m 0644 ${S}/config/speechd.conf ${D}${sysconfdir}
+       install -m 0644 ${S}/config/modules/*.conf ${D}${sysconfdir}/modules
 }
 
 do_stage() {