merge of 6dc5369b32237cf596f3cd1b746d8fc2326bf8bd
authorMatthias Hentges <oe@hentges.net>
Sun, 12 Feb 2006 12:13:56 +0000 (12:13 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sun, 12 Feb 2006 12:13:56 +0000 (12:13 +0000)
     and 873692217328c8db613557cc3eaef48a2a6860fb

conf/distro/ludeos.conf
packages/e17/e17-gpe-menu-convert_0.2.bb
packages/efl/edb-utils_1.0.5.005.bb [new file with mode: 0644]
packages/efl/edb_1.0.5.005.bb
packages/efl/edje-utils_0.5.0.023.bb [new file with mode: 0644]
packages/efl/edje_0.5.0.023.bb
packages/efl/embryo-utils_0.9.1.023.bb [new file with mode: 0644]
packages/efl/embryo_0.9.1.023.bb
packages/ixp4xx/ixp-osal-2.1/ixp4xx-header.patch
packages/ixp4xx/ixp-osal_2.1.bb

index fad8d4e..5ebe98b 100644 (file)
@@ -19,4 +19,18 @@ FEED_URIS_append += "native##http://ipkg.nslu2-linux.org/feeds/slugos-lag/native
 # This removes the dependency on upslug2-native.
 SLUGOS_NATIVE_DEPENDS = ""
 
+SLUGOS_EXTRA_RDEPENDS = "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck \
+kernel-module-ext2 \
+kernel-module-jbd \
+kernel-module-ext3 \
+kernel-module-nfs \
+kernel-module-vfat \
+kernel-module-ntfs \
+kernel-module-isofs \
+kernel-module-udf \
+kernel-module-reiserfs \
+kernel-module-nls-cp437 \
+kernel-module-nls-utf8 \
+"
+
 include conf/distro/slugos.conf
index fd55d34..88eefa7 100644 (file)
@@ -1,11 +1,10 @@
 DESCRIPTION = "Shell script to convert GPE .desktop files into e17 eap files and menus"
 DEPENDS = "edje e-wm"
-#RDEPENDS += "edje-utils e-wm"
-RDEPENDS += "libedje-dev e-wm"
+RDEPENDS += "edje-utils e-wm"
 LICENSE = "MIT"
 SECTION = "e/apps"
 MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "file://e17-gpe-menu-convert.sh"
 
@@ -16,4 +15,4 @@ do_install() {
 
 #pkg_postinst() {
 #      /usr/bin/e17-gpe-menu-convert.sh
-#}
\ No newline at end of file
+#}
diff --git a/packages/efl/edb-utils_1.0.5.005.bb b/packages/efl/edb-utils_1.0.5.005.bb
new file mode 100644 (file)
index 0000000..401d0e7
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "EDB is a database convenience library wrapped around the \
+Berkeley DB 2.7.7 by Sleepycat Software."
+DEPENDS = "zlib ncurses"
+LICENSE = "BSD"
+PR = "r4"
+
+inherit efl
+
+EXTRA_OECONF += "--disable-gtk"
+
+PACKAGES = "edb-utils"
+FILES_${PN} = "${bindir}/edb_ed ${bindir}/edb_vt_ed ${bindir}/edb_gtk_ed"
+RDEPENDS_${PN} += "ncurses"
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/edb-${PV}.tar.gz"
+S = "${WORKDIR}/edb-${PV}"
+
+libraries = ""
+headers = ""
index 5550538..a152530 100644 (file)
@@ -2,17 +2,12 @@ DESCRIPTION = "EDB is a database convenience library wrapped around the \
 Berkeley DB 2.7.7 by Sleepycat Software."
 DEPENDS = "zlib ncurses"
 LICENSE = "BSD"
-PR = "r3"
-
-## package.bbclass kills packages when there are duplicates, this means
-##  that efl.bbclass can't have PACKAGES += and so the FILES for previous
-##  packages take precedence over -utils
-#PACKAGES = "edb-utils"
-#FILES_edb-utils = "${bindir}/edb_ed ${bindir}/edb_vt_ed ${bindir}/edb_gtk_ed"
-#RDEPENDS_edb-utils += "ncurses"
+PR = "r4"
 
 inherit efl
 
 EXTRA_OECONF += "--disable-gtk"
 
 libdirectory = "src"
+
+FILES_${PN}-examples = ""
\ No newline at end of file
diff --git a/packages/efl/edje-utils_0.5.0.023.bb b/packages/efl/edje-utils_0.5.0.023.bb
new file mode 100644 (file)
index 0000000..6432fc1
--- /dev/null
@@ -0,0 +1,23 @@
+DESCRIPTION = "Edje is a complex graphical design & layout library."
+DEPENDS = "edje"
+LICENSE = "MIT"
+PR = "r6"
+
+inherit efl
+
+PACKAGES = "edje-utils"
+FILES_${PN} = "${bindir}/edje ${bindir}/edje_* ${datadir}/edje/data/template ${datadir}/edje/include"
+RDEPENDS_${PN} += "embryo-utils cpp cpp-symlinks gcc gcc-symlinks"
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/edje-${PV}.tar.gz \
+           cvs://anonymous@thinktux.net/root;module=e17/libs/edje/m4;date=20060101"
+S = "${WORKDIR}/edje-${PV}"
+
+libraries = ""
+headers = ""
+
+do_configure_prepend() {
+       install -d "${S}/m4"
+       install "${WORKDIR}/m4/"*.m4 "${S}/m4"
+       aclocal -I m4
+}
index 11662b2..43e135a 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Edje is a complex graphical design & layout library."
 # can also install vim data files
 DEPENDS = "virtual/evas virtual/ecore eet embryo edje-native virtual/imlib2"
 LICENSE = "MIT"
-PR = "r5"
+PR = "r6"
 
 ## package.bbclass kills packages when there are duplicates, this means
 ##  that efl.bbclass can't have PACKAGES += and so the FILES for previous
@@ -14,7 +14,7 @@ PR = "r5"
 
 inherit efl
 
-RDEPENDS_${PN}-dev += "libembryo-dev cpp cpp-symlinks gcc gcc-symlinks"
+FILES_${PN}-examples = "${datadir}/edje/data/images ${datadir}/edje/data/src ${datadir}/edje/data/test ${datadir}/edje/data/*.sh"
 
 FILES_${SRCNAME}-themes = ""
 
diff --git a/packages/efl/embryo-utils_0.9.1.023.bb b/packages/efl/embryo-utils_0.9.1.023.bb
new file mode 100644 (file)
index 0000000..7899e4a
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "Embryo implements a C like scripting language used in various parts \
+of the Enlightenment project, namely Edje. Embryo's scripting language is based on \
+CompuPhase's Small language that was introduced in Dr Dobb's Journal in 1999. \
+Embryo allows scripting capabilities in places that otherwise wouldn't support \
+basic programming structures such as in Edje EDCs."
+LICENSE = "MIT"
+PR = "r4"
+
+inherit efl
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/embryo-${PV}.tar.gz"
+S = "${WORKDIR}/embryo-${PV}"
+
+PACKAGES = "embryo-utils"
+FILES_${PN} = "${bindir}/embryo ${bindir}/embryo_* ${datadir}/embryo/include"
+
+libraries = ""
+headers = ""
index 603a0c8..0009c0a 100644 (file)
@@ -4,12 +4,8 @@ CompuPhase's Small language that was introduced in Dr Dobb's Journal in 1999. \
 Embryo allows scripting capabilities in places that otherwise wouldn't support \
 basic programming structures such as in Edje EDCs."
 LICENSE = "MIT"
-PR = "r3"
-
-## package.bbclass kills packages when there are duplicates, this means
-##  that efl.bbclass can't have PACKAGES += and so the FILES for previous
-##  packages take precedence over -utils
-#PACKAGES = "embryo-utils"
-#FILES_embryo-utils = "${bindir}/embryo ${bindir}/embryo_* ${datadir}/embryo/include"
+PR = "r4"
 
 inherit efl
+
+FILES_${PN}-examples = "${datadir}/${PN}/examples"
\ No newline at end of file
index 70eec5e..a9d87d4 100644 (file)
       "qMgr"                   /* name            */
 --- ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Base.h     1970-01-01 00:00:00.000000000 +0000
 +++ ixp_osal/os/linux/include/platforms/ixp400/ixp425/IxOsalOsIxp425Base.h     1970-01-01 00:00:00.000000000 +0000
-@@ -0,0 +1,72 @@
+@@ -0,0 +1,80 @@
 +/*
 + * Glue for the current linux definitons of this stuff.
 + */
 +#ifndef IxOsalOsIxp425Base_H
 +#define IxOsalOsIxp425Base_H 1
 +#include <asm-arm/arch-ixp4xx/ixp4xx-regs.h>
++#include <linux/version.h>
 +
 +/* Force Address Coherent (the default) mapping on LE - Linux 2.6
 + * does not have a way of changing it.
 +#define IXP425_PCI_CFG_BASE_PHYS      IXP4XX_PCI_CFG_BASE_PHYS
 +
 +//#define IXP425_EXP_BUS_BASE1_PHYS
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,16)
 +#define IXP425_EXP_BUS_BASE2_PHYS     IXP4XX_EXP_BUS_CS2_BASE_PHYS
++#else
++/* The following definition should be IXP4XX_EXP_BUS_BASE(2), but that is not
++   static and causes compilation problems later.  So we need to hard-code it.
++   Note that this hard-coded value is only correct for IXP42X. */
++#define IXP425_EXP_BUS_BASE2_PHYS     (IXP4XX_EXP_BUS_BASE_PHYS + (2 * SZ_16M))
++#endif
 +//#define IXP425_EXP_BUS_CS0_BASE_PHYS
 +//#define IXP425_EXP_BUS_CS1_BASE_PHYS
 +//#define IXP425_EXP_BUS_CS4_BASE_PHYS
index 48d4355..7a27e28 100644 (file)
@@ -31,7 +31,7 @@ SRC_URI += "file://le.patch;patch=1"
 SRC_URI += "file://assert.patch;patch=1"
 
 S = "${WORKDIR}/ixp_osal"
-PR = "r3"
+PR = "r4"
 
 COMPATIBLE_HOST = "^arm.*-linux.*"