madwifi-ng: add slugos support and bump to latest snapshot
authorMike Westerhof <mwester@dls.net>
Thu, 4 Jan 2007 06:37:30 +0000 (06:37 +0000)
committerMike Westerhof <mwester@dls.net>
Thu, 4 Jan 2007 06:37:30 +0000 (06:37 +0000)
packages/madwifi/files/slugos-VFP-wackelf.patch [new file with mode: 0644]
packages/madwifi/files/slugos-xscale-be-elf-copts.patch [new file with mode: 0644]
packages/madwifi/files/slugos-xscale-le-elf-copts.patch [new file with mode: 0644]
packages/madwifi/madwifi-ng_r.inc
packages/madwifi/madwifi-ng_r1871-20061229.bb [new file with mode: 0644]

diff --git a/packages/madwifi/files/slugos-VFP-wackelf.patch b/packages/madwifi/files/slugos-VFP-wackelf.patch
new file mode 100644 (file)
index 0000000..a47eed7
--- /dev/null
@@ -0,0 +1,20 @@
+--- madwifi.orig/ath_hal/Makefile      2007-01-03 23:44:10.000000000 -0600
++++ madwifi/ath_hal/Makefile   2007-01-03 23:47:55.000000000 -0600
+@@ -81,12 +81,16 @@
+ quiet_cmd_uudecode = UUDECODE $@
+       cmd_uudecode = $(obj)/uudecode -o $@ $<
+-$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
++$(obj)/wackelf: $(HAL)/public/wackelf.c
++      $(HOSTCC) $(HOSTCFLAGS) -o $@ $<
++
++$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode $(obj)/wackelf
+ ifdef LINUX24
+       $(Q)$(obj)/uudecode -o $@ $<
+ else
+       $(call if_changed,uudecode)
+ endif
++      $(Q)$(obj)/wackelf -fpa $@
+ install:
+       test -d $(DESTDIR)/$(KMODPATH) || mkdir -p $(DESTDIR)/$(KMODPATH)
diff --git a/packages/madwifi/files/slugos-xscale-be-elf-copts.patch b/packages/madwifi/files/slugos-xscale-be-elf-copts.patch
new file mode 100644 (file)
index 0000000..1a08f37
--- /dev/null
@@ -0,0 +1,10 @@
+--- madwifi.orig/hal/public/xscale-be-elf.inc  2007-01-03 23:42:09.000000000 -0600
++++ madwifi/hal/public/xscale-be-elf.inc       2007-01-03 23:48:50.000000000 -0600
+@@ -77,5 +77,5 @@
+ LDOPTS=       -EB
+ COPTS+=       -DAH_BYTE_ORDER=AH_BIG_ENDIAN
+-COPTS+= -march=armv4 -mbig-endian -fno-strict-aliasing -fno-common -mapcs-32 \
+-      -mtune=xscale  -mshort-load-bytes
++COPTS+= -march=armv4 -mbig-endian -fno-strict-aliasing -fno-common \
++      -mtune=xscale
diff --git a/packages/madwifi/files/slugos-xscale-le-elf-copts.patch b/packages/madwifi/files/slugos-xscale-le-elf-copts.patch
new file mode 100644 (file)
index 0000000..c4d9937
--- /dev/null
@@ -0,0 +1,8 @@
+--- madwifi.orig/hal/public/xscale-le-elf.inc  2007-01-03 23:42:06.000000000 -0600
++++ madwifi/hal/public/xscale-le-elf.inc       2007-01-03 23:48:50.000000000 -0600
+@@ -79,4 +79,4 @@
+ LDOPTS=       -EL
+ COPTS+=       -DAH_BYTE_ORDER=AH_LITTLE_ENDIAN
+ COPTS+= -march=armv4 -mlittle-endian -fno-strict-aliasing -fno-common \
+-      -mapcs-32 -mtune=xscale  -mshort-load-bytes
++      -mtune=xscale
index 215d8c2..c82b785 100644 (file)
@@ -11,6 +11,11 @@ SRC_URI = "http://snapshots.madwifi.org/${PN}/${PN}-${PV}.tar.gz \
           file://10-xscale-le-elf-copts.patch;patch=1 \
           file://10-sh4-le-elf-copts.patch;patch=1"
 
+SRC_URI_slugos = "http://snapshots.madwifi.org/${PN}/${PN}-${PV}.tar.gz \
+                 file://slugos-xscale-be-elf-copts.patch;patch=1 \
+                 file://slugos-xscale-le-elf-copts.patch;patch=1 \
+                 file://slugos-VFP-wackelf.patch;patch=1"
+
 S = "${WORKDIR}/${PN}-${PV}"
 
 inherit module-base
diff --git a/packages/madwifi/madwifi-ng_r1871-20061229.bb b/packages/madwifi/madwifi-ng_r1871-20061229.bb
new file mode 100644 (file)
index 0000000..42d8cca
--- /dev/null
@@ -0,0 +1,3 @@
+PR = "r0"
+
+require madwifi-ng_r.inc