amule: initial commit. closes 717 for OE.
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>
Mon, 18 Feb 2008 11:05:06 +0000 (11:05 +0000)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Mon, 18 Feb 2008 11:05:06 +0000 (11:05 +0000)
packages/amule/.mtn2git_empty [new file with mode: 0644]
packages/amule/amule_2.1.3.bb [new file with mode: 0644]
packages/amule/files/.mtn2git_empty [new file with mode: 0644]
packages/amule/files/parser.patch [new file with mode: 0644]

diff --git a/packages/amule/.mtn2git_empty b/packages/amule/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/amule/amule_2.1.3.bb b/packages/amule/amule_2.1.3.bb
new file mode 100644 (file)
index 0000000..b160203
--- /dev/null
@@ -0,0 +1,25 @@
+DESCRIPTION = "aMule is an eMule-like client for the eD2k \
+and Kademlia networks, supporting multiple platforms."
+HOMEPAGE = "http://www.amule.org"
+LICENSE = "GPL"
+SECTION = "web"
+PRIORITY = "optional"
+DEPENDS = "wxbase"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/amule/aMule-${PV}.tar.bz2 \
+           file://parser.patch;patch=1"
+
+S = "${WORKDIR}/aMule-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-amulecmd \
+                --enable-webserver \
+               --disable-monolithic \
+               --enable-amule-daemon \
+               --disable-nls"
+#              --enable-optimize"
+
+FILES_${PN} += " \
+        ${libdir}/xchat"
diff --git a/packages/amule/files/.mtn2git_empty b/packages/amule/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/amule/files/parser.patch b/packages/amule/files/parser.patch
new file mode 100644 (file)
index 0000000..ee77c42
--- /dev/null
@@ -0,0 +1,20 @@
+diff -ur aMule-2.1.0_orig/src/Parser.cpp aMule-2.1.0/src/Parser.cpp
+--- aMule-2.1.0_orig/src/Parser.cpp    2005-12-20 05:13:25.000000000 +0100
++++ aMule-2.1.0/src/Parser.cpp 2006-01-29 15:16:45.000000000 +0100
+@@ -203,14 +203,14 @@
+ #   define YYMALLOC malloc
+ #   if (! defined (malloc) && ! defined (YYINCLUDED_STDLIB_H) \
+       && (defined (__STDC__) || defined (__cplusplus)))
+-void *malloc (YYSIZE_T); /* INFRINGES ON USER NAME SPACE */
++/*void *malloc (YYSIZE_T);*/ /* INFRINGES ON USER NAME SPACE */
+ #   endif
+ #  endif
+ #  ifndef YYFREE
+ #   define YYFREE free
+ #   if (! defined (free) && ! defined (YYINCLUDED_STDLIB_H) \
+       && (defined (__STDC__) || defined (__cplusplus)))
+-void free (void *); /* INFRINGES ON USER NAME SPACE */
++/*void free (void *);*/ /* INFRINGES ON USER NAME SPACE */
+ #   endif
+ #  endif
+ #  ifdef __cplusplus