txdrug: fix include path and incorrect assumptions about $palmtopdir. closes 2420.
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>
Mon, 4 Aug 2008 21:46:10 +0000 (21:46 +0000)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Mon, 4 Aug 2008 21:46:10 +0000 (21:46 +0000)
packages/txdrug/txdrug_0.1.bb

index cd82234..31da811 100644 (file)
@@ -3,10 +3,10 @@ SECTION = "opie/applications"
 PRIORITY = "optional"
 LICENSE = "GPL"
 DEPENDS = "sqlite"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://teax.sourceforge.net/txdrug-${PV}.tar.gz \
-           file://${FILESDIR}/${palmtopdir}"
+           file://${FILESDIR}/opt/QtPalmtop"
 S = "${WORKDIR}/txdrug-tar"
 
 inherit palmtop
@@ -14,11 +14,16 @@ inherit palmtop
 EXTRA_QMAKEVARS_POST += "LIBS+=-lsqlite TARGET=txdrug"
 
 do_configure_prepend() {
-       rm -f Makefile && qmake -project
+        rm -f Makefile && qmake -project
+}
+
+do_configure_append() {
+        sed -i "s/\-I\/usr\/include\/sqlite\ //g" Makefile
 }
 
 do_install() {
         install -d ${D}${palmtopdir}
-       cp -Pfr `ls -dp ${WORKDIR}/${palmtopdir}/*|grep -v SCCS` ${D}${palmtopdir}/
+        cp -Pfr `ls -dp ${WORKDIR}/opt/QtPalmtop/*|grep -v SCCS` ${D}${palmtopdir}/
         install -D -m 755 txdrug ${D}${palmtopdir}/bin/txdrug
 }
+