switch from neon to soup-2.4 (fixes gstreamer http timeout spinlock)
authorghost <andreas.monzner@multimedia-labs.de>
Thu, 8 Jul 2010 10:24:42 +0000 (12:24 +0200)
committerghost <andreas.monzner@multimedia-labs.de>
Thu, 8 Jul 2010 10:24:42 +0000 (12:24 +0200)
Conflicts:

recipes/gstreamer/gst-plugins-base_0.10.29.bb

recipes/gnome/libsoup-2.4_2.29.5.bb
recipes/gstreamer/gst-plugins-base_0.10.29.bb

index a13106e..d2a89d0 100644 (file)
@@ -2,12 +2,18 @@ DESCRIPTION = "An HTTP library implementation in C"
 SECTION = "x11/gnome/libs"
 LICENSE = "GPL"
 DEPENDS = "libproxy glib-2.0 gnutls libxml2 sqlite3 gnome-keyring"
+DEPENDS_opendreambox = "glib-2.0 gnutls libxml2 sqlite3"
 
-inherit gnome
+#inherit gnome
+inherit autotools
 
-SRC_URI = "${GNOME_MIRROR}/libsoup/${@gnome_verdir("${PV}")}/libsoup-${PV}.tar.bz2"
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+SRC_URI = "${GNOME_MIRROR}/libsoup/${@'.'.join((bb.data.getVar('PV', d, 1)).split('.')[:2])}/libsoup-${PV}.tar.bz2"
 S = "${WORKDIR}/libsoup-${PV}"
 
+EXTRA_OECONF_opendreambox += "--without-gnome"
+
 PACKAGES =+ "libsoup-gnome"
 FILES_libsoup-gnome = "${libdir}/libsoup-gnome*.so.*"
 FILES_${PN} = "${libdir}/libsoup-2*.so.*"
index 29e5475..9582cd1 100644 (file)
@@ -4,7 +4,7 @@ SRC_URI_append_opendreambox = " file://samihack.patch;patch=1 \
 file://playbin2-Set-subtitle-encoding-on-the-decodebins-a.patch;patch=1 \
 file://playbin2-If-a-text-sink-is-provided-let-subtitle-p.patch;patch=1 "
 
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 
 PROVIDES += "gst-plugins"