recipes/python: add mutagen 1.18
authorghost <andreas.monzner@multimedia-labs.de>
Fri, 26 Feb 2010 18:58:18 +0000 (19:58 +0100)
committerghost <andreas.monzner@multimedia-labs.de>
Mon, 1 Mar 2010 11:39:55 +0000 (12:39 +0100)
recipes/python/python-mutagen/patch.diff [new file with mode: 0644]
recipes/python/python-mutagen_1.18.bb [new file with mode: 0644]

diff --git a/recipes/python/python-mutagen/patch.diff b/recipes/python/python-mutagen/patch.diff
new file mode 100644 (file)
index 0000000..73a112c
--- /dev/null
@@ -0,0 +1,12 @@
+diff -Naur mutagen/easymp4.py mutagen_pach/easymp4.py
+--- mutagen/mutagen/easymp4.py 2009-08-10 12:57:55.000000000 +0200
++++ mutagen/mutagen/easymp4.py 2010-01-11 19:24:05.000000000 +0100
+@@ -204,7 +204,7 @@
+     '\xa9cmt': 'comment',
+     'desc': 'description',
+     '\xa9grp': 'grouping',
+-    '\xa9grn': 'genre',
++    '\xa9gen': 'genre',
+     'cprt': 'copyright',
+     'soal': 'albumsort',
+     'soaa': 'albumartistsort',
diff --git a/recipes/python/python-mutagen_1.18.bb b/recipes/python/python-mutagen_1.18.bb
new file mode 100644 (file)
index 0000000..554ebd0
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Module for manipulating ID3 (v1 + v2) tags in Python"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Dr. Best <dr.best@dreambox-tools.info>"
+LICENSE = "GPL"
+SRCNAME = "mutagen"
+
+DEPENDS = "python"
+RDEPENDS = "python-shell"
+
+SRC_URI = "http://mutagen.googlecode.com/files/mutagen-${PV}.tar.gz \
+       file://patch.diff;patch=1;pnum=1 \
+"
+
+S = "${WORKDIR}/mutagen-${PV}"
+
+inherit distutils
+
+