Rename: image_ipk -> image.bbclass, IPKG_INSTALL -> PACKAGE_INSTALL to prepare for...
authorRichard Purdie <rpurdie@rpsys.net>
Sun, 31 Dec 2006 23:28:56 +0000 (23:28 +0000)
committerRichard Purdie <rpurdie@rpsys.net>
Sun, 31 Dec 2006 23:28:56 +0000 (23:28 +0000)
37 files changed:
classes/image.bbclass [new file with mode: 0644]
classes/image_ipk.bbclass [deleted file]
classes/rootfs_ipk.bbclass
classes/wrt-image.bbclass
contrib/oe-stylize.py
packages/angstrom/angstrom-bootmanager-image.bb
packages/angstrom/angstrom-bootstrap-image.bb
packages/angstrom/angstrom-gpe-image.bb
packages/images/bootstrap-image-bootchart.bb
packages/images/bootstrap-image.bb
packages/images/dvb-image.bb
packages/images/e-image-core.bb
packages/images/e-image.bb
packages/images/essential-image.bb
packages/images/essential-machine-image.bb
packages/images/gpe-image.bb
packages/images/jlime-opie.bb [new file with mode: 0644]
packages/images/maemo-image.bb
packages/images/mythfront-image.bb
packages/images/nslu2-linksys-image.bb
packages/images/nylon-image-base.bb
packages/images/nylon-image-mini.bb
packages/images/openprotium-image.bb
packages/images/opie-image.bb
packages/images/opie-kdepim-image.bb
packages/images/ossie-image.bb
packages/images/pivotboot-image.bb
packages/images/sdl-image.bb
packages/images/sectest-gpe-image.bb
packages/images/slugos-image.bb
packages/images/twin-image.bb
packages/images/uml-image.bb
packages/images/unslung-image.bb
packages/images/xfce-image.bb
packages/images/xterminal-image.bb
packages/meta/jlime-opie.bb [deleted file]
packages/tasks/task-ossie.bb

diff --git a/classes/image.bbclass b/classes/image.bbclass
new file mode 100644 (file)
index 0000000..2beb137
--- /dev/null
@@ -0,0 +1,99 @@
+inherit rootfs_ipk
+
+# We need to recursively follow RDEPENDS and RRECOMMENDS for images
+BUILD_ALL_DEPS = "1"
+do_rootfs[recrdeptask] = "do_package_write"
+
+# Images are generally built explicitly, do not need to be part of world.
+EXCLUDE_FROM_WORLD = "1"
+
+USE_DEVFS ?= "0"
+
+DEPENDS += "makedevs-native"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+def get_image_deps(d):
+       import bb
+       str = ""
+       for type in (bb.data.getVar('IMAGE_FSTYPES', d, 1) or "").split():
+               deps = bb.data.getVar('IMAGE_DEPENDS_%s' % type, d) or ""
+               if deps:
+                       str += " %s" % deps
+       return str
+
+DEPENDS += "${@get_image_deps(d)}"
+
+#
+# Get a list of files containing device tables to create.
+# * IMAGE_DEVICE_TABLE is the old name to an absolute path to a device table file
+# * IMAGE_DEVICE_TABLES is a new name for a file, or list of files, seached
+#   for in the BBPATH
+# If neither are specified then the default name of files/device_table-minimal.txt
+# is searched for in the BBPATH (same as the old version.)
+#
+def get_devtable_list(d):
+       import bb
+       devtable = bb.data.getVar('IMAGE_DEVICE_TABLE', d, 1)
+       if devtable != None:
+               return devtable
+       str = ""
+       devtables = bb.data.getVar('IMAGE_DEVICE_TABLES', d, 1)
+       if devtables == None:
+               devtables = 'files/device_table-minimal.txt'
+       for devtable in devtables.split():
+               str += " %s" % bb.which(bb.data.getVar('BBPATH', d, 1), devtable)
+       return str
+
+IMAGE_POSTPROCESS_COMMAND ?= ""
+
+# Must call real_do_rootfs() from inside here, rather than as a separate
+# task, so that we have a single fakeroot context for the whole process.
+fakeroot do_rootfs () {
+       set -x
+       rm -rf ${IMAGE_ROOTFS}
+
+       if [ "${USE_DEVFS}" != "1" ]; then
+               mkdir -p ${IMAGE_ROOTFS}/dev
+               for devtable in ${@get_devtable_list(d)}; do
+                       makedevs -r ${IMAGE_ROOTFS} -D $devtable
+               done
+       fi
+
+       real_do_rootfs
+
+       insert_feed_uris        
+
+       rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/lists/oe
+       
+       ${IMAGE_PREPROCESS_COMMAND}
+               
+       export TOPDIR=${TOPDIR}
+
+       for type in ${IMAGE_FSTYPES}; do
+               if test -z "$FAKEROOTKEY"; then
+                       fakeroot -i ${TMPDIR}/fakedb.image bbimage -t $type -e ${FILE}
+               else
+                       bbimage -n "${IMAGE_NAME}" -t "$type" -e "${FILE}"
+               fi
+       done
+
+       ${IMAGE_POSTPROCESS_COMMAND}
+}
+
+insert_feed_uris () {
+       
+       echo "Building feeds for [${DISTRO}].."
+               
+       for line in ${FEED_URIS}
+       do
+               # strip leading and trailing spaces/tabs, then split into name and uri
+               line_clean="`echo "$line"|sed 's/^[ \t]*//;s/[ \t]*$//'`"
+               feed_name="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\1/p'`"
+               feed_uri="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\2/p'`"                                        
+               
+               echo "Added $feed_name feed with URL $feed_uri"
+               
+               # insert new feed-sources
+               echo "src/gz $feed_name $feed_uri" >> ${IMAGE_ROOTFS}/etc/ipkg/${feed_name}-feed.conf
+       done                    
+}
diff --git a/classes/image_ipk.bbclass b/classes/image_ipk.bbclass
deleted file mode 100644 (file)
index 2beb137..0000000
+++ /dev/null
@@ -1,99 +0,0 @@
-inherit rootfs_ipk
-
-# We need to recursively follow RDEPENDS and RRECOMMENDS for images
-BUILD_ALL_DEPS = "1"
-do_rootfs[recrdeptask] = "do_package_write"
-
-# Images are generally built explicitly, do not need to be part of world.
-EXCLUDE_FROM_WORLD = "1"
-
-USE_DEVFS ?= "0"
-
-DEPENDS += "makedevs-native"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-def get_image_deps(d):
-       import bb
-       str = ""
-       for type in (bb.data.getVar('IMAGE_FSTYPES', d, 1) or "").split():
-               deps = bb.data.getVar('IMAGE_DEPENDS_%s' % type, d) or ""
-               if deps:
-                       str += " %s" % deps
-       return str
-
-DEPENDS += "${@get_image_deps(d)}"
-
-#
-# Get a list of files containing device tables to create.
-# * IMAGE_DEVICE_TABLE is the old name to an absolute path to a device table file
-# * IMAGE_DEVICE_TABLES is a new name for a file, or list of files, seached
-#   for in the BBPATH
-# If neither are specified then the default name of files/device_table-minimal.txt
-# is searched for in the BBPATH (same as the old version.)
-#
-def get_devtable_list(d):
-       import bb
-       devtable = bb.data.getVar('IMAGE_DEVICE_TABLE', d, 1)
-       if devtable != None:
-               return devtable
-       str = ""
-       devtables = bb.data.getVar('IMAGE_DEVICE_TABLES', d, 1)
-       if devtables == None:
-               devtables = 'files/device_table-minimal.txt'
-       for devtable in devtables.split():
-               str += " %s" % bb.which(bb.data.getVar('BBPATH', d, 1), devtable)
-       return str
-
-IMAGE_POSTPROCESS_COMMAND ?= ""
-
-# Must call real_do_rootfs() from inside here, rather than as a separate
-# task, so that we have a single fakeroot context for the whole process.
-fakeroot do_rootfs () {
-       set -x
-       rm -rf ${IMAGE_ROOTFS}
-
-       if [ "${USE_DEVFS}" != "1" ]; then
-               mkdir -p ${IMAGE_ROOTFS}/dev
-               for devtable in ${@get_devtable_list(d)}; do
-                       makedevs -r ${IMAGE_ROOTFS} -D $devtable
-               done
-       fi
-
-       real_do_rootfs
-
-       insert_feed_uris        
-
-       rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/lists/oe
-       
-       ${IMAGE_PREPROCESS_COMMAND}
-               
-       export TOPDIR=${TOPDIR}
-
-       for type in ${IMAGE_FSTYPES}; do
-               if test -z "$FAKEROOTKEY"; then
-                       fakeroot -i ${TMPDIR}/fakedb.image bbimage -t $type -e ${FILE}
-               else
-                       bbimage -n "${IMAGE_NAME}" -t "$type" -e "${FILE}"
-               fi
-       done
-
-       ${IMAGE_POSTPROCESS_COMMAND}
-}
-
-insert_feed_uris () {
-       
-       echo "Building feeds for [${DISTRO}].."
-               
-       for line in ${FEED_URIS}
-       do
-               # strip leading and trailing spaces/tabs, then split into name and uri
-               line_clean="`echo "$line"|sed 's/^[ \t]*//;s/[ \t]*$//'`"
-               feed_name="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\1/p'`"
-               feed_uri="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\2/p'`"                                        
-               
-               echo "Added $feed_name feed with URL $feed_uri"
-               
-               # insert new feed-sources
-               echo "src/gz $feed_name $feed_uri" >> ${IMAGE_ROOTFS}/etc/ipkg/${feed_name}-feed.conf
-       done                    
-}
index 8020fd0..9af23c7 100644 (file)
@@ -2,7 +2,7 @@
 # Creates a root filesystem out of IPKs
 #
 # This rootfs can be mounted via root-nfs or it can be put into an cramfs/jffs etc.
-# See image_ipk.oeclass for a usage of this.
+# See image.bbclass for a usage of this.
 #
 
 DEPENDS_prepend="ipkg-native ipkg-utils-native fakeroot-native "
@@ -17,7 +17,7 @@ do_build[nostamp] = "1"
 
 IPKG_ARGS = "-f ${T}/ipkg.conf -o ${IMAGE_ROOTFS}"
 
-IPKG_INSTALL += "ipkg ipkg-collateral"
+PACKAGE_INSTALL += "ipkg ipkg-collateral"
 
 ROOTFS_POSTPROCESS_COMMAND ?= ""
 
@@ -55,8 +55,8 @@ real_do_rootfs () {
                        ipkg-cl ${IPKG_ARGS} install $i
                done
        fi
-       if [ ! -z "${IPKG_INSTALL}" ]; then
-               ipkg-cl ${IPKG_ARGS} install ${IPKG_INSTALL}
+       if [ ! -z "${PACKAGE_INSTALL}" ]; then
+               ipkg-cl ${IPKG_ARGS} install ${PACKAGE_INSTALL}
        fi
 
        export D=${IMAGE_ROOTFS}
index ba1163a..45d9ac9 100644 (file)
@@ -3,7 +3,7 @@ ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/zImage*"
 
 def wrt_get_kernel_version(d):
        import bb
-       if bb.data.inherits_class('image_ipk', d):
+       if bb.data.inherits_class('image', d):
                skd = bb.data.getVar('STAGING_KERNEL_DIR', d, 1)
                return base_read_file(skd+'/kernel-abiversion')
        return "-no kernel version for available-"
index 7170af0..a92b58d 100755 (executable)
@@ -136,7 +136,7 @@ OE_vars = [
     'INITSCRIPT_PACKAGES',
     'INITSCRIPT_NAME',
     'INITSCRIPT_PARAMS',
-    'IPKG_INSTALL',
+    'PACKAGE_INSTALL',
     'KERNEL_IMAGETYPE',
     'KERNEL_IMAGEDEST',
     'KERNEL_OUTPUT',
index 9a0bf12..43c25eb 100644 (file)
@@ -7,9 +7,9 @@ RDEPENDS = "angstrom-base-depends angstrom-bootmanager"
 
 export IMAGE_BASENAME = "bootmanager-image"
 export IMAGE_LINGUAS = ""
-export IPKG_INSTALL = "${RDEPENDS}"
+export PACKAGE_INSTALL = "${RDEPENDS}"
 
-inherit image_ipk
+inherit image
 
 
 
index d4ce272..3977e22 100644 (file)
@@ -12,7 +12,7 @@ RDEPENDS = "task-base-core-default \
 
 export IMAGE_BASENAME = "bootstrap-image"
 export IMAGE_LINGUAS = ""
-export IPKG_INSTALL = "${RDEPENDS}"
+export PACKAGE_INSTALL = "${RDEPENDS}"
 
-inherit image_ipk
+inherit image
 
index 78f6b03..d366a62 100644 (file)
@@ -25,9 +25,9 @@ RDEPENDS = "\
     ${ANGSTROM_EXTRA_INSTALL}"
 
 
-export IPKG_INSTALL = "${RDEPENDS}"
+export PACKAGE_INSTALL = "${RDEPENDS}"
 
 #zap root password for release images
 ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
 
-inherit image_ipk
+inherit image
index 00a1e39..dea254e 100644 (file)
@@ -1,10 +1,10 @@
 export IMAGE_BASENAME = "bootstrap-image-bootchart"
 export IMAGE_LINGUAS = ""
-export IPKG_INSTALL = "${MACHINE_TASK_PROVIDER} bootchart acct"
+export PACKAGE_INSTALL = "${MACHINE_TASK_PROVIDER} bootchart acct"
 
 DEPENDS = "${MACHINE_TASK_PROVIDER} bootchart"
 RDEPENDS = "acct"
 
-inherit image_ipk
+inherit image
 
 LICENSE = "MIT"
index 5731d94..1ff60e6 100644 (file)
@@ -1,10 +1,10 @@
 export IMAGE_BASENAME = "bootstrap-image"
 export IMAGE_LINGUAS = ""
-export IPKG_INSTALL = "${MACHINE_TASK_PROVIDER}"
+export PACKAGE_INSTALL = "${MACHINE_TASK_PROVIDER}"
 
 DEPENDS = "${MACHINE_TASK_PROVIDER}"
 
-inherit image_ipk
+inherit image
 
 FEED_URIS_append_familiar   = " x11##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/x11 \
                                opie##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/opie"
index a6687d2..c4636b1 100644 (file)
@@ -4,8 +4,8 @@ IMAGE_LINGUAS = ""
 
 DVB_PACKAGES = "${MACHINE_TASK_PROVIDER} task-dvb"
 
-export IPKG_INSTALL = "${DVB_PACKAGES}"
+export PACKAGE_INSTALL = "${DVB_PACKAGES}"
 DEPENDS = "${DVB_PACKAGES}"
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
index f41f04e..c713437 100644 (file)
@@ -16,6 +16,6 @@ PREFERRED_PROVIDER_virtual/imlib2 = "imlib2-x11"
 PREFERRED_PROVIDER_virtual/libxine = "libxine-x11"
 PREFERRED_PROVIDER_libx11 = "libx11"
 
-export IPKG_INSTALL = "${MACHINE_TASK_PROVIDER} task-e-x11-core xserver-kdrive-fbdev glibc-charmap-utf-8 glibc-localedata-i18n"
+export PACKAGE_INSTALL = "${MACHINE_TASK_PROVIDER} task-e-x11-core xserver-kdrive-fbdev glibc-charmap-utf-8 glibc-localedata-i18n"
 
-inherit image_ipk
+inherit image
index e42df3f..2f0bef9 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "An X11-based distribution with the Enlightenment Window Manager a
 PR = "r5"
 
 export IMAGE_BASENAME = "e-image"
-export IPKG_INSTALL += "task-e-x11-core \
+export PACKAGE_INSTALL += "task-e-x11-core \
                         gpe-task-pim \
                         gpe-task-settings \
                         gpe-task-apps \
@@ -32,4 +32,4 @@ export IPKG_INSTALL += "task-e-x11-core \
 
 DEPENDS += "task-e-x11-core task-gpe figment xhost gpe-soundserver gpe-confd xauth"
 
-RDEPENDS = "${IPKG_INSTALL}"
+RDEPENDS = "${PACKAGE_INSTALL}"
index 2388a0e..9544b82 100644 (file)
@@ -15,7 +15,7 @@ PR = "r0"
 
 ######################################################################################
 
-inherit image_ipk
+inherit image
 
 ######################################################################################
 
@@ -25,4 +25,4 @@ DEPENDS = "task-essential-to-boot"
 
 export IMAGE_BASENAME = "essential-image"
 export IMAGE_LINGUAS = ""
-export IPKG_INSTALL = "task-essential-to-boot"
+export PACKAGE_INSTALL = "task-essential-to-boot"
index 38a8d6c..70ce1e1 100644 (file)
@@ -15,7 +15,7 @@ PR = "r0"
 
 ######################################################################################
 
-inherit image_ipk
+inherit image
 
 ######################################################################################
 
@@ -33,4 +33,4 @@ MACHINE_TASKS_akita = "task-essential-to-boot \
 
 export IMAGE_BASENAME = "essential-image"
 export IMAGE_LINGUAS = ""
-export IPKG_INSTALL = "${MACHINE_TASKS}"
+export PACKAGE_INSTALL = "${MACHINE_TASKS}"
index 53c6d5f..b448c0a 100644 (file)
@@ -25,9 +25,9 @@ GPE_EXTRA_INSTALL += "${GPE_BIGFLASH_INSTALL}"
 XSERVER ?= "xserver-kdrive-fbdev"
 
 DEPENDS = "${MACHINE_TASK_PROVIDER} task-gpe"
-RDEPENDS = "${IPKG_INSTALL}"
+RDEPENDS = "${PACKAGE_INSTALL}"
 
-export IPKG_INSTALL = "\
+export PACKAGE_INSTALL = "\
     ${MACHINE_TASK_PROVIDER} \
     gpe-task-base \
     gpe-task-pim \
@@ -38,5 +38,5 @@ export IPKG_INSTALL = "\
 
 #ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
diff --git a/packages/images/jlime-opie.bb b/packages/images/jlime-opie.bb
new file mode 100644 (file)
index 0000000..a6f8b79
--- /dev/null
@@ -0,0 +1,68 @@
+export IMAGE_BASENAME = "jlime-opie"
+export IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+PR = "r21"
+
+DEPENDS = "task-bootstrap task-opie"
+RDEPENDS = "${INSTALL_PACKAGES}"
+
+extra_stuff := '${@base_conditional("ROOT_FLASH_SIZE", "24", "", "task-opie-extra-games task-opie-extra-apps task-opie-extra-styles konqueror-embedded",d)}'
+
+INSTALL_PACKAGES = "task-bootstrap task-opie-base task-opie-base-applets \
+                   task-opie-base-inputmethods task-opie-base-apps \
+                   task-opie-base-settings task-opie-base-decorations \
+                   task-opie-base-styles task-opie-base-pim \
+                   task-opie-extra-settings \
+                   task-opie-bluetooth task-opie-irda \
+                   ${extra_stuff}"
+
+export PACKAGE_INSTALL = "${INSTALL_PACKAGES}"
+
+# merge feed-sources into ipkg.conf for opie-aqpkg as it can't handle feed-sources outside of ipkg.conf.
+merge_feeds() {
+
+        if ! test -z "${FEED_URIS}"
+        then
+                # Die gracefully if ipkg-collateral failed
+                if ! test -e "${IMAGE_ROOTFS}/etc/ipkg.conf"
+                then
+                        echo "[${IMAGE_ROOTFS}/etc/ipkg.conf] is missing!"
+                        exit 1
+                fi
+
+                # comment out existing feed-sources inserted by ipkg-collateral
+                cat ${IMAGE_ROOTFS}/etc/ipkg.conf | sed "s/^src\ /#src\ /" > ${IMAGE_ROOTFS}/etc/ipkg.conf_
+                rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
+
+                # extract, then delete destinations
+                cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
+                cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep -v "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf_
+                rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
+
+
+                for line in ${FEED_URIS}
+                do
+                        # strip leading and trailing spaces/tabs, then split into name and uri
+                        line_clean="`echo "$line"|sed 's/^[ \t]*//;s/[ \t]*$//'`"
+                        feed_name="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\1/p'`"
+                        feed_uri="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\2/p'`"
+
+                        # insert new feed-sources
+                        echo "src/gz $feed_name $feed_uri" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
+                done
+
+                # remove temporary files and rebuild ipkg.conf
+                echo "" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
+                cat ${IMAGE_ROOTFS}/etc/ipkg.conf.dest >> ${IMAGE_ROOTFS}/etc/ipkg.conf
+                rm ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
+
+                # remove -feed.conf files which are no longer needed
+                cd ${IMAGE_ROOTFS}/etc/ipkg/ && rm -- *-feed.conf
+        fi
+}
+
+# merge feed-sources into ipkg.conf and create /etc/timestamp from build date
+IMAGE_PREPROCESS_COMMAND = "merge_feeds; create_etc_timestamp"
+
+inherit image
index d0368cb..2153e42 100644 (file)
@@ -19,9 +19,9 @@ DEPENDS = "${MACHINE_TASK_PROVIDER} \
           meta-maemo \
           ${MAEMO_EXTRA_DEPENDS}"
 
-export IPKG_INSTALL = "${MACHINE_TASK_PROVIDER} maemo-task-base maemo-task-theme \
+export PACKAGE_INSTALL = "${MACHINE_TASK_PROVIDER} maemo-task-base maemo-task-theme \
                       maemo-task-apps ${MAEMO_EXTRA_INSTALL} \
                       ${XSERVER}"
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
index 9bfedcf..49e6b5a 100644 (file)
@@ -6,8 +6,8 @@ IMAGE_LINGUAS = ""
 
 MYTHFRONT_PACKAGES = "${MACHINE_TASK_PROVIDER} task-mythfront"
 
-export IPKG_INSTALL = "${MYTHFRONT_PACKAGES}"
+export PACKAGE_INSTALL = "${MYTHFRONT_PACKAGES}"
 DEPENDS = "${MYTHFRONT_PACKAGES}"
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
index 18329c9..7cfad43 100644 (file)
@@ -3,12 +3,12 @@ USE_DEVFS = "1"
 
 IMAGE_BASENAME = "nslu2-linksys"
 
-IPKG_INSTALL = "nslu2-linksys-ramdisk"
+PACKAGE_INSTALL = "nslu2-linksys-ramdisk"
 
-DEPENDS = "nslu2-linksys-kernel ${IPKG_INSTALL}"
+DEPENDS = "nslu2-linksys-kernel ${PACKAGE_INSTALL}"
 
 NSLU2_DEVICE_TABLE = "${@bb.which(bb.data.getVar('BBPATH', d, 1), 'files/device_table-nslu2.txt')}"
 EXTRA_IMAGECMD_ext2.gz = "-f ${NSLU2_DEVICE_TABLE}"
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
index 2672334..120cff5 100644 (file)
@@ -1,4 +1,4 @@
-inherit image_ipk
+inherit image
 inherit nylon-image
 LICENSE = "MIT"
 
@@ -21,7 +21,7 @@ RDEPENDS_append_mtx-2 = " modutils modutils-initscripts modutils-depmod modutils
 ## kernel 2.6 ##
 RDEPENDS_append_mtx-3 = " module-init-tools udev"
 
-export IPKG_INSTALL = "${RDEPENDS}"
+export PACKAGE_INSTALL = "${RDEPENDS}"
 
 IMAGE_LINGUAS = ""
 
index b1f5591..e6acd1f 100644 (file)
@@ -11,9 +11,9 @@ NYLON_BASE = "base-files base-passwd busybox \
 RDEPENDS = "kernel \
        ${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS}"
 
-export IPKG_INSTALL = "${RDEPENDS}"
+export PACKAGE_INSTALL = "${RDEPENDS}"
 
 IMAGE_LINGUAS = ""
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
index 5547709..faec266 100644 (file)
@@ -103,9 +103,9 @@ RDEPENDS = " \
        ${OPENPROTIUM_KERNEL} "
 #      ${SLUGOS_EXTRA_RDEPENDS}"
 
-IPKG_INSTALL = "${RDEPENDS}"
+PACKAGE_INSTALL = "${RDEPENDS}"
 
-inherit image_ipk
+inherit image
 
 storcenter_pack_image() {
        # find latest kernel
index 172e411..3613cca 100644 (file)
@@ -17,7 +17,7 @@ INSTALL_PACKAGES = "${MACHINE_TASK_PROVIDER} task-opie-base task-opie-base-apple
 INSTALL_PACKAGES_spitz_append = "task-opie-extra-games task-opie-extra-apps task-opie-extra-styles"
 INSTALL_PACKAGES_akita_append = "task-opie-extra-games task-opie-extra-apps task-opie-extra-styles"
 
-export IPKG_INSTALL = "${INSTALL_PACKAGES}"
+export PACKAGE_INSTALL = "${INSTALL_PACKAGES}"
 
 # merge feed-sources into ipkg.conf for opie-aqpkg as it can't handle feed-sources outside of ipkg.conf.
 merge_feeds() {
@@ -65,4 +65,4 @@ merge_feeds() {
 # merge feed-sources into ipkg.conf and create /etc/timestamp from build date
 IMAGE_PREPROCESS_COMMAND = "merge_feeds; create_etc_timestamp"
 
-inherit image_ipk
+inherit image
index 7fdc221..477d924 100644 (file)
@@ -7,4 +7,4 @@ export IMAGE_BASENAME = "opie-kdepim-image"
 
 INSTALL_PACKAGES += "kopi kapi kammu kopi-applet"
 
-export IPKG_INSTALL = "${INSTALL_PACKAGES}"
+export PACKAGE_INSTALL = "${INSTALL_PACKAGES}"
index 59f49cf..7f7cfbd 100644 (file)
@@ -1,6 +1,6 @@
 export IMAGE_BASENAME = "ossie-image"
 export IMAGE_LINGUAS = ""
-export IPKG_INSTALL = "${MACHINE_TASK_PROVIDER} task-ossie"
+export PACKAGE_INSTALL = "${MACHINE_TASK_PROVIDER} task-ossie"
 
 DEPENDS = "${MACHINE_TASK_PROVIDER} task-ossie"
 
@@ -14,6 +14,6 @@ FEED_URIS += " \
                 ${MACHINE}##${OSSIE_URI}/unstable/feed/${TARGET_ARCH}/machine/${MACHINE}"
 
 
-inherit image_ipk
+inherit image
 
 LICENSE = "MIT"
index 50634e0..78c3d7a 100644 (file)
@@ -1,11 +1,11 @@
 export IMAGE_BASENAME = "pivotboot-image"
 export IMAGE_LINGUAS = ""
-export IPKG_INSTALL = "task-pivotboot"
+export PACKAGE_INSTALL = "task-pivotboot"
 
 DEPENDS = "task-pivotboot"
 PR = "r1"
 
-inherit image_ipk
+inherit image
 
 FEED_URIS_append_familiar   = " x11##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/x11 \
                                opie##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/opie"
index 0e8f856..d6a0b4b 100644 (file)
@@ -4,6 +4,6 @@ export IMAGE_BASENAME = "sdl-image"
 
 DEPENDS = "${MACHINE_TASK_PROVIDER} task-sdl"
 
-export IPKG_INSTALL = "${MACHINE_TASK_PROVIDER} sdl-base"
+export PACKAGE_INSTALL = "${MACHINE_TASK_PROVIDER} sdl-base"
 
-inherit image_ipk
+inherit image
index 9a068bf..fa16437 100644 (file)
@@ -21,9 +21,9 @@ GPE_EXTRA_INSTALL += "${GPE_EXTRA_INSTALL_${GUI_MACHINE_CLASS}}"
 XSERVER ?= "xserver-kdrive-fbdev"
 
 DEPENDS = "${MACHINE_TASK_PROVIDER} task-gpe"
-RDEPENDS = "${IPKG_INSTALL}"
+RDEPENDS = "${PACKAGE_INSTALL}"
 
-export IPKG_INSTALL = "\
+export PACKAGE_INSTALL = "\
     ${MACHINE_TASK_PROVIDER} \
     gpe-task-base \
     gpe-task-pim \
@@ -34,5 +34,5 @@ export IPKG_INSTALL = "\
 
 ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
 
-inherit image_ipk
+inherit image
 
index 0e03400..cf7d580 100644 (file)
@@ -91,9 +91,9 @@ RDEPENDS = "kernel ixp4xx-npe \
        ${SLUGOS_KERNEL} \
        ${SLUGOS_EXTRA_RDEPENDS}"
 
-IPKG_INSTALL = "${RDEPENDS}"
+PACKAGE_INSTALL = "${RDEPENDS}"
 
-inherit image_ipk
+inherit image
 
 python () {
     # Don't build slugos images unless the configuration is set up
index b2f3ec4..a0e68c9 100644 (file)
@@ -7,12 +7,12 @@ DEPENDS = '${MACHINE_TASK_PROVIDER} \
          vim \
          mutt'
 
-export IPKG_INSTALL = '${MACHINE_TASK_PROVIDER} \
+export PACKAGE_INSTALL = '${MACHINE_TASK_PROVIDER} \
                       twin \
                       orpheus \
                       nano \
                       vim \
                       mutt'
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
index 1983d03..43afa30 100644 (file)
@@ -6,7 +6,7 @@ OPIE_LIBS = "qte qpf-bitstream-vera libqpe-opie libopie2"
 OPIE_BASE = "opie-qcop opie-quicklauncher opie-taskbar"
 
 DEPENDS = "${MACHINE_TASK_PROVIDER}"
-export IPKG_INSTALL = "${DEPENDS}"
+export PACKAGE_INSTALL = "${DEPENDS}"
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
index 58f61b1..b56f007 100644 (file)
@@ -18,7 +18,7 @@ RDEPENDS  = "kernel update-modules unslung-rootfs \
 #      findutils \
        ${UNSLUNG_EXTRA_RDEPENDS}"
 
-IPKG_INSTALL = "kernel update-modules unslung-rootfs \
+PACKAGE_INSTALL = "kernel update-modules unslung-rootfs \
        libc6-unslung slingbox ipkg \
        libipkg \
 #      cpio \
@@ -28,7 +28,7 @@ IPKG_INSTALL = "kernel update-modules unslung-rootfs \
 
 IMAGE_PREPROCESS_COMMAND += "unslung_clean_image; "
 
-inherit image_ipk
+inherit image
 
 # Note that anything in this function must be repeatable without having to rebuild the rootfs
 unslung_clean_image () {
index a681428..42b0907 100644 (file)
@@ -8,8 +8,8 @@ X_RDEPENDS = "xserver-kdrive-fbdev"
 XFCE_DEPENDS = "${MACHINE_TASK_PROVIDER} task-xfce-base"
 XFCE_RDEPENDS = "${XFCE_DEPENDS}"
 
-export IPKG_INSTALL = "${X_RDEPENDS} ${XFCE_RDEPENDS}"
+export PACKAGE_INSTALL = "${X_RDEPENDS} ${XFCE_RDEPENDS}"
 DEPENDS = "${X_DEPENDS} ${XFCE_DEPENDS}"
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
index 174766e..3b4576e 100644 (file)
@@ -4,8 +4,8 @@ IMAGE_LINGUAS = ""
 
 XTERMINAL_PACKAGES = "${MACHINE_TASK_PROVIDER} task-xterminal"
 
-export IPKG_INSTALL = "${XTERMINAL_PACKAGES}"
+export PACKAGE_INSTALL = "${XTERMINAL_PACKAGES}"
 DEPENDS = "${XTERMINAL_PACKAGES}"
 
-inherit image_ipk
+inherit image
 LICENSE = "MIT"
diff --git a/packages/meta/jlime-opie.bb b/packages/meta/jlime-opie.bb
deleted file mode 100644 (file)
index 679dacd..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-export IMAGE_BASENAME = "jlime-opie"
-export IMAGE_LINGUAS = ""
-
-LICENSE = "MIT"
-PR = "r21"
-
-DEPENDS = "task-bootstrap task-opie"
-RDEPENDS = "${INSTALL_PACKAGES}"
-
-extra_stuff := '${@base_conditional("ROOT_FLASH_SIZE", "24", "", "task-opie-extra-games task-opie-extra-apps task-opie-extra-styles konqueror-embedded",d)}'
-
-INSTALL_PACKAGES = "task-bootstrap task-opie-base task-opie-base-applets \
-                   task-opie-base-inputmethods task-opie-base-apps \
-                   task-opie-base-settings task-opie-base-decorations \
-                   task-opie-base-styles task-opie-base-pim \
-                   task-opie-extra-settings \
-                   task-opie-bluetooth task-opie-irda \
-                   ${extra_stuff}"
-
-export IPKG_INSTALL = "${INSTALL_PACKAGES}"
-
-# merge feed-sources into ipkg.conf for opie-aqpkg as it can't handle feed-sources outside of ipkg.conf.
-merge_feeds() {
-
-        if ! test -z "${FEED_URIS}"
-        then
-                # Die gracefully if ipkg-collateral failed
-                if ! test -e "${IMAGE_ROOTFS}/etc/ipkg.conf"
-                then
-                        echo "[${IMAGE_ROOTFS}/etc/ipkg.conf] is missing!"
-                        exit 1
-                fi
-
-                # comment out existing feed-sources inserted by ipkg-collateral
-                cat ${IMAGE_ROOTFS}/etc/ipkg.conf | sed "s/^src\ /#src\ /" > ${IMAGE_ROOTFS}/etc/ipkg.conf_
-                rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
-
-                # extract, then delete destinations
-                cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
-                cat ${IMAGE_ROOTFS}/etc/ipkg.conf | egrep -v "^dest\ " > ${IMAGE_ROOTFS}/etc/ipkg.conf_
-                rm ${IMAGE_ROOTFS}/etc/ipkg.conf && mv ${IMAGE_ROOTFS}/etc/ipkg.conf_ ${IMAGE_ROOTFS}/etc/ipkg.conf
-
-
-                for line in ${FEED_URIS}
-                do
-                        # strip leading and trailing spaces/tabs, then split into name and uri
-                        line_clean="`echo "$line"|sed 's/^[ \t]*//;s/[ \t]*$//'`"
-                        feed_name="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\1/p'`"
-                        feed_uri="`echo "$line_clean" | sed -n 's/\(.*\)##\(.*\)/\2/p'`"
-
-                        # insert new feed-sources
-                        echo "src/gz $feed_name $feed_uri" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
-                done
-
-                # remove temporary files and rebuild ipkg.conf
-                echo "" >> ${IMAGE_ROOTFS}/etc/ipkg.conf
-                cat ${IMAGE_ROOTFS}/etc/ipkg.conf.dest >> ${IMAGE_ROOTFS}/etc/ipkg.conf
-                rm ${IMAGE_ROOTFS}/etc/ipkg.conf.dest
-
-                # remove -feed.conf files which are no longer needed
-                cd ${IMAGE_ROOTFS}/etc/ipkg/ && rm -- *-feed.conf
-        fi
-}
-
-# merge feed-sources into ipkg.conf and create /etc/timestamp from build date
-IMAGE_PREPROCESS_COMMAND = "merge_feeds; create_etc_timestamp"
-
-inherit image_ipk
index 98f0a2d..cd05034 100644 (file)
@@ -7,7 +7,7 @@ PACKAGES = "task-ossie"
 
 ALLOW_EMPTY = "1"
 
-IPKG_INSTALL = "${OSSIE_BASE} ${OSSIE_PLATFORM} ${OSSIE_COMPONENTS} ${OSSIE_WAVEFORMS}"
+PACKAGE_INSTALL = "${OSSIE_BASE} ${OSSIE_PLATFORM} ${OSSIE_COMPONENTS} ${OSSIE_WAVEFORMS}"
 
 OSSIE_BASE = "screen procps xerces-c omniorb usrp"
 OSSIE_PLATFORM = "ossiecf ossie-standardinterfaces ossie-nodebooter ossie-c-wavloader"