display-brightness: Do not allow to turn off the backlight
authorMatthias Hentges <oe@hentges.net>
Mon, 19 Nov 2007 16:39:50 +0000 (16:39 +0000)
committerMatthias Hentges <oe@hentges.net>
Mon, 19 Nov 2007 16:39:50 +0000 (16:39 +0000)
packages/display-brightness/display-brightness.sh
packages/display-brightness/display-brightness_1.0.0.bb

index a82c748..935dabf 100644 (file)
@@ -38,7 +38,7 @@ if [ "$1" = "up" ]; then
 fi
 
 if [ "$1" = "down" ]; then
-    if [ $ACTUAL_BRIGHTNESS -eq 0 ]; then
+    if [ $ACTUAL_BRIGHTNESS -lt 2 ]; then
         exit 0
     elif [ $ACTUAL_BRIGHTNESS -lt $STEP ]; then
         STEP=1
index bc46c16..f06fde0 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "display brightness utility"
 AUTHOR = "Patrick Steiner <patrick.steiner@a1.net>"
 DEPENDS = ""
 PRIORITY = "optional"
-PR = "r3"
+PR = "r4"
 LICENSE = "GPLv2"
 
 SRC_URI = "file://display-brightness.sh"