linux-handhelds: fix compilation error due to missing include
authorPaul Eggleton <bluelightning@bluelightning.org>
Sat, 15 Nov 2008 13:01:55 +0000 (13:01 +0000)
committerPaul Eggleton <bluelightning@bluelightning.org>
Sat, 15 Nov 2008 13:06:32 +0000 (13:06 +0000)
Add missing include of linux/limits.h. Fixes bug #4344.

packages/linux/linux-handhelds-2.6-2.6.21/gcc4x-limits.patch [new file with mode: 0644]
packages/linux/linux-handhelds-2.6_2.6.21-hh20.bb

diff --git a/packages/linux/linux-handhelds-2.6-2.6.21/gcc4x-limits.patch b/packages/linux/linux-handhelds-2.6-2.6.21/gcc4x-limits.patch
new file mode 100644 (file)
index 0000000..02f3a5d
--- /dev/null
@@ -0,0 +1,10 @@
+--- linux/scripts/mod/sumversion.c.orig        2008-11-15 12:22:04.000000000 +0000
++++ linux/scripts/mod/sumversion.c     2008-11-15 12:22:21.000000000 +0000
+@@ -7,6 +7,7 @@
+ #include <ctype.h>
+ #include <errno.h>
+ #include <string.h>
++#include <linux/limits.h>
+ #include "modpost.h"
+ /*
index 3df1102..7fbc286 100644 (file)
@@ -1,7 +1,7 @@
 SECTION = "kernel"
 DESCRIPTION = "handhelds.org Linux kernel 2.6 for PocketPCs and other consumer handheld devices."
 LICENSE = "GPL"
-PR = "r20"
+PR = "r21"
 
 DEFAULT_PREFERENCE = "-1"
 
@@ -12,6 +12,7 @@ FILESPATH = "${FILE_DIRNAME}/linux-handhelds-2.6-2.6.21/${MACHINE}:${FILE_DIRNAM
 SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
            file://linux-2.6.git-9d20fdd58e74d4d26dc5216efaaa0f800c23dd3a.patch;patch=1 \
            http://www.rpsys.net/openzaurus/patches/archive/export_atags-r0a.patch;patch=1 \
+           file://gcc4x-limits.patch;patch=1 \
           file://defconfig"
 
 require linux-handhelds-2.6.inc