pulseaudio 0.9.9 fix building against uClibc. closes #4106
authorMichael Lauer <mickey@vanille-media.de>
Fri, 28 Mar 2008 15:39:27 +0000 (15:39 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Fri, 28 Mar 2008 15:39:27 +0000 (15:39 +0000)
packages/pulseaudio/files/fix-shm.patch [new file with mode: 0644]
packages/pulseaudio/pulseaudio_0.9.9.bb

diff --git a/packages/pulseaudio/files/fix-shm.patch b/packages/pulseaudio/files/fix-shm.patch
new file mode 100644 (file)
index 0000000..3bf61d0
--- /dev/null
@@ -0,0 +1,20 @@
+# fixes building against uclibc
+# fixed upstream, see http://www.pulseaudio.org/ticket/200
+Index: pulseaudio-0.9.9/src/pulsecore/shm.c
+===================================================================
+--- pulseaudio-0.9.9/src/pulsecore/shm.c (revision 1971)
++++ pulseaudio-0.9.9/src/pulsecore/shm.c (revision 2110)
+@@ -319,4 +319,5 @@
+ int pa_shm_cleanup(void) {
++#ifdef HAVE_SHM_OPEN
+ #ifdef SHM_PATH
+     DIR *d;
+@@ -376,5 +377,6 @@
+     closedir(d);
+-#endif
++#endif /* SHM_PATH */
++#endif /* HAVE_SHM_OPEN */
+     return 0;
index 7e63b61..f38595e 100644 (file)
@@ -1,15 +1,15 @@
 require pulse.inc
 
 DEPENDS += "dbus"
+PR = "r4"
 
 # this is not correct (see below)
 SRC_URI += "\
   file://disable-using-glibc-tls.patch;patch=1 \
   file://fix-dbus-without-hal.patch;patch=1 \
+  file://fix-shm.patch;patch=1 \
 "            
 
-PR = "r3"
-
 # problems w/ pulseaudio 0.9.9 atm:
 # 1.) needs libltdl >= 1.5.24 (yes, any older version will NOT work at runtime)
 # 2.) doesn't build w/ glibc TLS support (hence patched out)