fix mytub plugin get entry problem.
authorikseong <ikseong@vuplus>
Mon, 27 Sep 2010 06:49:02 +0000 (15:49 +0900)
committerikseong <ikseong@vuplus>
Mon, 27 Sep 2010 06:49:02 +0000 (15:49 +0900)
To get entrh to parse not only 'youtube_gdata' but also 'youtube_gdata_player'.

recipes/enigma2/enigma2-plugins.bb
recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_mytube_entry_vuplus.patch [new file with mode: 0644]

index 7fc9012..42bfbb9 100755 (executable)
@@ -21,11 +21,13 @@ PV = "experimental-cvs${SRCDATE}"
 # if you want vuplus experimental, use:
 TAG_vuplus = ""
 PV_vuplus = "experimental-cvs${SRCDATE}"
+PR_vuplus = "r1"
 
 SRC_URI = "cvs://anonymous@cvs.schwerkraft.elitedvb.net/cvsroot/enigma2-plugins;module=enigma2-plugins;method=pserver${TAG};date=${SRCDATE}"
 
 SRC_URI_append_vuplus = " \
           file://enigma2_plugins_mytube_vuplus.patch;patch=1;pnum=1 \
+          file://enigma2_plugins_mytube_entry_vuplus.patch;patch=1;pnum=1 \
            file://dreamboxweb.png \
            file://favicon.ico"
 
diff --git a/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_mytube_entry_vuplus.patch b/recipes/enigma2/enigma2-plugins/vuplus/enigma2_plugins_mytube_entry_vuplus.patch
new file mode 100644 (file)
index 0000000..21f754c
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/mytube/src/MyTubeService.py b/mytube/src/MyTubeService.py
+index 7371026..1794db9 100755
+--- a/mytube/src/MyTubeService.py
++++ b/mytube/src/MyTubeService.py
+@@ -115,7 +115,7 @@ class MyTubeFeedEntry():
+               if self.entry.media.player:
+                       split = self.entry.media.player.url.split("=")
+                       ret = split.pop()
+-                      if ret == 'youtube_gdata':
++                      if ret == 'youtube_gdata' or ret == 'youtube_gdata_player':
+                               tmpval=split.pop()
+                               if tmpval.endswith("&feature"):
+                                       tmp = tmpval.split("&")