cdtool - Initial add.
authorRaymond Danks <raymond@edanks.com>
Mon, 24 Jul 2006 15:50:52 +0000 (15:50 +0000)
committerRaymond Danks <raymond@edanks.com>
Mon, 24 Jul 2006 15:50:52 +0000 (15:50 +0000)
cdtool/.mtn2git_empty [new file with mode: 0644]
cdtool/cdtool_2.1.8pre4.bb [new file with mode: 0644]
cdtool/files/.mtn2git_empty [new file with mode: 0644]
cdtool/files/install-no-owner.patch [new file with mode: 0644]

diff --git a/cdtool/.mtn2git_empty b/cdtool/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/cdtool/cdtool_2.1.8pre4.bb b/cdtool/cdtool_2.1.8pre4.bb
new file mode 100644 (file)
index 0000000..8f2b425
--- /dev/null
@@ -0,0 +1,14 @@
+# cdtool .bb build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+HOMEPAGE="http://hinterhof.net/cdtool/"
+DESCRIPTION="cdtool is a free software package to control the audio functions \
+of an attached CDROM drive from the command line in a quick and scriptable way."
+MAINTAINER = "Raymond Danks <info-linux@geode.amd.com>"
+LICENSE = "GPL"
+
+SRC_URI="http://hinterhof.net/${PN}/dist/${PN}-${PV}.tar.gz \
+       file://install-no-owner.patch;patch=1"
+
+inherit autotools
diff --git a/cdtool/files/.mtn2git_empty b/cdtool/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/cdtool/files/install-no-owner.patch b/cdtool/files/install-no-owner.patch
new file mode 100644 (file)
index 0000000..9519767
--- /dev/null
@@ -0,0 +1,33 @@
+--- cdtool-2.1.8pre4/Makefile.in.orig  2006-06-05 20:38:28.567261984 -0600
++++ cdtool-2.1.8pre4/Makefile.in       2006-06-05 20:38:46.218578576 -0600
+@@ -44,13 +44,13 @@
+ install: install-files install-links
+ install-files:
+       mkdir -p $(DESTDIR)$(bindir)
+-      $(INSTALL) cdctrl $(DESTDIR)$(bindir) -o root
+-      $(INSTALL) cdloop $(DESTDIR)$(bindir) -o root
+-      $(INSTALL) cdadd $(DESTDIR)$(bindir) -o root
+-      $(INSTALL) cdown $(DESTDIR)$(bindir) -o root
+-      $(INSTALL) cdtool2cddb $(DESTDIR)$(bindir) -o root
++      $(INSTALL) cdctrl $(DESTDIR)$(bindir) 
++      $(INSTALL) cdloop $(DESTDIR)$(bindir)
++      $(INSTALL) cdadd $(DESTDIR)$(bindir)
++      $(INSTALL) cdown $(DESTDIR)$(bindir)
++      $(INSTALL) cdtool2cddb $(DESTDIR)$(bindir)
+-      mkdir -p $(DESTDIR)$(mandir)/man1
++      $(INSTALL) -d $(DESTDIR)$(mandir)/man1
+       $(INSTALL) cdctrl.1 $(DESTDIR)$(mandir)/man1
+       $(INSTALL) cdloop.1 $(DESTDIR)$(mandir)/man1
+       $(INSTALL) cdadd.1 $(DESTDIR)$(mandir)/man1
+@@ -58,8 +58,8 @@
+       $(INSTALL) cdtool.1 $(DESTDIR)$(mandir)/man1
+       $(INSTALL) cdtool2cddb.1 $(DESTDIR)$(mandir)/man1
+-      mkdir -p $(DESTDIR)$(libdir)/cdtool
+-      $(INSTALL) cdtool $(DESTDIR)$(libdir)/cdtool -o root
++      $(INSTALL) -d  $(DESTDIR)$(libdir)/cdtool
++      $(INSTALL) cdtool $(DESTDIR)$(libdir)/cdtool
+  
+ LINKTARGET = ../lib/cdtool/cdtool
+ LINKS = cdplay cdpause cdstop cdclose cdeject cdir cdinfo cdreset \