Next attempt to get a non segfaulting qpe/Qtopia. -edition phone might be the key...
authorHolger Freyther <zecke@selfish.org>
Tue, 18 Mar 2008 12:05:39 +0000 (12:05 +0000)
committerHolger Freyther <zecke@selfish.org>
Tue, 18 Mar 2008 12:05:39 +0000 (12:05 +0000)
packages/qtopia-phone/qtopia-phone-x11/fic-gta02/device-conf
packages/qtopia-phone/qtopia-phone-x11_4.3.1.bb

index 7c8a59f..0ec27eb 100644 (file)
@@ -1,45 +1,20 @@
--arch OE_QT_ARCH
+-arch arm
 -xplatform OE_QT_XPLATFORM
--verbose
--qtopiamedia
--no-infrared
+-little-endian
+-edition phone
 -dbus
--dbuspath OE_QT_DBUSPATH
--iconsize 22
 -displaysize 480x640
--extra-qtopiacore-config "-fast" 
--extra-qtopiacore-config "-no-accessibility" 
--extra-qtopiacore-config "-no-cups"
--extra-qtopiacore-config "-no-iconv"
--extra-qtopiacore-config "-nomake demos" 
--extra-qtopiacore-config "-nomake examples"
--extra-qtopiacore-config "-qt-libjpeg" 
--extra-qtopiacore-config "-qt-libmng" 
--extra-qtopiacore-config "-qt-libpng" 
--extra-qtopiacore-config "-qt-zlib" 
--extra-qtopiacore-config "-release" 
--extra-qtopiacore-config "-no-sm"
--extra-qtopiacore-config "-fontconfig"
--extra-qtopiacore-config "-xrandr"
--extra-qtopiacore-config "-xrender"
--extra-qtopiacore-config "OE_QT_ENDIAN"
--extra-qt-config "-nomake examples" 
--extra-qt-config "-nomake demos" 
--extra-qt-config "-no-sm"
--extra-qtopiacore-config "OE_QT_ENDIAN"
--font dejavu_sans_condensed:10,11,13,15,16,17,18,19,28,36:50,75
--image OE_QT_RPREFIX
--launch-method quicklaunch
--force-quicklaunch
--no-clean 
+-voip
+-sound-system alsa
+-bluetooth
 -no-drm
--no-qvfb
--no-vpn
 -no-sxe
--no-silent
+-no-infrared
+-extra-qtopiacore-config "-no-cups -no-iconv -no-sm -fontconfig -xrender -xrandr"
+-extra-qt-config "-nomake examples -nomake demos -no-sm" 
+-image OE_QT_RPREFIX
+-launch-method normal
 -prefix OE_QT_RPREFIX
--reduce-exports=yes
 -release
 -confirm-license
-OE_QT_EXTRACONFIG
 
index 3a08e86..6f2f202 100644 (file)
@@ -12,7 +12,7 @@ PRIORITY = "optional"
 HOMEPAGE = "http://www.trolltech.com"
 DEPENDS = "glib-2.0 dbus freetype alsa-lib bluez-libs virtual/libx11 fontconfig xft libxext libxrender libxrandr libxcursor libxtst"
 PROVIDES = "qtopia-phone"
-PR = "r4"
+PR = "r6"
 SRCREV = "${AUTOREV}"
 SRC_URI = "git://git.openmoko.org/git/qtopia.git;protocol=git \
            file://device-conf \
@@ -35,18 +35,13 @@ export QTOPIA_DEPOT_PATH = "${S}"
 
 require qtopia-phone_arch.inc
 
-QT_ARCH = "${@qtopia_arch(d)}"
-QT_ENDIAN = "${@qtopia_endian(d)}"
 PLATFORM = "${BUILD_OS}-g++"
 XPLATFORM = "linux-oe-g++"
 BUILDDIR = "${WORKDIR}/build"
 
 OE_QT_DBUSPATH = "${STAGING_DIR_HOST}"
-OE_QT_ARCH = "${QT_ARCH}"
 OE_QT_XPLATFORM = "${XPLATFORM}"
 OE_QT_RPREFIX = "/opt/Qtopia"
-OE_QT_ENDIAN = "${QT_ENDIAN}"
-OE_QT_EXTRACONFIG = "-I${STAGING_INCDIR}/dbus-1.0"
 
 do_configure() {
 
@@ -66,11 +61,8 @@ sed -i -e "s|QMAKE_RPATH.*|QMAKE_RPATH =|" ${S}/devices/${TARGET-DEVICE}/mkspecs
 
 # sed the dynamic config into the file
 sed -i -e "s|OE_QT_DBUSPATH|${OE_QT_DBUSPATH}|" ${WORKDIR}/device-conf
-sed -i -e "s|OE_QT_ARCH|${OE_QT_ARCH}|" ${WORKDIR}/device-conf
 sed -i -e "s|OE_QT_XPLATFORM|${OE_QT_XPLATFORM}|" ${WORKDIR}/device-conf
 sed -i -e "s|OE_QT_RPREFIX|${OE_QT_RPREFIX}|" ${WORKDIR}/device-conf
-sed -i -e "s|OE_QT_ENDIAN|${OE_QT_ENDIAN}|" ${WORKDIR}/device-conf
-sed -i -e "s|OE_QT_EXTRACONFIG|${OE_QT_EXTRACONFIG}|" ${WORKDIR}/device-conf
 
 rm -f ${S}/devices/${TARGET-DEVICE}/configure
 cp ${WORKDIR}/device-conf ${S}/devices/${TARGET-DEVICE}/configure
@@ -79,7 +71,7 @@ echo "" > ${S}/devices/${TARGET-DEVICE}/environment
 
 mkdir -p ${BUILDDIR}
 cd ${BUILDDIR}
-echo yes | ${S}/configure -device ${TARGET-DEVICE} -xplatform ${XPLATFORM} -I${STAGING_INCDIR}/freetype2 -I${STAGING_INCDIR}/fontconfig
+echo yes | ${S}/configure -device ${TARGET-DEVICE} -xplatform ${XPLATFORM} -I${STAGING_INCDIR}/freetype2 -I${STAGING_INCDIR}/fontconfig -I${STAGING_INCDIR}/dbus-1.0
 
 }