packages/usbpath/* : add usbpath library and add is as DEPENDS to
authorGraeme Gregory <dp@xora.org.uk>
Mon, 15 Oct 2007 10:26:32 +0000 (10:26 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Mon, 15 Oct 2007 10:26:32 +0000 (10:26 +0000)
dfu-util

packages/dfu-util/dfu-util-native_svn.bb
packages/dfu-util/dfu-util_svn.bb
packages/usbpath/.mtn2git_empty [new file with mode: 0644]
packages/usbpath/usbpath-native_svn.bb [new file with mode: 0644]
packages/usbpath/usbpath_svn.bb [new file with mode: 0644]

index 9bfe4ba..457094d 100644 (file)
@@ -2,7 +2,7 @@ require dfu-util_${PV}.bb
 
 inherit native
 
-DEPENDS = "libusb-native"
+DEPENDS = "libusb-native usbpath-native"
 
 do_stage() {
        install -d ${STAGING_BINDIR_NATIVE}
index 9be5b92..1f34a5b 100644 (file)
@@ -5,7 +5,7 @@ LICENSE = "GPL"
 PV = "0.1+svnr${SRCREV}"
 PR = "r0"
 
-DEPENDS = "libusb"
+DEPENDS = "libusb usbpath"
 
 SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=dfu-util;proto=http"
 S = "${WORKDIR}/dfu-util"
diff --git a/packages/usbpath/.mtn2git_empty b/packages/usbpath/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/usbpath/usbpath-native_svn.bb b/packages/usbpath/usbpath-native_svn.bb
new file mode 100644 (file)
index 0000000..0cfafa2
--- /dev/null
@@ -0,0 +1,7 @@
+require usbpath_svn.bb
+inherit native
+
+do_stage () {
+       autotools_stage_all
+}
+
diff --git a/packages/usbpath/usbpath_svn.bb b/packages/usbpath/usbpath_svn.bb
new file mode 100644 (file)
index 0000000..95c02c9
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "Convert the physical locations of a USB device to/from its number"
+AUTHOR = "Werner Almesberger <werner@openmoko.org>"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+PV = "0.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host;module=usbpath;proto=http"
+
+S = "${WORKDIR}/usbpath"
+
+inherit autotools
+
+do_stage () {
+       autotools_stage_all
+}
+