cx3110x: Creating sysfs link between device and interface wlan0.
authorRodrigo Vivi <rodrigo.vivi@openbossa.org>
Tue, 13 May 2008 13:39:56 +0000 (10:39 -0300)
committerRodrigo Vivi <rodrigo.vivi@openbossa.org>
Thu, 23 Oct 2008 20:35:51 +0000 (17:35 -0300)
packages/mamona/cx3110x-0.8.1/create_sysfs_link_for_wlan0.patch [new file with mode: 0644]
packages/mamona/cx3110x-0.8.1/series
packages/mamona/cx3110x_0.8.1.bb

diff --git a/packages/mamona/cx3110x-0.8.1/create_sysfs_link_for_wlan0.patch b/packages/mamona/cx3110x-0.8.1/create_sysfs_link_for_wlan0.patch
new file mode 100644 (file)
index 0000000..cf4fa1e
--- /dev/null
@@ -0,0 +1,11 @@
+--- cx3110x-0.8.1.new/src/sm_drv_spi.c 2008-05-13 10:27:19.000000000 -0300
++++ cx3110x-0.8.1/src/sm_drv_spi.c     2008-05-12 19:02:16.000000000 -0300
+@@ -1067,6 +1067,8 @@
+               goto err_out_4;
+       }
++        SET_NETDEV_DEV(dev, &wlan_omap_device.dev);
++
+       register_netdev(dev);
+       
+       /* Let's fetch the firmware from userspace */
index 1ec63e2..fa690cb 100644 (file)
@@ -4,3 +4,4 @@ cx3110x.patch
 fix_cross_makefile.patch
 fix_ssid_data_length.patch
 770_performance_improvements.patch
+create_sysfs_link_for_wlan0.patch
index 286b5a1..f548bca 100644 (file)
@@ -19,6 +19,7 @@ SRC_URI = "https://garage.maemo.org/frs/download.php/2443/cx3110x-0.8.1.tar.gz \
  file://fix_cross_makefile.patch;patch=1 \\r
  file://fix_ssid_data_length.patch;patch=1 \\r
  file://770_performance_improvements.patch;patch=1 \\r
+ file://create_sysfs_link_for_wlan0.patch;patch=1 \\r
 "\r
 # add service file\r
 \r