conf/machine/*: Add "phone" MACHINE_FEATURE for phone devices.
authorPaul Sokolovsky <pmiscml@gmail.com>
Wed, 9 Jan 2008 17:37:13 +0000 (17:37 +0000)
committerPaul Sokolovsky <pmiscml@gmail.com>
Wed, 9 Jan 2008 17:37:13 +0000 (17:37 +0000)
conf/machine/htcalpine.conf
conf/machine/htcapache.conf
conf/machine/htcblueangel.conf
conf/machine/htchimalaya.conf
conf/machine/htcsable.conf
conf/machine/htctornado.conf
conf/machine/include/motorola-ezx-base.inc
packages/tasks/task-base.bb

index 6bf8999..f7f0254 100644 (file)
@@ -15,7 +15,7 @@ VOLATILE_STORAGE_SIZE = "64"
 MACHINE_GUI_CLASS = "smallscreen"
 MACHINE_DISPLAY_WIDTH_PIXELS = "240"
 MACHINE_DISPLAY_HEIGHT_PIXELS = "320"
-MACHINE_FEATURES = "kernel26 touchscreen apm alsa pcmcia irda bluetooth usbgadget screen vfat"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa pcmcia irda bluetooth usbgadget screen vfat phone"
 
 #
 # Software/packages selection
index afaa6fc..b3debb6 100644 (file)
@@ -15,7 +15,7 @@ VOLATILE_STORAGE_SIZE = "64"
 MACHINE_GUI_CLASS = "smallscreen"
 MACHINE_DISPLAY_WIDTH_PIXELS = "240"
 MACHINE_DISPLAY_HEIGHT_PIXELS = "320"
-MACHINE_FEATURES = "kernel26 touchscreen apm alsa pcmcia irda bluetooth usbgadget screen vfat"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa pcmcia irda bluetooth usbgadget screen vfat phone"
 
 #
 # Software/packages selection
index a5feeb2..f95cb70 100644 (file)
@@ -15,7 +15,7 @@ VOLATILE_STORAGE_SIZE = "128"
 MACHINE_GUI_CLASS = "smallscreen"
 MACHINE_DISPLAY_WIDTH_PIXELS = "240"
 MACHINE_DISPLAY_HEIGHT_PIXELS = "320"
-MACHINE_FEATURES = "kernel26 touchscreen apm alsa irda bluetooth wifi usbgadget screen vfat"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa irda bluetooth wifi usbgadget screen vfat phone"
 
 #
 # Software/packages selection
index 003406b..472e5d6 100644 (file)
@@ -15,7 +15,7 @@ VOLATILE_STORAGE_SIZE = "64"
 MACHINE_GUI_CLASS = "smallscreen"
 MACHINE_DISPLAY_WIDTH_PIXELS = "240"
 MACHINE_DISPLAY_HEIGHT_PIXELS = "320"
-MACHINE_FEATURES = "kernel26 touchscreen apm alsa irda usbgadget screen vfat"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa irda usbgadget screen vfat phone"
 
 #
 # Software/packages selection
index a577cc7..2ae1419 100644 (file)
@@ -15,7 +15,7 @@ VOLATILE_STORAGE_SIZE = "64"
 MACHINE_GUI_CLASS = "smallscreen"
 MACHINE_DISPLAY_WIDTH_PIXELS = "240"
 MACHINE_DISPLAY_HEIGHT_PIXELS = "240"
-MACHINE_FEATURES = "kernel26 touchscreen apm alsa irda usbgadget screen vfat"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa irda usbgadget screen vfat phone"
 
 #
 # Software/packages selection
index 0162472..b311afe 100644 (file)
@@ -9,7 +9,7 @@ PACKAGE_EXTRA_ARCHS = "armv4t armv5te"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-tornado-omap2"
 
-MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget vfat"
+MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget vfat phone"
 
 MACHINE_EXTRA_RDEPENDS = "alsa-state"
 
index 87571c0..da88b14 100644 (file)
@@ -11,8 +11,8 @@ PREFERRED_PROVIDER_virtual/kernel = "linux-ezx"
 #mtd2: 00580000 00020000 "VFM_Filesystem"
 #mtd3: 00020000 00020000 "Logo"
 
-MACHINE_FEATURES = "kernel26 touchscreen apm alsa bluetooth usbgadget usbhost keyboard screen"
-MACHINE_FEATURES += "iwmmxt"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa bluetooth usbgadget usbhost keyboard screen phone"
+MACHINE_FEATURES += " iwmmxt"
 
 
 MACHINE_DISPLAY_WIDTH_PIXELS = "240"
index 40ef6dd..8f2f793 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r56"
+PR = "r57"
 
 inherit task