subversion: Add version 1.4.5
authorMatthias Hentges <oe@hentges.net>
Thu, 29 Nov 2007 17:55:16 +0000 (17:55 +0000)
committerMatthias Hentges <oe@hentges.net>
Thu, 29 Nov 2007 17:55:16 +0000 (17:55 +0000)
packages/subversion/subversion_1.4.5.bb [new file with mode: 0644]

diff --git a/packages/subversion/subversion_1.4.5.bb b/packages/subversion/subversion_1.4.5.bb
new file mode 100644 (file)
index 0000000..1daf45b
--- /dev/null
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+PR = "r0"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+           file://disable-revision-install.patch;patch=1 \
+          file://neon-detection.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
+                --without-berkeley-db --without-apxs --without-apache \
+                --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+                --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+do_configure() {
+       gnu-configize
+       libtoolize --force
+       aclocal -I build/ -I build/ac-macros/ && autoconf
+       oe_runconf
+}
+
+do_stage() {
+       autotools_stage_all
+}