Busybox shell is not executing /etc/profile.d/* files, thus fixed.
authorKhem Raj <raj.khem@gmail.com>
Sat, 19 Apr 2008 19:51:28 +0000 (19:51 +0000)
committerKhem Raj <raj.khem@gmail.com>
Sat, 19 Apr 2008 19:51:28 +0000 (19:51 +0000)
packages/base-files/base-files/profile
packages/base-files/base-files_3.0.14.bb

index 3dc22f3..5797535 100644 (file)
@@ -20,8 +20,10 @@ if [ "$PS1" ]; then
 fi
 
 if [ -d /etc/profile.d ]; then
-  for i in `ls /etc/profile.d/`; do
-    . /etc/profile.d/$i
+  for i in /etc/profile.d/*.sh; do
+    if [ -r $i ]; then
+      . $i
+    fi
   done
   unset i
 fi
index 0391bea..83f6be3 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Miscellaneous files for the base system."
 SECTION = "base"
 PRIORITY = "required"
-PR = "r77"
+PR = "r78"
 LICENSE = "GPL"
 
 SRC_URI = " \