chumby-kernel: allow booting from USB disks (/dev/sda1)
authorJan Lübbe <jluebbe@debian.org>
Fri, 18 Jan 2008 02:48:44 +0000 (02:48 +0000)
committerJan Lübbe <jluebbe@debian.org>
Fri, 18 Jan 2008 02:48:44 +0000 (02:48 +0000)
packages/linux/chumby-kernel/defconfig
packages/linux/chumby-kernel_2.6.16-chumby-1.2.bb

index db836c1..9606510 100644 (file)
@@ -1004,8 +1004,8 @@ CONFIG_USB_MON=y
 #
 # File systems
 #
-# CONFIG_EXT2_FS is not set
-# CONFIG_EXT3_FS is not set
+CONFIG_EXT2_FS=y
+CONFIG_EXT3_FS=y
 # CONFIG_REISERFS_FS is not set
 # CONFIG_JFS_FS is not set
 # CONFIG_FS_POSIX_ACL is not set
index 89546e0..37fe9f1 100644 (file)
@@ -17,13 +17,12 @@ COMPATIBLE_HOST = 'arm.*-linux'
 
 ARCH = "arm"
 
-#CMDLINE_CONSOLE ?= "ttyS0,115200n8"
-#CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
-#CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
-#CMDLINE_ROOT = "root=/dev/mtdblock2 rootfstype=jffs2 console=ttyS0,115200 mem=64M"
-#CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
+# Use this CMDLINE for booting from RootFS 1 on the internal flash (22MB)
 CMDLINE = "console=ttyS0,38400 root=/dev/mtdblock5 rootfstype=jffs2 psplash=false"
 
+# Use this CMDLINE for booting from the first partition of an USB disk
+#CMDLINE = "console=ttyS0,38400 root=/dev/sda1 rootfstype=ext2 rootdelay=8 psplash=false"
+
 COMPATIBLE_MACHINE = "chumby"
 
 module_autoload_chumby_accel = "chumby_accel"