mplayer_1.0pre8.bb: Add a patch to hook up the imageon driver (making it
authorMatt Reimer <mattjreimer@gmail.com>
Mon, 27 Nov 2006 21:34:27 +0000 (21:34 +0000)
committerMatt Reimer <mattjreimer@gmail.com>
Mon, 27 Nov 2006 21:34:27 +0000 (21:34 +0000)
actually usable), and build the imageon driver for hx4700 as well.

packages/mplayer/files/imageon-video_out.patch [new file with mode: 0644]
packages/mplayer/mplayer_1.0pre8.bb

diff --git a/packages/mplayer/files/imageon-video_out.patch b/packages/mplayer/files/imageon-video_out.patch
new file mode 100644 (file)
index 0000000..fcb7953
--- /dev/null
@@ -0,0 +1,20 @@
+--- mplayer/libvo/video_out.c.orig     2006-11-27 12:49:51.000000000 -0800
++++ mplayer/libvo/video_out.c  2006-11-27 12:41:59.000000000 -0800
+@@ -87,6 +87,7 @@ extern vo_functions_t video_out_syncfb;
+ extern vo_functions_t video_out_fbdev;
+ extern vo_functions_t video_out_fbdev2;
+ extern vo_functions_t video_out_w100;
++extern vo_functions_t video_out_imageon;
+ extern vo_functions_t video_out_svga;
+ extern vo_functions_t video_out_png;
+ extern vo_functions_t video_out_ggi;
+@@ -200,6 +201,9 @@ vo_functions_t* video_out_drivers[] =
+ #ifdef HAVE_W100
+       &video_out_w100,
+ #endif
++#ifdef HAVE_IMAGEON
++      &video_out_imageon,
++#endif
+ #ifdef HAVE_SVGALIB
+       &video_out_svga,
+ #endif
index b5af659..c59c30e 100644 (file)
@@ -17,7 +17,8 @@ SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-${PV}.tar.bz2 \
            file://libmpdemux-ogg-include.patch;patch=1 \
            file://libmpcodecs-ogg-include.patch;patch=1 \
            file://pld-onlyarm5.patch;patch=1 \
-           ${SOURCEFORGE_MIRROR}/libw100/mplayer-imageon.patch;patch=1"
+           ${SOURCEFORGE_MIRROR}/libw100/mplayer-imageon.patch;patch=1 \
+           file://imageon-video_out.patch;patch=1"
 
 RCONFLICTS_${PN} = "mplayer-atty"
 RREPLACES_${PN} = "mplayer-atty"
@@ -26,6 +27,7 @@ PR = "r3"
 PARALLEL_MAKE = ""
 
 DEPENDS_append_c7x0 = " sharp-aticore-oss libw100 "
+DEPENDS_append_hx4700 = " libw100 "
 
 S = "${WORKDIR}/MPlayer-${PV}"
 
@@ -168,6 +170,7 @@ EXTRA_OECONF = " \
         "
 
 EXTRA_OECONF_append_c7x0 = " --enable-w100 --enable-imageon "
+EXTRA_OECONF_append_hx4700 = " --enable-imageon "
 
 do_configure() {
        cp ${WORKDIR}/vo_w100.c ${S}/libvo