gnome-keyring: update to 2.26, adjust packaging accordingly
authorKoen Kooi <koen@openembedded.org>
Sat, 28 Mar 2009 10:18:14 +0000 (11:18 +0100)
committerKoen Kooi <koen@openembedded.org>
Sat, 28 Mar 2009 10:18:14 +0000 (11:18 +0100)
conf/checksums.ini
recipes/gnome/gnome-keyring_2.26.0.bb [new file with mode: 0644]

index b74d8f7..1dfebde 100644 (file)
@@ -7886,6 +7886,10 @@ sha256=70752dc8b33930655b82392e4f149f93bedf6cbc640b30dcfcf986d43470b306
 md5=aa5552dc129f3509ee39145b7f0bf977
 sha256=3c9eb7f45dd0026340635b9e1ee18c36a47541610aa5a7ef604ca645aa4763f9
 
+[http://ftp.gnome.org/pub/GNOME/sources/gnome-keyring/2.26/gnome-keyring-2.26.0.tar.bz2]
+md5=0395fcf79b990465030a2795dcddacb9
+sha256=7acda11db2eb07b2f68a1a506203fe95141954acb10c394850418fd04ed80a07
+
 [http://ftp.gnome.org/pub/GNOME/sources/gnome-menus/2.10/gnome-menus-2.10.2.tar.bz2]
 md5=97b0ad03ea219cc8f5c02585db1d237e
 sha256=0968a399590d94cf9e1640b647cc10f972a3a802cbd9602c0839f56fd2864193
diff --git a/recipes/gnome/gnome-keyring_2.26.0.bb b/recipes/gnome/gnome-keyring_2.26.0.bb
new file mode 100644 (file)
index 0000000..8259ac9
--- /dev/null
@@ -0,0 +1,28 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+
+inherit autotools gnome pkgconfig
+
+DEPENDS = "gtk+ libtasn1 libgcrypt"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service"
+
+do_configure_prepend() {
+       cp ${WORKDIR}/tasn.m4 acinclude.m4
+}
+
+do_install_append () {
+       install -d ${D}${datadir}/dbus-1/services
+       install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
+PACKAGES =+ "gnome-keyring-pam-plugin"
+FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
+
+do_stage() {
+        autotools_stage_all
+}