python-pycurl 7.16.4 update to 7.18.2; use dynamic linking
authorMichael Lauer <mickey@vanille-media.de>
Sat, 9 Aug 2008 19:56:57 +0000 (19:56 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Sat, 9 Aug 2008 19:56:57 +0000 (19:56 +0000)
packages/python/python-pycurl/.mtn2git_empty [new file with mode: 0644]
packages/python/python-pycurl/no-static-link.patch [new file with mode: 0644]
packages/python/python-pycurl_7.16.4.bb [deleted file]
packages/python/python-pycurl_7.18.2.bb [new file with mode: 0644]

diff --git a/packages/python/python-pycurl/.mtn2git_empty b/packages/python/python-pycurl/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/python/python-pycurl/no-static-link.patch b/packages/python/python-pycurl/no-static-link.patch
new file mode 100644 (file)
index 0000000..b7c5ab9
--- /dev/null
@@ -0,0 +1,14 @@
+Index: pycurl-7.18.2/setup.py
+===================================================================
+--- pycurl-7.18.2.orig/setup.py
++++ pycurl-7.18.2/setup.py
+@@ -97,8 +97,7 @@ else:
+         else:
+             extra_compile_args.append(e)
+     libs = split_quoted(
+-        os.popen("'%s' --libs" % CURL_CONFIG).read()+\
+-        os.popen("'%s' --static-libs" % CURL_CONFIG).read())
++        os.popen("'%s' --libs" % CURL_CONFIG).read())
+     for e in libs:
+         if e[:2] == "-l":
+             libraries.append(e[2:])
diff --git a/packages/python/python-pycurl_7.16.4.bb b/packages/python/python-pycurl_7.16.4.bb
deleted file mode 100644 (file)
index a9480ad..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "libcurl Python Bindings"
-SECTION = "devel/python"
-PRIORITY = "optional"
-LICENSE = "LGPL"
-RDEPENDS = "python-core curl (>=${PV})"
-DEPENDS = "curl-${PV}"
-SRCNAME = "pycurl"
-
-SRC_URI = "http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit distutils
diff --git a/packages/python/python-pycurl_7.18.2.bb b/packages/python/python-pycurl_7.18.2.bb
new file mode 100644 (file)
index 0000000..406add1
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "libcurl Python Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "curl-${PV}"
+SRCNAME = "pycurl"
+PR = "ml0"
+
+SRC_URI = "\
+  http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz \
+  file://no-static-link.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_append() {
+       mv -f ${D}${datadir}/share/* ${D}${datadir}/
+}
+
+RDEPENDS = "python-core curl (>=${PV})"