xdg-user-dirs: add 0.10 (from poky)
authorKoen Kooi <koen@openembedded.org>
Sun, 31 May 2009 14:44:41 +0000 (16:44 +0200)
committerKoen Kooi <koen@openembedded.org>
Sun, 31 May 2009 14:44:41 +0000 (16:44 +0200)
recipes/xdg-user-dirs/xdg-user-dirs/configurefix.patch [new file with mode: 0644]
recipes/xdg-user-dirs/xdg-user-dirs_0.10.bb [new file with mode: 0644]

diff --git a/recipes/xdg-user-dirs/xdg-user-dirs/configurefix.patch b/recipes/xdg-user-dirs/xdg-user-dirs/configurefix.patch
new file mode 100644 (file)
index 0000000..576cdde
--- /dev/null
@@ -0,0 +1,18 @@
+The AM_DISABLE_STATIC appears to pull in strange libtool junk so just remove it.
+
+RP - 27/5/09
+
+Index: xdg-user-dirs-0.10/configure.ac
+===================================================================
+--- xdg-user-dirs-0.10.orig/configure.ac       2009-05-27 22:27:20.000000000 +0100
++++ xdg-user-dirs-0.10/configure.ac    2009-05-27 22:27:28.000000000 +0100
+@@ -13,8 +13,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+-AM_PROG_MKDIR_P       
+-AM_DISABLE_STATIC
++AM_PROG_MKDIR_P
+ AM_ICONV
+ GETTEXT_PACKAGE=xdg-user-dirs
diff --git a/recipes/xdg-user-dirs/xdg-user-dirs_0.10.bb b/recipes/xdg-user-dirs/xdg-user-dirs_0.10.bb
new file mode 100644 (file)
index 0000000..2ea08b6
--- /dev/null
@@ -0,0 +1,11 @@
+DESCRIPTION = "xdg-user-dirs is a tool to help manage user directories like the desktop folder and the music folder"
+SRC_URI = "http://user-dirs.freedesktop.org/releases/xdg-user-dirs-0.10.tar.gz \
+           file://configurefix.patch;patch=1 "
+PR = "r1"
+
+inherit autotools_stage
+
+do_install_append () {
+       install -d ${D}${sysconfdir}/skel/.config/
+       mv ${D}${sysconfdir}/xdg/user-dirs.defaults ${D}${sysconfdir}/skel/.config/user-dirs.dirs
+}