man: GNU_HASH QA fix.
authorStanislav Brabec <utx@penguin.cz>
Thu, 23 Apr 2009 21:06:44 +0000 (21:06 +0000)
committerutx@penguin.cz <utx@penguin.cz>
Thu, 23 Apr 2009 21:06:44 +0000 (21:06 +0000)
recipes/man/man_1.5p.bb

index 2a1ed7f..c3412a5 100644 (file)
@@ -14,13 +14,14 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/man/man-${PV}.tar.bz2 \
 # Disable parallel make or it tries to link objects before they are built
 PARALLEL_MAKE = ""
 
-EXTRA_OEMAKE = ""
+EXTRA_OEMAKE = 'LFDLAGS="${LDFLAGS}"'
 GS = "-DGREPSILENT=\"q\""
 DEFS = "-DUSG -DDO_COMPRESS ${GS}"
 
 do_configure() {
        # this doesn't support cross compilation, so it generates a
        # bogus configuration
+       sed -i /^LDFLAGS/d src/Makefile.in
        ./configure -d -confdir ${sysconfdir}
 }